Contribute
Register

Intel NUC8i5BEK Catalina Install Issues - IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0

Joined
Jul 16, 2020
Messages
8
Motherboard
Intel NUC8i5BEK
CPU
Intel i5-8259U
Graphics
Intel Iris Plus Graphics 655
Mac
  1. MacBook Pro
Hey everyone,

I recently bought an off-the-shelf Intel NUC8i5BEK to Hackintosh, and I'm completely new this. So I must say the one thing Apple DOES have, still, is the "it just works" thing :) Most of the time, these days...

So far I've used the basic Unibeast guide to get through to the very end of Step 4, but on reboot from the new option "MacOS Catalina" which shows up in Clover after the installation process seems to have happened, I am running into an error: "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0"

I have adopted a folder from BlackHack13 with kexts to start with, and added some fixes as patchwork along the way. Currently trying with boot flags "-x", "-f", "-disablegfxfirmware", and "dart=0". Though I had the same issue before using these as well, has not changed anything. I'm also using a USB2.0 hub currently to alleviate an issue I was having with scrambled graphics. I will include my EFI folder to make it easier to diagnose.

My sense is that a graphics issue is the difficulty here, and I'm just using the integrated Iris 655 graphics, don't have any other graphics card or want one.

If anyone can help me fix this it would be much appreciated!
 

Attachments

  • EFI.zip
    21.6 MB · Views: 39
  • IMG_1820.jpg
    IMG_1820.jpg
    3.2 MB · Views: 109

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,836
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I am running into an error: "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0"
That's not an error - It is quite normal but things usually progress beyond that stage.
The fact that it hangs there indicates a graphics problem.

Clover needs updating.

Booting in safe mode runs with a minimal selection of kexts and may serve to only mask the real problem.

The developer of OsxAptioFix2Drv-free2000.efi has warned against its use and asserts that it may damage hardware.
 
Joined
Jul 16, 2020
Messages
8
Motherboard
Intel NUC8i5BEK
CPU
Intel i5-8259U
Graphics
Intel Iris Plus Graphics 655
Mac
  1. MacBook Pro
That's not an error - It is quite normal but things usually progress beyond that stage.
The fact that it hangs there indicates a graphics problem.

Clover needs updating.

Booting in safe mode runs with a minimal selection of kexts and may serve to only mask the real problem.

The developer of OsxAptioFix2Drv-free2000.efi has warned against its use and asserts that it may damage hardware.

What would you recommend I do then? Do I just replace CLOVERX64.efi with the newer one in my EFI folder, and replace OscAptioFix2Drv-free2000.efi with the previous AptioMemoryFix.efi?
 
Joined
Jul 16, 2020
Messages
8
Motherboard
Intel NUC8i5BEK
CPU
Intel i5-8259U
Graphics
Intel Iris Plus Graphics 655
Mac
  1. MacBook Pro
That's not an error - It is quite normal but things usually progress beyond that stage.
The fact that it hangs there indicates a graphics problem.

Clover needs updating.

Booting in safe mode runs with a minimal selection of kexts and may serve to only mask the real problem.

The developer of OsxAptioFix2Drv-free2000.efi has warned against its use and asserts that it may damage hardware.

So I went ahead and updated Clover Bootloader using Clover Configurator's Install/Update function (to build v5.0 r5119), and also replaced OsxAptioFix2Drv-free2000.efi with the original AptioMemoryFix.

I made a few small tweaks as well but nothing has worked so far, or even made any change to the verbose read-out whatsoever. Stuck at same point still.

Uploading EFI folder again for reference. Help needed!
 

Attachments

  • EFI.zip
    22.1 MB · Views: 48

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,836
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Joined
Jul 16, 2020
Messages
8
Motherboard
Intel NUC8i5BEK
CPU
Intel i5-8259U
Graphics
Intel Iris Plus Graphics 655
Mac
  1. MacBook Pro
Despite previous advice you are still booting in safe mode.

Hi, I removed the safe mode boot option (as well as -f because I found it on a different thread and don't even see it in the clover configurator context menu)- but I'm still stuck at the same point.

Anything else I should try?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,836
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Anything else I should try?

Ensure that the DVMT setting is at least 64MB.
Remove graphics settings from config.plist and leave graphics to Lilu/WhateverGreen.kext.
It may be that graphics are working but on a different port than the one that you have connected to the monitor.

Use the forum Search tool to find a NUC8 guide to follow.
 
Last edited:
Joined
Jul 16, 2020
Messages
8
Motherboard
Intel NUC8i5BEK
CPU
Intel i5-8259U
Graphics
Intel Iris Plus Graphics 655
Mac
  1. MacBook Pro
Ensure that the DVMT setting is at least 64MB.
Remove graphics settings from config.plist and leave graphics to Lilu/WhateverGreen.kext.
It may be that graphics are working but on a different port than the one that you have connected to the monitor.

Use the forum Search tool to find a NUC8 guide to follow.

That worked!! Thank you so much. I was able to get into Catalina and set up MacOS. However, my clover bootloader hasn't been showing the MacOS Catalina option, but I did this boot from the "Filevault Prebooter from Preboot" option, which does seem to work. Is this any cause for concern?

Now I have to figure out post-installation and getting it to boot from SSD. I'd like to use MultiBeast for this, but want to make sure I'm selecting the right drivers, options, etc. Is there a good resource or guidelines for doing this? The guide that I linked to the earlier, the standard one, kind of glosses over this part.
 
Joined
Jul 16, 2020
Messages
8
Motherboard
Intel NUC8i5BEK
CPU
Intel i5-8259U
Graphics
Intel Iris Plus Graphics 655
Mac
  1. MacBook Pro

Unfortunately, I'm already stuck just at trying to get Multibeast to work in starting the post-installation process / installing to the SSD. I'm getting a 'could not install' error which I believe is caused by SIP being enabled.

Of course, I cannot disable SIP from the regular Catalina boot on my USB, but I'm also not able to boot from Recovery at all which would allow me to disable SIP. I just get a bunch of seemingly APFS and HFS-related, Forcing CS_RUNTIME, and maybe a few Legacy Shim messages before total crash and reboot.

Furthermore, when I try the method of disabling SIP that involves setting the Rt Variables / CsrActiveConfig values in config.plist, I then get crashes trying to boot up the regular mode for Catalina off the USB as well.

My EFI should be the same as the last one above, although with the Graphics options removed, if anyone can help.
 
Top