Contribute
Register

Intel NUC 10 Frost Canyon

Joined
Jul 15, 2020
Messages
17
Motherboard
Intel NUC 10
CPU
i7-10710U
Graphics
Intel UHD 630
One last question, when you say hangs on boot what do you mean? A Black Screen or the the text output using -v boot argument stops (verbose boot)? If so did you add the boot argument needed for most 5700Xt cards "agdpmod=pikera"

While the Razor Core is connected and its booting up..it hangs and it performs a kernel dump. I attached a screenshot of it.
I tried adding the boot argument that you mention and got the same result, it hangs while booting.

Also when it successfully boots without the eGPU. I connect the eGPU to the NUC and the mouse cursor freezes completely, the fan ramps up to high and the HDD activity lights begins to flash continously. I have to unplug the eGPU and do a manual reboot to get Mac OS working again. Thanks for your help with this.
 

Attachments

  • 1.jpg
    1.jpg
    4.5 MB · Views: 22
  • 2.jpg
    2.jpg
    3.9 MB · Views: 19
Joined
Feb 21, 2010
Messages
2,290
Motherboard
Asus Rog Strix Z490 Gaming E
CPU
i9-10900K
Graphics
5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. Android
My nuc10 i3 is woking happily except the 4k resolutions. I can only get full HD. Any help to get the full res?
I don't know this for a fact but since there is no Apple driver for Intel UHD Graphics for 10th Gen Intel Processors it gets complicated. Instead we have to use the generic 07009B3E Device ID recommended by the OpenCore developers and that may be the issue.
 
Joined
Feb 21, 2010
Messages
2,290
Motherboard
Asus Rog Strix Z490 Gaming E
CPU
i9-10900K
Graphics
5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. Android
While the Razor Core is connected and its booting up..it hangs and it performs a kernel dump. I attached a screenshot of it.
I tried adding the boot argument that you mention and got the same result, it hangs while booting.

Also when it successfully boots without the eGPU. I connect the eGPU to the NUC and the mouse cursor freezes completely, the fan ramps up to high and the HDD activity lights begins to flash continously. I have to unplug the eGPU and do a manual reboot to get Mac OS working again. Thanks for your help with this.
Okay, is the version of Razor Core you are using supported by Apple?
 
Joined
Jul 15, 2020
Messages
17
Motherboard
Intel NUC 10
CPU
i7-10710U
Graphics
Intel UHD 630
Okay, is the version of Razor Core you are using supported by Apple?

Yep, officially it does list it on its website as supported, just plug and play via the USB Type C Thunderbolt 3 port
https://support.apple.com/en-us/HT208544

When I google around razor core + hackintosh, they are post that report it works successfully like a real Mac including the plug and play aspect..but haven't found anything for my specific hardware (Radeon RX 5700 + NUC10i7 + Razor Core X) that works..maybe its just not compatible or I need some very specific fix, kext or something..
 
Joined
Mar 13, 2012
Messages
71
Motherboard
Gigabyte GA-Z68MA-D2H
CPU
i3-2105
Graphics
HD 3000
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Anybody tried to update to 10.15.7?
 
Top