Contribute
Register

Intel NUC 10 Frost Canyon

Joined
Jul 31, 2020
Messages
29
Motherboard
NUC10
CPU
i7-10710U
Graphics
Intel UHD Graphics 630
I have not. But I must admit I'm very skeptical about this approach. The very old thread at https://embdev.net/topic/284710 shows that the problem occurs/ed even on Apple hardware, and appeared when users upgraded to 10.8 or later and were using a Dell monitor (mostly).
I've the problem on my Dell U2413 (made circa 2013), but not on a Dell P2418D (born in 2018). Too bad the fix consisting in an override of the display properties won't work anymore.

edit: I've plugged on the rear USB-C port a Dell adapter with USB-A/Eth/VGA/HDMI (DA200) and plugged my display to this adapter instead of NUC's HDMI port: same result, HDMI input is forced into YPbPr instead of RGB during the boot process.
Only difference is that a reboot of the NUC let me see the full boot process (boot loader menu, verbose boot) instead of a black screen until login screen pops up.
 
Last edited:

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,854
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have not. But I must admit I'm very skeptical about this approach. The very old thread at https://embdev.net/topic/284710 shows that the problem occurs/ed even on Apple hardware, and appeared when users upgraded to 10.8 or later and were using a Dell monitor (mostly).
I've the problem on my Dell U2413 (made circa 2013), but not on a Dell P2418D (born in 2018). Too bad the fix consisting in an override of the display properties won't work anymore.
It's just a suggestion, as you say it is a very old thread. Is your monitor that old? Its a very unusual issue, I scanned the link you posted and it maybe possible to add to the Device properties for the intel graphics to include the EEID Fix.
 
Last edited:

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,854
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I have not. But I must admit I'm very skeptical about this approach. The very old thread at https://embdev.net/topic/284710 shows that the problem occurs/ed even on Apple hardware, and appeared when users upgraded to 10.8 or later and were using a Dell monitor (mostly).
I've the problem on my Dell U2413 (made circa 2013), but not on a Dell P2418D (born in 2018). Too bad the fix consisting in an override of the display properties won't work anymore.

edit: I've plugged on the rear USB-C port a Dell adapter with USB-A/Eth/VGA/HDMI (DA200) and plugged my display to this adapter instead of NUC's HDMI port: same result, HDMI input is forced into YPbPr instead of RGB during the boot process.
Only difference is that a reboot of the NUC let me see the full boot process (boot loader menu, verbose boot) instead of a black screen until login screen pops up.
Time for a newer monitor :shifty:
 
Joined
Jul 31, 2020
Messages
29
Motherboard
NUC10
CPU
i7-10710U
Graphics
Intel UHD Graphics 630
Time for a newer monitor :shifty:
Not that simple as I need a monitor with very good image quality and 4 inputs. Mine currently have DP, mDP, HDMI, DVI. I could go with any combination of DPs and HDMIs but I need a total of 4. The display also have to be "small", 24 or 25" max. I'll leave this problem for later :)
 
Joined
Sep 14, 2019
Messages
42
Motherboard
Intel NUC10i7FNB
CPU
i7-10710U
Graphics
UHD GT2

FNCML357.0044.2020.0715.1813
 
Joined
Oct 11, 2012
Messages
92
Motherboard
Asus N552VX-FW131T
CPU
i7-6700HQ
Graphics
HD 530 + GT 950m, 1920x1080
Ax201 is now supported with OpenIntelWireless
.
Can you check it?
 
Joined
Sep 14, 2019
Messages
42
Motherboard
Intel NUC10i7FNB
CPU
i7-10710U
Graphics
UHD GT2

Attachments

  • EFI-0.6.0.zip
    12.8 MB · Views: 342
Last edited:
Joined
Jul 15, 2020
Messages
25
Motherboard
Intel NUC 10
CPU
i7-10710U
Graphics
UHD 630
I would like to share some benchmarks of NUC10i7 (Intel Core i7-10710U) running Catalina.
Cinebench R15 gives about 30 fps, about half what I got from a venerable Radeon 5770 Mac Edition hooked to a macOS VM. Cinebench CPU score is very good though. I did not expect that much.
Motionmark is a browser benchmark, I've ran it in a fresh Firefox 79 install.

View attachment 482468 View attachment 482467

I couldn't find Cinebench R15 so I used R20 instead. The major difference I see is that I have hypertreating disable. Also I have SMCProcessor Kext, don't know if that has any impact on performance.
 

Attachments

  • Screen Shot 2020-08-02 at 1.30.01 PM.png
    Screen Shot 2020-08-02 at 1.30.01 PM.png
    101 KB · Views: 36
  • Screen Shot 2020-08-02 at 1.37.31 PM.png
    Screen Shot 2020-08-02 at 1.37.31 PM.png
    136.6 KB · Views: 43
Joined
Jul 15, 2020
Messages
25
Motherboard
Intel NUC 10
CPU
i7-10710U
Graphics
UHD 630
Ax201 is now supported with OpenIntelWireless
.
Can you check it?

Yep, it works. I got the NUC10i7FNH. My slow speeds is probably because I am far away from the router and using 5Ghz. It connects and works more importantly.
 

Attachments

  • Screen Shot 2020-08-02 at 2.00.07 PM.png
    Screen Shot 2020-08-02 at 2.00.07 PM.png
    79 KB · Views: 129
  • Screen Shot 2020-08-02 at 2.01.20 PM.png
    Screen Shot 2020-08-02 at 2.01.20 PM.png
    200.7 KB · Views: 132
Top