Contribute
Register

Intel NUC 10 Frost Canyon

Joined
Nov 23, 2010
Messages
530
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
They removed it

yes. they did the same with the 0041 ver.
guys any way for the thunderbolt hot-plug? I tried the ssdt found on this thread. but it freezes my hack using egpu expander
 
Joined
Sep 14, 2019
Messages
42
Motherboard
Intel NUC10i7FNB
CPU
i7-10710U
Graphics
UHD GT2
I'm currently on 0043, updated from 0041... Fully working with Windows 10, MX Linux, Debian, Fedora, Manjaro, POP!OS and Mint on my Multiboot NUC(intosh) ;-) ... and sometime macOS will 100% working, too
 

Attachments

  • BIOS Update [FNCML357].pdf
    610.4 KB · Views: 24
Last edited:
Joined
Nov 23, 2010
Messages
530
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm currently on 0043, updated from 0041... Fully working with Windows 10, MX Linux, Debian, Fedora, Manjaro, POP!OS and Mint on my Multiboot NUC(intosh) ;-) ... and sometime macOS will 100% working, too

not available anymore.
ps did anybody upgrade to 10.15.6? any issue?
 
Joined
Jul 8, 2019
Messages
38
Motherboard
NUC10i7FNB
CPU
Intel CPUi7-10710U
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Thanks for the suggestion. I did, while Mac OS is on, I turn the HDMI monitor on/off multiple times, after I do it seems the monitor disappears from the entry of output devices. I restarted also multiple times and neither the HDMI nor headphone audio works...I am still trying different versions of AppleALC (I am placing them on the hard drive boot efi -> oc -> kexts folder, and reboot each time. Also changing the alcid= to different numbers on my config.plist and reboot and hopefully some of this options does work (either HDMI or headphones I will be happy, all else works nicely). Thanks for the help.


I am wondering if the layouts for AppleAlc are impacted by the model. For example, maybe we want to be a 2018 Mac Mini and not a 2019 iMac in SMBIOS?
 
Last edited:
Joined
Jul 15, 2020
Messages
17
Motherboard
Intel NUC 10
CPU
i7-10710U
Graphics
Intel UHD 630
I am wondering if the layouts for AppleAlc are impacted by the model. For example, maybe we want to be a 2018 Mac Mini and not a 2019 iMac in SMBIOS?

Sound works!! I am using VoodooHDA instead. I went to read this whole post and try the steps on post#103.
Reboot it, using headphones and I click the sound icon and hear the sound. Also YouTube videos play and sound works too.
On your answer, I am using techynolli EFI, which uses macmini8,1 as system model.
 

Attachments

  • Screen Shot 2020-07-16 at 4.11.15 PM.png
    Screen Shot 2020-07-16 at 4.11.15 PM.png
    103.4 KB · Views: 49
  • Screen Shot 2020-07-16 at 4.13.06 PM.png
    Screen Shot 2020-07-16 at 4.13.06 PM.png
    131.1 KB · Views: 49
Joined
Jul 15, 2020
Messages
17
Motherboard
Intel NUC 10
CPU
i7-10710U
Graphics
Intel UHD 630
Sound works!! I am using VoodooHDA instead. I went to read this whole post and try the steps on post#103.
Reboot it, using headphones and I click the sound icon and hear the sound. Also YouTube videos play and sound works too.
On your answer, I am using techynolli EFI, which uses macmini8,1 as system model.

To add to this, I found a cleaner approach. Instead of adding the AppleHDADisabler, simply add the -alcoff to the config file under NVRAM├── Add ├── 7C436110-AB2A-4BBB-A880-FE41995C9F82 boot-args section. It does the same thing but without the need of an additional kext. So far audio via headphones working good.
 
Joined
Jul 8, 2019
Messages
38
Motherboard
NUC10i7FNB
CPU
Intel CPUi7-10710U
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
To add to this, I found a cleaner approach. Instead of adding the AppleHDADisabler, simply add the -alcoff to the config file under NVRAM├── Add ├── 7C436110-AB2A-4BBB-A880-FE41995C9F82 boot-args section. It does the same thing but without the need of an additional kext. So far audio via headphones working good.

Does it still work when you disconnect/reconnect HDMI?
 
Joined
Jul 15, 2020
Messages
17
Motherboard
Intel NUC 10
CPU
i7-10710U
Graphics
Intel UHD 630
Does it still work when you disconnect/reconnect HDMI?

Oh, wow. HDMI audio works too. No need to turn on/off/ disconnect/reconnect the HDMI monitor. I selected it on the audio and YouTube video play and audio works as well as system sounds. Thanks!
 

Attachments

  • Screen Shot 2020-07-16 at 5.03.33 PM.png
    Screen Shot 2020-07-16 at 5.03.33 PM.png
    291.1 KB · Views: 45
Joined
Jul 8, 2019
Messages
38
Motherboard
NUC10i7FNB
CPU
Intel CPUi7-10710U
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Oh, wow. HDMI audio works too. No need to turn on/off/ disconnect/reconnect the HDMI monitor. I selected it on the audio and YouTube video play and audio works as well as system sounds. Thanks!
VoodoHDA works initially, but I have an HDMI KVM. If I switch to another computer and then back, it fails. So if you disconnect HDMI after boot, then reconnect, does it still work? Is it still working if you do that several times successively?
 
Joined
Jul 15, 2020
Messages
17
Motherboard
Intel NUC 10
CPU
i7-10710U
Graphics
Intel UHD 630
VoodoHDA works initially, but I have an HDMI KVM. If I switch to another computer and then back, it fails. So if you disconnect HDMI after boot, then reconnect, does it still work? Is it still working if you do that several times successively?

Ah, okay, I get you..sorry, I didn't understand initially.
I unplug and reconnect the HDMI, the HDMI interface still there however no audio plays. I change it back to headphones, the headphones work normally..however change it back to HDMI, still no audio. I have to do a restart then HDMI starts working again. This applies when I turn on/off the monitor and when I connect/disconnect the HDMI cable.
 
Top