Contribute
Register

Intel i5-9600K 7MB UHD 630.

Joined
Feb 28, 2019
Messages
12
Motherboard
ASRock Z390 Phantom Gaming 4
CPU
i5-9600K
Graphics
RTX 2070
Mobile Phone
  1. Android
Hello,

For the past 2 weeks I've spent so many hours trying different Device ID and platforms ids, tried headkaze Intel patching, and many guides more. Unfortunately I couldn't get it to work properly. So now I hope you can help me.

The display is currently on 1920x1080, connected to HDMI on RTX 2070.

About this Mac capture:
394858


As of now Intel Device ID is set to nothing, as well as the platform ID.
I'll post my EFI as well.

Thanks.
 
Last edited:
Joined
Mar 24, 2019
Messages
2
Motherboard
Gigabyte Z390 M Gaming
CPU
i5-9600k
Graphics
Intel UHD Graphics 630
Besides not using the eGPU, I have exactly the same setup as you do. I've found using WhateverGreen updates the graphics from "Display 7 MB" to "Intel UHD Graphics 630 7 MB". However, I haven't found a solution yet. I think our best bet is this thread. If you find a solution, please report it here. I'll be sure to do the same!

EDIT: The solution worked for me! I hope it does for you as well :)
 
Last edited:
Joined
Feb 28, 2019
Messages
12
Motherboard
ASRock Z390 Phantom Gaming 4
CPU
i5-9600K
Graphics
RTX 2070
Mobile Phone
  1. Android
Besides not using the eGPU, I have exactly the same setup as you do. I've found using WhateverGreen updates the graphics from "Display 7 MB" to "Intel UHD Graphics 630 7 MB". However, I haven't found a solution yet. I think our best bet is this thread. If you find a solution, please report it here. I'll be sure to do the same!

EDIT: The solution worked for me! I hope it does for you as well :)
Would you mind sharing your EFI please?
Thanks!

Edit: noticed your setup isn't exactly like mine.
My motherboard is an AsRock, yours is Gigabyte.

Thanks anyway. Although I'd appreciate if you could tell me the device and platform id.

After setting device id to 0x59128086 and platform id 0x59120000 it does seem to detect the igpu but doesn't boot.


IMG_20190325_102532.jpg
 
Last edited:
Joined
Mar 24, 2019
Messages
2
Motherboard
Gigabyte Z390 M Gaming
CPU
i5-9600k
Graphics
Intel UHD Graphics 630
Yeah, I'm sorry, there is no pre compiled patch for your MB, so I guess it will be a bit more difficult. I'm using the iMac18,1, with platform-id 07009B3E. I'm leaving the IntelGFX fake id empty as well.
 
Top