Contribute
Register

Intel I225-V Connection issue!!

Status
Not open for further replies.
Joined
Nov 1, 2010
Messages
85
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700K
Graphics
GTX 980 TI
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I have Gigabyte z490 aorus ultra with intel i225-v and the network card works but has a connection issue. keep going in and out.
I was searching on the web and found out that i225-v having a lot of issues. Does anyone having the same issue???
 
Joined
Jul 31, 2015
Messages
81
Motherboard
Z490 Vision G
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
If you don't need the 2.5 Gbps speeds, then manually set your network to 1000BASE-T in network preferences to resolve the connectivity issues.

If you need the 2.5 Gbps speeds, then i225 (v1 and maybe v2) is defective by design so your only permanent solution is to get a replacement motherboard with the latest revision of i225 chips. As far as I can remember, the permanently fixed version of i225 will not enter the consumer market before early 2021.
 
Joined
Nov 19, 2013
Messages
52
Motherboard
Aorus z370 gaming 5
CPU
i7 8700k
Graphics
gtx 1080ti
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I have Gigabyte z490 aorus ultra with intel i225-v and the network card works but has a connection issue. keep going in and out.
I was searching on the web and found out that i225-v having a lot of issues. Does anyone having the same issue???
do you have fakepci and fakepcii225 in your OC?
do you have any ethernet driver in your kexts? if so, which one?
 
Joined
Feb 4, 2011
Messages
197
Motherboard
ASUS Prime Z490-A
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have this same network card and I cant get it to show up in Big Sur. What do I need to do?
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
7,184
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Here is a solution for ASUS PRIME Z490-A I225-V on Clover:

 
Status
Not open for further replies.
Top