Contribute
Register

Intel I-225V ethernet not working

Status
Not open for further replies.
Joined
Nov 16, 2020
Messages
8
Motherboard
Asus b550-e
CPU
Ryzen 9 3900X
Graphics
Sapphire RX580 4GB
Hello guys, after quite some time I decided to make an hackintosh again using my current rig. I have an Asus B550-E motherboard which has an Intel I-225V network card. Online I found two kexts that could help me (FakePcIIID & FakePCIID_Intel_I225-V) and as read on the opencore guide I inserted this: PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0,0x0) with device id F2150000. But this does not work at all, I just get into the recovery, click install and it says that it needs an internet connection... I attached the EFI folder.
Could you help me?


Thanks to everyone!
 

Attachments

  • EFI.zip
    2.4 MB · Views: 155
Joined
Jul 23, 2012
Messages
803
Motherboard
GA-Z77N-WIFI-F3-Clover
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
  1. Mac mini
Screen Shot 2021-03-18 at 12.30.52.png


PciRoot(0x0)/Pci(0x1C,0x1)/Pci(0x0,0x0) with device id F2150000. ? F3150000 ?
 
Joined
Nov 16, 2020
Messages
8
Motherboard
Asus b550-e
CPU
Ryzen 9 3900X
Graphics
Sapphire RX580 4GB
Sorry for the late reply, so... I've got some other problems now, I can get into the boot selector but after selecting macOS I just get a black screen, I didn't change anything as far as I remember
 
Last edited:
Joined
Nov 16, 2020
Messages
8
Motherboard
Asus b550-e
CPU
Ryzen 9 3900X
Graphics
Sapphire RX580 4GB


Now it reboots after "pci (build 23:59:13 jan 20 2021), flags 0x20c3080"
 
Last edited:
Joined
Sep 3, 2021
Messages
1
Motherboard
Asus TUF X570 Gaming PRO
CPU
Ryzen 5800X
Graphics
Sapphire Nitro+ RX570 8GB
Hi.
I have an I225-V on my motherboard and I was looking for the kext for it.
What I found in the forum is this:
"If you're on Big Sur 11.3+ you can just use dk.e1000=0 boot-arg in order to enable the I225-V LAN card"
 
Status
Not open for further replies.
Top