Contribute
Register

Intel HD Graphics 4600 7 MB

Status
Not open for further replies.
Joined
Oct 12, 2017
Messages
3
I installed high sierra 10.13.5 on my hackintosh.

My device:
brand: ASUS
Motheboard : Z97
CPU: core i7 4770
RAM : 16G
Graphics: Hd4600
connector: (originally VGA) HDMI to HDMI cable + HDMI to DVI converter.

configuration:
- I copied following files to "kexts/others/".
AppleALC.kext, AppleIntelE1000e.kext, AtherosE2200Ethernet.kext, CodecCommander.kext, FakeSMC_ACPISensors.kext, FakeSMC_CPUSensors.kext, FakeSMC_GPUSensors.kext, FakeSMC_LPCSensors.kext, FakeSMC.kext, IntelGraphicsFixup.kext, IntelMausiEtherent-v2.2.0.zip, IntelMausiEthernet.kext Lilu.kext NullCPUPowerManagement.kext, NvidiaGraphicsFixup.kext, RealtekRTL8111.kext, Shik.kext, uSBInjectAll.kext, VooodooPS2Controller.kext, WhateverGreen.kext, XHCI-200-series-injector.kext

- I edited "config.plist"
boot: dart=0, nv_disable=1
devices: intelGFX=0
graphics: injectEDID=true, injectIntel=true, ig-platform-id=0x0d220003

- drivers64UEFI
apfs.efi, AppleImageCodec-64.efi, AppleKeyAggregator-64.eft, AppleUITheme-64.efi, DataHubDxe-64.efi, EmuVariableUefi-64.efi, FirmwareVolume-64.efi, FSinject-64.efi, OsxAptioFix2Drv-64.efi, OsxFatBinaryDrv-64.efi, SMCHelper-64.efi, VBoxHfs-64.efi

- CMOS setting.
preallocate memory: 64mb
os: other os
fastboot: disable.

When I set "injectEDID=true, ig-platform-id=0x0d220003" to config.plist, always restarted on startup.
When I remove it, working well, but Vram is only 7mb.

I tried to fix this problem for 4 days. but I am a beginner in this field.
I have read too many guides, but too complex for me.
I hope you to help me to fix my problem.
Thank you
 

Attachments

  • config.plist
    7.1 KB · Views: 295
Last edited:
@jin.zhenxiu, please update your profile (personal details) with your Motherboard (Mobo), CPU and iGPU or Graphics Card.
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.

Desktop HD4600 requirements:
- config.plist/Graphics/Inject/Intel=true
- config.plist/Graphics/ig-platform-id=0x0d220003
- config.plist/Devices/FakeID/IntelGFX=0x0
- BIOS DVMT-prealloc 64mb
- digital connection to your monitor (VGA not supported)
- VT-d disabled or use dart=0
 
Status
Not open for further replies.
Back
Top