Contribute
Register

Intel HD 2500 iGPU partially working with Mojave

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,158
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Sadly, I don't have MSI Radeon RX 560 Low profile here in Kosovo.
Contacted the biggest online seller and the company where they get their products from, none of them does have it on stock.
The shipping situation is sort of complicated...

They do have the MSI Nvidia 1050 Ti low profile on stock as well, but the macOS Mojave drivers don't seem to be close, probably a dream too.

But at the very least, I can use HD4000 for macOS Mojave, don't need much power from GPU for my tasks.
Use Nvidia 1050 Ti on Windows for some casual gaming.

But I would've preferred the Rx 560 LP, wonder what is the performance comparison between those two.

1050 ti has more performance, but RX 560 in OSX runs much smoother. The web drivers lately seem to be buggy. But in windows Nvidia is king.
 
Joined
Dec 7, 2018
Messages
1
I have a 7010 Optiplex with an i5-3570s. I've never run a hackintosh before, but for funsies I tried to see if I could make the HD-2500 work in Mojave until my HD4000 processor arrives.

After using multibeast to install EFI and fakesmc I got the black screen with just the mouse, but booting into safe mode shows a HD2500 1.5gb and chess works. It looks like actual hardware acceleration is disabled though, so I'm going to attempt to remove the FakeID and kext injection, because from what I can tell the ID is supported
 
Joined
Feb 14, 2018
Messages
7
Motherboard
0MN1TX Dell Optiplex 7010 USFF
CPU
i5-3470S
Graphics
HD 2500
I have a 7010 Optiplex with an i5-3570s. I've never run a hackintosh before, but for funsies I tried to see if I could make the HD-2500 work in Mojave until my HD4000 processor arrives.

After using multibeast to install EFI and fakesmc I got the black screen with just the mouse, but booting into safe mode shows a HD2500 1.5gb and chess works. It looks like actual hardware acceleration is disabled though, so I'm going to attempt to remove the FakeID and kext injection, because from what I can tell the ID is supported

Fake ID/intelGFX 0x0152
this is the fakeid that works on our computer
NO ACCELERATION
 
Joined
Mar 4, 2011
Messages
11
Motherboard
GA-M61-HD2
CPU
Pentium G1610
Graphics
GT 610
Mac
  1. MacBook Air
Mobile Phone
  1. Android
@trs96 i will post here the files and maybe you can give it a try and see how it works.

Theres is pretty much everything working as expected, only some minimal adjustments needed like possible Fan RPM reading etc.
I added two config.plist files, config-1 & config-2, they are both the same but just different ig-platform-id for HD2500 and see which one works.

Personally i don't use unibeast or multibeast as i personalize Clover for personal PC/Laptop use.

Kexts that i use:
- Lilu.kext
- WhateverGreen.kext
- VirtualSMC.kext (you can use FakeSMC.kext instead, just personal choice).
- AppleALC.kext
- IntelMausiEthernet.kext
- FakePCIID.kext & FakePCIID_XHCIMux.kext

i always install all kexts into /Library/Extensions, usually i create a desktop folder lets say called kext and put the kexts that i will install on that folder and then i open terminal and write the command:
Code:
sudo cp -R *.kext /Library/Extensions/
this command will copy all kexts with correct permissions into Library/Extensions/
then i rebuild caches with:
Code:
sudo kextcache -i /

into EFI/Clover/ACPI/Patched:
- SSDT-XOSI.aml
- SSDT-LPC.aml
- SSDT-SMBUS.aml
- SSDT-EC.aml
- SSDT-IMEI.aml
- SSDT-ALC221.aml

No need for SSDT.aml generated from the CPU PowerManagement guide via the script as everything is done into config.plist

For HD2500 it is described even on Headkaze Guide which should be supported:
https://www.tonymacx86.com/threads/guide-intel-framebuffer-patching-using-whatevergreen.256490/

Give my files a try, test if config-1 or config-2 gives you Graphics Acceleration on HD2500, im curious for someone to try as it will be a game changer for the people who can't yet afford a DGPU on their i5 models.

Will soon publish the Mojave guide for these machines thanks to your phenomenal Sierra/High Sierra guides for these Golden Desktops.

Hello
I have a core i3 3220 processor with intel hd 2500 graphics, and I followed your guide, install the files in the patch folder, and I just boot with the config.plis-2.
He gave me audio for hdmi but what I still do not get is that metal appears: supported
I can play YouTube videos but I can not see anything in vlc. And I guess I do not have graphical acceleration

Thank you.
 

Attachments

  • Captura de pantalla 2019-01-05 a la(s) 12.13.40.png
    Captura de pantalla 2019-01-05 a la(s) 12.13.40.png
    283.2 KB · Views: 460
Joined
Mar 5, 2019
Messages
2
Motherboard
HP Compaq Elite 8300 SFF
CPU
Intel i5-3470 3.20GHz
Graphics
Intel HD Graphics 2500 7MB
Hi everyone, I´ve just finished to install Mojave on a HP8300 Compaq SFF (first time doing a Hackintosch). It has an Intel HD2500 inside but I´m not really sure it should work properly. For example I can play YouTube videos without problem but when I try to play an .mp4 file this message appears "An unknown error occurred (-101)". By the other hand, I can not play movies in streaming websites. If I go to About this Mac -> Hardware -> Graphics/Displays ->Kernel Extension Info (No Kext Loaded), but I loaded the kexts. Anyone on the same/similar situation? Thanks in advance for the help
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,500
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@silverar, please update your profile (account details) with your Motherboard, CPU and iGPU or Graphics Card(s).
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
 
Joined
Mar 5, 2019
Messages
2
Motherboard
HP Compaq Elite 8300 SFF
CPU
Intel i5-3470 3.20GHz
Graphics
Intel HD Graphics 2500 7MB
Joined
Jul 11, 2016
Messages
18
Motherboard
Dell Optiplex 7050
CPU
i5 > Need model # > See Rules!
Graphics
HD 630
@silverar, did you successfully installed Mojave with hd graphics 2500 ?
 
Joined
Jul 11, 2016
Messages
18
Motherboard
Dell Optiplex 7050
CPU
i5 > Need model # > See Rules!
Graphics
HD 630
@besro, can you upload your clover folder ?
 
Joined
Dec 23, 2016
Messages
4
Motherboard
ASUS Z490 PRIME
CPU
i10 10700
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
I also manage to get hd 2500 working but no acceleration so I will probably upgrade to hd 4000. I also have amd r5 230 but also without acceleration...
 
Top