Contribute
Register

Installing GC-Alpine Ridge Thunderbolt 3 card in Asus Maximus Hero 9

Joined
Aug 22, 2017
Messages
333
Motherboard
ASUS Rog Maximus IX Hero
CPU
i7-7700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
I’m hoping to get some help from the many experts on this forum to see if I can get this Thunderbolt 3 card to work.

My build is based on this Golden build by @JCMunson with a lot of follow up help from @P1LGRIM @pastrychef @RehabMan and @Stork who was instrumental in helping me with the RX580 install. I have followed @JCMunsonII instructions to the letter with a few minor exceptions, notably power management, USB port mapping and GPU (his was Nvidia and mine was RX580). Shout out to @BoomR who has been very patient with me while I spam his Golden Build thread.

I initially set out to pick up ASUS ThunderboltEX2 PCIe Expansion Card, then quickly realized that those are neither supported by the Z270 platform nor are readily available. I then decided to look to the ASUS ThunderboltEX3 as the solution. As I was doing my research the one thing that appealed to me, also pointed out by @BoomR here was that the GC-Alpine Ridge card had 2x TH3 ports vs only 1x on the ASUS ThunderboltEX3. I also took note that he entertained the possibility of the ASUS card matched with his GA-Z370 AORUS UG. I figured, why not reverse that and match the Gigabyte TH3 card with my ASUS? I then stumbled on this thread on overclock forums where this guy actually pairs the newer, updated ASUS driver with the Alpine Ridge. I thought it was crazy too until I was able to get it working without any problems in Windows. Still works – hot plug and everything.

I’m getting kind of desperate trying to get it up and running in High Sierra 10.3.6. I'm running the latest 1301 BIOS and have tried just about every BIOS setting imaginable and macOS simply doesn’t recognize the audio interface. BTW, I'm using the new Slate VRS8 thunderbolt audio interface. Before you say: "it's the driver" I've successfully tested this interface on a trashcan Mac Pro running macOS Sierra and my Macbook Pro running Mojave and it worked without a hitch. Other than some of my USB 3.0 ports not working (I haven’t spent the time to map them all) and this issue, everything else works 100% including sleep, iMessage, etc.

Some like @kgp manage to have a successful implementation, with hotplug I might add, and others like @brutwurm just give up. Posts like this one by @Middleman give me hope, though our systems and AIC's slightly differ. I would really appreciate any assistance anyone can provide!

My EFI folder is attached along with a few screenshots of the key folders for quick reference. Also including a log zip file which includes ASL Messages and IORegistry output and Clover Boot log.
 

Attachments

Last edited:
Joined
Dec 26, 2011
Messages
30
Motherboard
ASUS Prime Z270-A
CPU
I7-7700K
Graphics
R9 280X
Any chance you ever figured this out?

I have an Alpine Ridge card installed on an Asus Prime z270a which works fine in Windows 10, and actually works with the VRS-8 in Windows (even though windows thunderbolt isn't currently supposed to be working), but I can't seem to get the VRS8 to show up in Sierra 10.12.6.
 
Joined
Aug 22, 2017
Messages
333
Motherboard
ASUS Rog Maximus IX Hero
CPU
i7-7700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Any chance you ever figured this out?

I have an Alpine Ridge card installed on an Asus Prime z270a which works fine in Windows 10, and actually works with the VRS-8 in Windows (even though windows thunderbolt isn't currently supposed to be working), but I can't seem to get the VRS8 to show up in Sierra 10.12.6.
I posted few hours ago. Haven't figured out yet. ‍♂
 
Joined
Dec 26, 2011
Messages
30
Motherboard
ASUS Prime Z270-A
CPU
I7-7700K
Graphics
R9 280X
Ah, yeah I see that now.
I'd just found your post while searching to remedy the same basic problem.
I'm still trying to determine if my issue is with thunderbolt itself or just the VRS8 not being detected.
 
Joined
Jul 13, 2016
Messages
987
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
RX580
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
Thunderbolt on a Hack is pretty much emerging tech, there are a few posts with some SSDT that help make Hot Plug work but it is finicky at best. For me I just installed my Titan Ridge into my board in the x4 slot and it worked even before the bios update to support it but I can not get the hot plug feature to work. But it only works when I put it in the x4 slot when I try and put it in x8 slot it does not work maybe you need to start there. I also have the TB header connected to the MB.
 
Joined
Aug 22, 2017
Messages
333
Motherboard
ASUS Rog Maximus IX Hero
CPU
i7-7700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
But it only works when I put it in the x4 slot when I try and put it in x8 slot it does not work maybe you need to start there. I also have the TB header connected to the MB.
I have had it connected to both x4 and x8 slots and I have the same issue. As far as Thunderbolt being "emerging tech" I would respectfully disagree. It's been around longer than USB 3.1 but most don't pay attention to it. I DO understand why - because USB 3 and 3.1 provides enough transfer speed for most people while TH is more of a niche tech. That said, it is technology adopted by Apple and as such I thought this would be the forum where it will receive proper attention.
 
Joined
Jul 13, 2016
Messages
987
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
RX580
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
I have had it connected to both x4 and x8 slots and I have the same issue. As far as Thunderbolt being "emerging tech" I would respectfully disagree. It's been around longer than USB 3.1 but most don't pay attention to it. I DO understand why - because USB 3 and 3.1 provides enough transfer speed for most people while TH is more of a niche tech. That said, it is technology adopted by Apple and as such I thought this would be the forum where it will receive proper attention.
Yes it has been around for a long time, however in the Hackintosh world it does not work very well hence my comment that on a Hackintosh it was emerging tech. So you may disagree all you like does not change the fact that it does not work correctly.
 
Joined
Jul 13, 2016
Messages
987
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
RX580
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
Anyone willing to help? Or did I speak too soon about how helpful the experts are here?
How could you get an expert to be helpful when there just are no experts when it comes to thunderbolt, I have told you already thunderbolt is finicky at best. Read threw the following posts and when you done read them again.

https://www.tonymacx86.com/threads/in-progress-ssdt-for-thunderbolt-3-hotplug.248784/

and the Thunderbolt portion:

https://www.tonymacx86.com/threads/imac-pro-x299-live-the-future-now-with-macos-10-14-mojave-successful-build-extended-guide.255082/

Those two threads contain the bulk of what people know about thunderbolt, how to make it work, and how to make hot plug work sometimes for some people.
 
Joined
Aug 22, 2017
Messages
333
Motherboard
ASUS Rog Maximus IX Hero
CPU
i7-7700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
How could you get an expert to be helpful when there just are no experts when it comes to thunderbolt, I have told you already thunderbolt is finicky at best. Read threw the following posts and when you done read them again.

https://www.tonymacx86.com/threads/in-progress-ssdt-for-thunderbolt-3-hotplug.248784/

and the Thunderbolt portion:

https://www.tonymacx86.com/threads/imac-pro-x299-live-the-future-now-with-macos-10-14-mojave-successful-build-extended-guide.255082/

Those two threads contain the bulk of what people know about thunderbolt, how to make it work, and how to make hot plug work sometimes for some people.
If you don't mind, please stay off this thread if you're not going to be helpful. Thanks.
 
Top