Contribute
Register

Installing Big Sur 11.1 on new clover(5129) and new OC(0.6.6)

Joined
Mar 28, 2019
Messages
5
Motherboard
PowerX h81
CPU
g3240
Graphics
gt 710
Mac
  1. iMac
I am getting following error while installing Big Sur on Pentium Dual Core g3240 with Nvidia gt 710 please help

vlcsnap-2021-02-10-14h21m26s356.png
 

Attachments

  • EFIc.zip
    4.2 MB · Views: 37
  • EFIoc.zip
    2.5 MB · Views: 21

trs96

Moderator
Joined
Jul 31, 2012
Messages
19,156
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Big Sur on Pentium Dual Core g3240
Unsupported CPU is one of your problems. Search for how to spoof the CPU ID. Change that in your Config.plist.
 
Joined
Mar 28, 2019
Messages
5
Motherboard
PowerX h81
CPU
g3240
Graphics
gt 710
Mac
  1. iMac
I know this cpu is not supported, but spoofing CPU ID same error happens in both clover and oc
 
Joined
Oct 26, 2013
Messages
1,054
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
I am getting following error while installing Big Sur on Pentium Dual Core g3240 with Nvidia gt 710 please help


Try my Haswell Celeron G1840 + GT730 and SKL Pentium G4400 + GT630 OC 0.66 EFI, Big Sur 11.2 fresh installation and 11.3 OTA upgrade OK.

SMBIOS set to iMacPro1,1 and IGPU is disabled vs config.plist to prevent black screen during installation.

CPU PM controlled vs Frequency Vector table through cpufriend, work for Haswell and SKL up.

For G3258, use ssdt-3100.aml frequency vector table should be enough.

Both my hacks use minimum config file (config skl/haswell inst.plist) for Big Sur fresh installation, no Lilu and its plugins in use, and use full config (config imacpro11 Haswell g1840 / config imacpro SKL g4400) for OTA upgrade.
 

Attachments

  • celeron-pentium-EFI.zip
    5.5 MB · Views: 57
Last edited:
Joined
Mar 28, 2019
Messages
5
Motherboard
PowerX h81
CPU
g3240
Graphics
gt 710
Mac
  1. iMac

@shuhung

Oh man! You are great! thank you thank you, its works!:clap::clap::clap::clap::clap::clap:
Screenshot 2021-02-14 at 7.50.10 AM.png


Missing Hardware acceleration from nvidia-gt710

Screenshot 2021-02-14 at 7.52.01 AM.png
 
Last edited:
Joined
Oct 26, 2013
Messages
1,054
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Missing Hardware acceleration from nvidia-gt710

No, pngs show that QE/CI already work, seems to be ASPM compatible issue, try disable ASPM support from BIOS or add device properties as bellow.
1613299885723.png


pci-aspm-default=0, equal to disable

pci-aspm-default=1, equal to L0s, fast response but easy cause screen flickering, need DGPU fully compatible with mobo ASPM mode.

pci-aspm-default=2, equal to L1, best power saving mode but high latency and response is slow, should work with most of DGPU & mobos.

pci-aspm-default=3, equal to L0s + L1, for fast response and power saving mode, need DGPU fully compatible with mobo ASPM mode.
 
Joined
Mar 28, 2019
Messages
5
Motherboard
PowerX h81
CPU
g3240
Graphics
gt 710
Mac
  1. iMac
I can't enable VT-x even though it is enabled in BIOS!

Tried above settings and tested with dortania got following error:

VDADecoderCreate failed. err: -12473
An error was returned by the decoder layer. This may happen for example because of bitstream/data errors during a decode operation. This error may also be returned from VDADecoderCreate when hardware decoder resources are available on the system but currently in use by another process.
VDADecoderCreate failed. err: -12473

According to my system(Pentium DC g3240+gt 710) which config is best?
config imacpro11 Haswell g1840.plist
config imacpro SKL g4400.plist
config-haswell skl.plist
config.plist
 
Joined
Oct 26, 2013
Messages
1,054
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
I can't enable VT-x even though it is enabled in BIOS!

Tried above settings and tested with dortania got following error:

VDADecoderCreate failed. err: -12473
An error was returned by the decoder layer. This may happen for example because of bitstream/data errors during a decode operation. This error may also be returned from VDADecoderCreate when hardware decoder resources are available on the system but currently in use by another process.
VDADecoderCreate failed. err: -12473

According to my system(Pentium DC g3240+gt 710) which config is best?
config imacpro11 Haswell g1840.plist
config imacpro SKL g4400.plist
config-haswell skl.plist
config.plist

My EFI use iMacPro1,1 for installation, headless IGPU mode not supported, change to other SMBIOS like iMac15,1 after fresh install, delete other values on PciRoot(0x0)/Pci(0x2,0x0) and re-enable device properties for headless IGPU support as below

1613326372864.png
 
Joined
Mar 28, 2019
Messages
5
Motherboard
PowerX h81
CPU
g3240
Graphics
gt 710
Mac
  1. iMac
Ok now works. Thanks again man! :clap: :clap: :clap: :clap:
 
Last edited:
Top