Contribute
Register

Solved > Install stuck at apple logo with progress bar at 100%

Joined
Apr 16, 2019
Messages
9
Motherboard
Asus TUF Z390-PRO Gaming
CPU
i7-9700K
Graphics
RX 590
Hello everybody,

First hackintosh attempt. I managed to create the unibeast install on my usb key. After booting on it, the apple logo appears and the process bar starts. It takes 15-20 minutes to reach the end and then stays stuck with the bar at 100%.

I launched the same in verbose. See attached files

any ideas on what I am doing wrong ?

Thank you in advance for your help
 

Attachments

Joined
Mar 30, 2019
Messages
18
Motherboard
Z370 AORUS Gaming 7
CPU
i9-9900K
Graphics
UHD 630 + Vega 56
Mac
Mac Pro
Mobile Phone
Android
I went through a similar ordeal recently but my issue was more BIOS compatibility related.

Your error message points to "AMFILoadTrustedKeysFromNVRam: no nvram variable"

I am not a Hackintosh guru by any means but I found this thread that looks a lot like your problem


And seeing you have a 390 board may try to check this one out too

 
Joined
Apr 16, 2019
Messages
9
Motherboard
Asus TUF Z390-PRO Gaming
CPU
i7-9700K
Graphics
RX 590
Thank you for your answer.

I tried the FixOwnership without any success. It stayed stuck at the same place.

I then tried to enable the above 4G decoding. Didn't work either

Maybe I should try to install High Sierra first and then do the upgrade orders anybody has another idea ?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
3,491
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Thank you for your answer.

I tried the FixOwnership without any success. It stayed stuck at the same place.

I then tried to enable the above 4G decoding. Didn't work either

Maybe I should try to install High Sierra first and then do the upgrade orders anybody has another idea ?
You might want to try following this Golden Build guide by @MacMan:
 
Joined
Apr 16, 2019
Messages
9
Motherboard
Asus TUF Z390-PRO Gaming
CPU
i7-9700K
Graphics
RX 590
I did try that, and followed exactly the same settings as his build seemed quite similar to mine.

I created the bootable usb key with unibeast, ran Clover_v2.4k_r4920-UEFI-EmuNVR-UB.pkg to install it onto the key after. Put the same settings in the BIOS.

But the problem is still there and I am stuck at the install page with the apple logo ....
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
3,491
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I did try that, and followed exactly the same settings as his build seemed quite similar to mine.

I created the bootable usb key with unibeast, ran Clover_v2.4k_r4920-UEFI-EmuNVR-UB.pkg to install it onto the key after. Put the same settings in the BIOS.

But the problem is still there and I am stuck at the install page with the apple logo ....
Have you checked your BIOS version? You may need an older BIOS such as revision 2012 on the ASUS TUF Z390-PRO Gaming.
 
Joined
Apr 16, 2019
Messages
9
Motherboard
Asus TUF Z390-PRO Gaming
CPU
i7-9700K
Graphics
RX 590
ahhhhh Yeah that might be my mistake here ... I have the most recent version. ... I'll try that

thank you !
 
Joined
Jul 25, 2012
Messages
6,582
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Thank you for your answer.

I tried the FixOwnership without any success. It stayed stuck at the same place.

I then tried to enable the above 4G decoding. Didn't work either

Maybe I should try to install High Sierra first and then do the upgrade orders anybody has another idea ?
  • You are following 'hit or miss' suggestions based on very little real information about your system which you have but did not provide in its entirety in your post.
  • Any time a boot failure occurs either during installation or on an installed System disk, the following data must be given to the Forum to get real informed help based on data:
    1. The full Make and Models of Motherboard, CPU , Graphics , Target Hard disk [Your post has the minimum essential hardware Specifications in your Profile. ]
      • Many don't provide that voluntarily and needs Moderator intervention causing unnecessary delay in getting a good response.
    2. A legible verbose boot screen showing what happened during boot failure. [You have posted a Verbose boot screen]
      • Very often, but NOT ALWAYS, the text based output may show some clue to the cause of Boot failure if enough legible screen is uploaded.
      • The problem is NOT ALWAYS in the last line .
      • In fact, the last line may deceptively appear as a true error causing boot failure when in fact the real culprit may be hiding many lines above the false error line!
    3. Clover or EFI Folder from the Hidden partition of the booting disk (macOS USB Installer or System Disk as the case may be) as a Zipped file
      • very few upload CLOVER.zip on their own. [You have not uploaded CLOVER.zip from the macOSMojave USB Installer]
      • Many don't know how to do upload CLOVER [Steps -> #4 ]
    4. BIOS Screen shots showing the Exact Options chosen or List of BIOS options actually chosen.
      • Many do not bother to list them. [You have not uploaded BIOS screen shots]
        • Many don't know why that is needed.
      • Many will say " I have followed all the recommended BIOS options from the GUIDE".
        • No GUIDE is written as a Manual for all different combinations of Motherboards, CPU, Graphics, Wifi , LAN cards etc people choose from myriads of manufacturers for their builds.
        • Guides provide just general help , not a SPECIFIC instruction for each MoBo and other devices we use.
        • If you are not prepared to spend time looking around in the BIOS menu the various items and learn from any and all sources what they are for, are you really ready to build a computer with any Operating system let alone Hackintosh which requires extra skills to make a Windows hardware masquerading as Mac?
        • The Motherboard Manual is generally made for Windows users but if the screen shots are uploaded Hackintosh troubleshooters can help the Poster with suggestions.
        • Many UEFI BIOS screens can be automatically captured on to a FAT32 Formatted USB Flash disks using a designated key like F12. [steps-> #33 ]
    5. If you are interested to get Tips about macOSMojave installation and posting for help, check this post: https://www.tonymacx86.com/threads/some-tips-to-macos-mojave-installation-and-posting-for-help.276352/
 
Joined
Apr 16, 2019
Messages
9
Motherboard
Asus TUF Z390-PRO Gaming
CPU
i7-9700K
Graphics
RX 590
So I am starting from scratch.

My complete configuration is :

Asus TUF Z390 pro gaming
Intel Core i7-9700k
Sapphire RX 590 Nitro +
Corsair Vengeance LPX 32 GB (2 x 16 GB) 2666 MHz
Crucial P1 1TB 3D NAND NVMe PCIe M.2 SSD

I managed to create the unibeast install on my usb key. After booting on it, the apple logo appears and the process bar starts. It takes 15-20 minutes to reach the end and then stays stuck with the bar at 100%.

Here is the complete Verbose boot screen :

404745


404746


404747


I am attaching to this post the Clover folder in zip.


For the BIOS I followed exactly the build from here : https://www.tonymacx86.com/threads/macmans-build-asus-tuf-z390-pro-gaming-i9-9900k-uhd-630.275272/


I made the mistake of updating my BIOS to the latest version but even with the patch offered some messages before I am ending up with that.

Any ideas ?


Thank you for your help and patience
 

Attachments

Top