Contribute
Register

<< Solved >> Install Nvidia Web Driver for Build ID 17G66 (BRAND new High Sierra build???)

Joined
Aug 23, 2012
Messages
6
Motherboard
Asrock Taichi X99
CPU
i7-5820K
Graphics
GTX 1080
Mobile Phone
  1. iOS
Hello,

I installed driver x.x.x.x.40.135 and have graphics acceleration. However, I am using a 4K monitor and cannot see the supported resolution. The max I can see is 2560 x1440!

I am running 10.13.6 17G66.

Any help would be appreciated.


Thanks
 
Joined
Sep 30, 2017
Messages
17
Motherboard
ASRock Z370M Pro4
CPU
i5-8600K
Graphics
GTX-1060 + UHD630
Mobile Phone
  1. Android
Hello,

I installed driver x.x.x.x.40.135 and have graphics acceleration. However, I am using a 4K monitor and cannot see the supported resolution. The max I can see is 2560 x1440!

I am running 10.13.6 17G66.

Any help would be appreciated.


Thanks
What SmBIOS is used for? Seem's any mobile
 
Joined
Apr 22, 2020
Messages
3
Motherboard
Lenovo Legion Y530
CPU
Core i7 8750H 2.2 GHZ
Graphics
Geforce GTX 1050 & Intel UHD 630 | 1920x1080
Mobile Phone
  1. iOS
Hello, I have installed clean High sierra (17G66) to my laptop (Lenovo Legion Y530 , Core i7 8750H, 8GB ram, Geforce GTX 1050, 256GB ssd + 2 tb hdd) . Then I have installed decurity updates and my build changed successfully to the latest build of high sierra which is supported by NVIDIA’s last web driver. I have downloaded it and installed . Also I have installed cuda drivers. But still I can not drive (activate ) my Nvidia GPU.. Whatever I do it is still UHD Graphics 630 1536 mb . I tried different bootflags such as nvda_drv=1 (NvdaWeb box check in configurator) , tried to disable igpu but it just got me 7 mb uhd graphics still no nvidia. Tried PEG to GFX0 patch too still no success, tried to change some bios settings in graphical section (changed peg to dGPU something like that) . Tried some tutorials from internet about activating nvidia graphics on High Sierra but no success.
I have Catalina too on my laptop . I know that on mojave and catalina nvidia officialy is not suported . That is why I installed High sierra additionally to try nvidia. If I success I will continue to use high sierra for nvidia. Otherwise I will be using catalina with UHD graphics .
 
Joined
Sep 30, 2017
Messages
17
Motherboard
ASRock Z370M Pro4
CPU
i5-8600K
Graphics
GTX-1060 + UHD630
Mobile Phone
  1. Android
Hello, I have installed clean High sierra (17G66) to my laptop (Lenovo Legion Y530 , Core i7 8750H, 8GB ram, Geforce GTX 1050, 256GB ssd + 2 tb hdd) . Then I have installed decurity updates and my build changed successfully to the latest build of high sierra which is supported by NVIDIA’s last web driver. I have downloaded it and installed . Also I have installed cuda drivers. But still I can not drive (activate ) my Nvidia GPU.. Whatever I do it is still UHD Graphics 630 1536 mb . I tried different bootflags such as nvda_drv=1 (NvdaWeb box check in configurator) , tried to disable igpu but it just got me 7 mb uhd graphics still no nvidia. Tried PEG to GFX0 patch too still no success, tried to change some bios settings in graphical section (changed peg to dGPU something like that) . Tried some tutorials from internet about activating nvidia graphics on High Sierra but no success.
I have Catalina too on my laptop . I know that on mojave and catalina nvidia officialy is not suported . That is why I installed High sierra additionally to try nvidia. If I success I will continue to use high sierra for nvidia. Otherwise I will be using catalina with UHD graphics .
You should know the mobile discrete graphic cards can not be used by Hackintish due to technical design of laptops MB.
 
Joined
Mar 10, 2017
Messages
52
Motherboard
Asus Rampage V5 Edition 10
CPU
i7 6850k
Graphics
GTX 1080ti
Try this script
Code:
bash <(curl -s https://vulgo.github.io/webdriver) 387.10.10.10.40.113

Unfortunately this driver link address now seems broken but I got my GTX 1080ti successfully working well on Nvidia with this same High Sierra (17G66) build. Running well on two screens on DP outputs and a 3rd screen on HDMI output.
For me the easiest route was to patch terminal with brew.sh and webdriver.sh and select a web driver that was closest to this 17G66 build. Works flawlessly so far, assuming that the config file's Graphics has no graphic injects ticked and System has webdriver ticked. Also both Lilu.kext and Everything Green.kext need to be in the EFI bootloader.

Now to get my Thunderbolt working again which seems to have disconnected through the install of Os High Sierra
 

jwk

Joined
Oct 8, 2011
Messages
236
Motherboard
Z68X-UD5-B3
CPU
i7-2700K
Graphics
PNY Quadro 4000
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
Unfortunately this driver link address now seems broken but I got my GTX 1080ti successfully working well on Nvidia with this same High Sierra (17G66) build. Running well on two screens on DP outputs and a 3rd screen on HDMI output.
For me the easiest route was to patch terminal with brew.sh and webdriver.sh and select a web driver that was closest to this 17G66 build. Works flawlessly so far, assuming that the config file's Graphics has no graphic injects ticked and System has webdriver ticked. Also both Lilu.kext and Everything Green.kext need to be in the EFI bootloader.

Now to get my Thunderbolt working again which seems to have disconnected through the install of Os High Sierra
Raddles, what Nvidia driver version did you finally download for the GTX 1080Ti???
 
Joined
Mar 10, 2017
Messages
52
Motherboard
Asus Rampage V5 Edition 10
CPU
i7 6850k
Graphics
GTX 1080ti
Raddles, what Nvidia driver version did you finally download for the GTX 1080Ti???

Hi Jwk, I went with Web.driver version 387.10.10.10.40.127 17G6030 as it is closest in release to the original (17G66) installation of 10.13.6 which i'm stuck on since my file system is HFS+.

Screen Shot 2020-05-25 at 1.06.09 pm.png

This is my terminal screen using the command 'webdriver --list' after both 'brew.sh' https://brew.sh/ and Vulgo's great 'webdriver.sh' https://github.com/vulgo/webdriver.sh have been installed. These extra terminal commands are permanently included into terminal which is great. Simply enter the number in corresponding to the most equivalent driver and hit 'Y' for next prompt and it patches without any hassles. My graphics is flawless even without having an Nvidia Control Panel. I just use Display settings which works great for screen size and resolutions and I'm running 3 screens. Happy to help guide you through if you need. This forum has helped me so much over the years. :)
 

jwk

Joined
Oct 8, 2011
Messages
236
Motherboard
Z68X-UD5-B3
CPU
i7-2700K
Graphics
PNY Quadro 4000
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
Hi Raddles,
Thank you for your reply and I greatly appreciate you offering to help. I'm on HFS+ as well, no plans at this time to change that... Build 17G66, like you. I guess I don't understand how the nvidia driver version numbers are related to the 10.13.66 release numbers; to a neophyte it would seem like the 387.10.10.10.40.105 for 17G65 would be the closest, or maybe 387.10.10.10.40.108 for 17G3025... or is the driver you selected chosen by being the latest nvidia driver that works with build 17G66?

I currently have a Sapphire Pulse Radeon 580 8GB installed (SKU 11265-05-20G) GDDR5 which 'worked' OOB without any changes to my basic install of 10.13.66... (audio over HDMI not working, just started to try to figure that out) system report indicates Metal, but I haven't run any tests to see if card is fully working; this card was not meant for this build, I bought it for a different workstation, but installed it in a GA-Z97X-UD5H-BK just to see if it worked. The BIOS was set with external graphics card having boot priority, but Intel graphics is still enabled; I have video on the 580 throughout the entire boot process, and onboard (intel) HDMI video + Sapphire DVI or HDMI video going dual monitors working OOB, which is very surprising to me. Like you, I have a 1080Ti (liquid-cooled) that really is the card that needs to end up in this build, I need it for the CUDA cores and performance, so that's why I'm looking for the correct Nvidia driver for this build, and I greatly appreciate any help that you (or anyone else, for that matter) can provide. The first hack I built was Snow Leopard and last hack I build was Yosemite, and a lot of changes have happened since then, Clover is new to me, as are a lot of new (to me) tools that are now mainstream, so I've got a lot of catching up to do. Biggest problem is that with all the changes in the past few years, it confusing reading the articles on this site as to which are still current and which have been deprecated by newer tools/plugins/techniques.
 
Top