Contribute
Register

Install not completing - macOS 12.6 Update

Joined
Dec 10, 2019
Messages
21
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I ran the Software Update installer and when the computer restarted, I think I chose the wrong option at the bootloader screen (two options: macOS / macOS Installer)

I've tried selecting both multiple times, have cleared the nvram, and even plugged in my bootable backup to try to get macOS booted again--I seem to be stuck.

How do I resume and finish the update to 12.6?
 
Joined
Mar 2, 2014
Messages
1,591
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
You are not supposed to touch anything when the installer is running; it's all automatic. Don't select either; allow the app to do that. There are a few black screens, restarts, and re-selecting of the correct target disk, all done by the installer. In my case, I had tried a USB flash drive install of Monterey 12.6, but it failed at 17 minutes to finish. So I next used Software Update from my working Big Sur 11.7 installation, which did work. You do need to be sure that your EFI boot loader (in my case OpenCore 0.8.4) is up to date, and if you have Bluetooth and/or WIFI kexts active, they need to be the latest and the right ones.
 
Joined
Dec 10, 2019
Messages
21
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
You are not supposed to touch anything when the installer is running; it's all automatic. Don't select either; allow the app to do that. There are a few black screens, restarts, and re-selecting of the correct target disk, all done by the installer. In my case, I had tried a USB flash drive install of Monterey 12.6, but it failed at 17 minutes to finish. So I next used Software Update from my working Big Sur 11.7 installation, which did work. You do need to be sure that your EFI boot loader (in my case OpenCore 0.8.4) is up to date, and if you have Bluetooth and/or WIFI kexts active, they need to be the latest and the right ones.
Any idea how to start the process over? I must have interrupted it
 
Joined
Mar 2, 2014
Messages
1,591
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
What version of the Mac OS, and what version of OpenCore (or Clover) are you using to boot? And what exactly happens when you try to boot into your current OS?
 
Joined
Dec 10, 2019
Messages
21
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
What version of the Mac OS, and what version of OpenCore (or Clover) are you using to boot? And what exactly happens when you try to boot into your current OS?
It looks like it was a config.plist issue. Once I fixed that, the solution was to just select macOS Installer at boot loader options and the install continued as normal.

Thanks!
 
Top