Contribute
Register

Install network kext

Joined
Sep 4, 2015
Messages
48
Motherboard
Asus P8H61-M Pro
CPU
i7-2600
Graphics
HD2000 / 210
Is it possible to install a networking kext on Snow Leopard 10.6.3?

I have been able to install SL, but have no networking. The lights on the interfaces work and I can go through the setup process, but all I get is No route to host. My motherboard is an P8H61 Pro. The Ethernet hardware Realtek 81xx gigabit.

I have tried running Kextbeast and although it seems to run through the install process, nothing seems to happen with the kexts on the desktop.
 
Joined
Mar 31, 2011
Messages
741
Motherboard
Gigabyte GA-Z97-D3H (F7)
CPU
i7-4790S
Graphics
HD 4600
Mobile Phone
  1. Android
  2. iOS
Asus P8H61-M Pro uses the Realtek RTL8111E

so use the Kext from Mieze / RTL8111_driver_for_osx here .

It was recommended by Dortania not to use the latest version for older systems so maybe choose the Release Version 2.2.2 (2018-01-21) firstly.

Also read the Readme file as it has some useful info for your consideration.
 
Joined
Sep 4, 2015
Messages
48
Motherboard
Asus P8H61-M Pro
CPU
i7-2600
Graphics
HD2000 / 210
Thanks. I have downloaded that driver and also noted and read the read.me. Very useful. Unfortunately it seems that not only can I not install the 10.6.8 update, I cannot install kexts either. I think the key to progress is for me to get the 10.6.8 update installed somehow but I have no idea why it is failing so am a bit stuck.

BTW, I made something of an accidental discovery. After my last install, I suddenly got a pop-up that saidf there were some updates available. It seems that if the PC is connected to the network at the time of the install from the SL DVD, then it comes up with network enabled and working. I had been leaving the network disconnected during this stage. Even if I subsequently plugged it in afterwards, although it would show the network cable being connected and disconnected, it would not find a DHCP address and just assigned itself the 169.x.x.x dummy address.

Unfortunately even though I now have a working network connection, this has not resolved the problem I am having with getting the 10.6.8 update installer. Installing the 5 available updates shown in the pop-up (whatever they were) just resulted in a crash at boot-up. I am just re-installing from scratch once again....
 
Last edited:
Joined
Sep 4, 2015
Messages
48
Motherboard
Asus P8H61-M Pro
CPU
i7-2600
Graphics
HD2000 / 210
I have some more detail on the error concerned from /var/log/install.log:


Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: Starting installation:

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: Configuring volume "OSX"

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: Preparing disk for local booted install.

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: Free space on "OSX": 111.56 GB (111564492800 bytes).

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: Create temporary directory "/var/folders/YU/YU0-jxKwGD8AGqEjwKpAwE+++TI/-Tmp-//Install.344k4F6Tq"

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: IFPKInstallElement (15 packages)

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: Failed install preflight: Error Domain=PKInstallErrorDomain Code=102 UserInfo=0x11f300820 "The package “MacOSXUpdCombo10.6.8.pkg” is untrusted." Underlying Error=(Error Domain=NSOSStatusErrorDomain Code=-2147409654 UserInfo=0x11f319b30 "The operation couldn’t be completed. CSSMERR_TP_CERT_EXPIRED")

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: IFDInstallController 3F26F0 state = 7

Sep 13 14:10:54 Thornton-Derevoiress-Mac-Pro Installer[344]: Displaying 'Install Failed' UI.​

What is IFPKInstallElement and why is MacOSXUpdCombo10.6.8.pkg untrusted? How do I make it trusted?
 
Joined
Sep 4, 2015
Messages
48
Motherboard
Asus P8H61-M Pro
CPU
i7-2600
Graphics
HD2000 / 210
With a little bit of Googling I found that I had to set the clock back to an earlier point in time. This allowed the installer to run, but unfortunately it crashed so I am starting over again one final time. This time I will leave the machine off the network set the clock back immediately post SL DVD install and before installing UpdateHelper and copying the update img on to the desktop.
 
Last edited:
Joined
Sep 4, 2015
Messages
48
Motherboard
Asus P8H61-M Pro
CPU
i7-2600
Graphics
HD2000 / 210
Well it seems tat perseverance has paid off. I finally have SL with the 10.6.8 update installed!

It required the network to be left connected and the date to be set back to August 2011. I have made a backup of the current setup. The next step will be to get Yosemite on it.
 
Top