Contribute
Register

Install Monterey help

Joined
Jan 11, 2020
Messages
90
Motherboard
Asus Z390-plus
CPU
i5-9600K
Graphics
RX570
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi all,

Thanks in advance for any help! I'm on Catalina with clover 5104. Now I have an USB with macOS Monterey install. I've succesfully booted into the installer and after the first installment steps the install wants to reboot. This is the point where it does not advance forward. I constantly have a boot stop. I assume my Open Core setup is not ok or my SSDT is not properly fitted for my hardware. I cannot change it for the better. In the attachement is my OC efi zipped.
Thanks for any help or pointing in the right direction.
 

Attachments

  • EFI.zip
    9.1 MB · Views: 21
Joined
Apr 1, 2012
Messages
443
Motherboard
MSI MPG Z490 Gaming Plus
CPU
i7 10700
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
Not a solution, suggestions:
In a brief review of your EFI I don't see custom USB kext, without which you cannot install Monterey.
You can make that in Catalina using the USB inject all kext. If you boot into Windows its actually easier to make the kext. It will work in both clover and OC.
Your kext folder seems kind of a mess with what looks like too many kexts and in the wrong format, all you need is the kext itself.
Your hardware should be straight forward, if you search you should be able to find a sample from someone showing how the EFI should be structured for that chipset, possibly that specific motherboard.
 
Joined
Jan 11, 2020
Messages
90
Motherboard
Asus Z390-plus
CPU
i5-9600K
Graphics
RX570
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks for your advice! Much appreciated!
Okay, so can I use the USB Inject All that I'm using in the Clover 5104 boot that is working for Catalina?

EDIT: Sorry, yea, as you were saying: "It works in both Clover and OC."
 
Last edited:
Joined
Jan 11, 2020
Messages
90
Motherboard
Asus Z390-plus
CPU
i5-9600K
Graphics
RX570
Mac
  1. iMac
Mobile Phone
  1. iOS
The reboot point is in the attachments. What do I have to change?
 

Attachments

  • IMG_6758.JPG
    IMG_6758.JPG
    3 MB · Views: 12

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,495
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi all,

Thanks in advance for any help! I'm on Catalina with clover 5104. Now I have an USB with macOS Monterey install. I've succesfully booted into the installer and after the first installment steps the install wants to reboot. This is the point where it does not advance forward. I constantly have a boot stop. I assume my Open Core setup is not ok or my SSDT is not properly fitted for my hardware. I cannot change it for the better. In the attachement is my OC efi zipped.
Thanks for any help or pointing in the right direction.
BrcmBluetoothInjector.kext
BrcmNonPatchRAM.kext
BrcmNonPatchRAM2.kext
BrcmPatchRAM.kext
BrcmPatchRAM2.kext
should be removed

Lilu should be listed first
 
Top