Contribute
Register

Install Mac OS doesn't appear as option in Clover for Monterey USB installer

Joined
Mar 25, 2016
Messages
62
Motherboard
Gigabyte Z690 UD AX DDR4
CPU
i7-12700k
Graphics
RX590
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. Android
I have my Catalina (10.15.5) Mac to download the Monterey installer and Clover 5141. I created a USB boot stick using this guide:


...but when I boot from it no boot options appear. If I press F3 to show hidden options the only thing showing is "Boot UEFI external from EFI", which just reloads Clover again. There is no option for "Install Mac OS". I have repeated the process a few times to make sure I didn't miss something, but nothing changes.

The last time I tried, I put the USB stick into my PC and booted BEFORE I installed Clover onto it - The PC has an older Clover installation on it. The "Install Mac OS" option did appear using the older Clover on my PC. So I moved the USB stick back to my Mac and did the Clover installation as it was described in the guide. I boot from the USB stick on my PC again and the "Install Mac OS" option is not there. I boot from the old Clover on my PC and the option IS there. What step am I messing up during the Clover installation to the USB stick?

FWIW, I have tried both the Standard installation of Clover 5141 and a custom one for EFI with no difference.

PC details are:
- Intel i7-12700K CPU
- Gigabyte Z690 UD AX DDR4 mainboard, latest firmware
- AMD RX590 video card
- 16GB 3200 DDR memory
- ~512GB M.2 SX8200NP SSD (blank)
- One 2TB Seagate ST2000DM001 SATA drive, holding data and the old Clover installation
- LG Bluray writer
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
3,418
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Are you adding/incuding a HFS+ driver to your /CLOVER/drivers/UEFI folder?

HFSPlus.efi or VBoxHfs.efi (not both) need to be present in the UEFI folder for the HFS+ drives to show on the Clover boot screen.
 
Joined
Mar 25, 2016
Messages
62
Motherboard
Gigabyte Z690 UD AX DDR4
CPU
i7-12700k
Graphics
RX590
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. Android
Are you adding/incuding a HFS+ driver to your /CLOVER/drivers/UEFI folder?

HFSPlus.efi or VBoxHfs.efi (not both) need to be present in the UEFI folder for the HFS+ drives to show on the Clover boot screen.
The simplest solutions are the best solutions! Thank you.

While I'm not a computer n00b, I am definitely a Hackintosh n00b. Little items like this go overlooked often.

Now to get my configuration set up and hopefully get my Alder Lake system working.
 
Top