Contribute
Register

Install Guide : Intel Haswell NUC Core i5 (D54250WYK) V2 (Mavericks)

Joined
Jan 20, 2015
Messages
1
Mac
Classic Mac
Mobile Phone
Installation Guide : Intel Haswell NUC Core i5 (D54250WYK) V2

He Guys.

THANKS FOR THE INSTALL GUIDE. AWESOME.


I did the Installation on a NUC and run at my first try.
I got 2 Problems with OSX.

1. When i start the Plex Home Theatre and play a full HD Video is there no Sound.
I am playing it directly from the Plex Media Server and the Sound would play.

What is the Reason for this Problem.


2. When The nuc goes in the sleepmode and i wake it up.
The lan connection is missing and i must start it new.


What about the chameleon start Screen, can i create a autorun or is it normal
That i must hit the return button on the keyboard.

I try all options for the Sound but nothing Works.
 
Joined
Nov 24, 2010
Messages
124
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 5700 XT
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Installation Guide : Intel Haswell NUC Core i5 (D54250WYK) V2

Thank You!! Thank You!!

Did not have to follow your guide exactly since I already had a Mavericks 9.5 install on a hard drive. I picked it up from the point you started working with the installation itself. I did need to add PCIRootUID=1 . I am using this for a lighting console. Now Win 7 is working perfectly but I rather OS X. Touch screen works with Yosemite but does not seem to work with Mavericks. Can I update to Yosemite or are there touch screen drivers for Mavericks.?

Thank You Bob
 
Joined
Feb 1, 2011
Messages
4
Motherboard
Lenovo Legion Y720
CPU
i7-7700HQ
Graphics
HD 630
Mac
MacBook Pro
Installation Guide : Intel Haswell NUC Core i5 (D54250WYK) V2

I tried to install security Update 2015-001. It caused the Intel NUC to continuously reboot after the update. I wonder if anyone else has experienced similar problems?

Onidori
 
Joined
Aug 16, 2014
Messages
1
Mac
Classic Mac
Mobile Phone
Installation Guide : Intel Haswell NUC Core i5 (D54250WYK) V2

I tried to install security Update 2015-001. It caused the Intel NUC to continuously reboot after the update. I wonder if anyone else has experienced similar problems?

Onidori
Hello Onidori,

the same happend to me. I didn't know what exactly happend, but i solved this way:
As WonkeyDonkey in his perfect guide described http://www.tonymacx86.com/mavericks...e-intel-haswell-nuc-core-i5-d54250wyk-v2.html,
i did "Section 6 - Install OS X" again and OSX is booting normaly.

JoseLA
 

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
4,505
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
iMac, Mac mini
Mobile Phone
iOS
Installation Guide : Intel Haswell NUC Core i5 (D54250WYK) V2

Well after a long delay, i finally got a replacement NUC back today! Better late than never Intel!

Ill start looking at the latest Yosemite stuff in the next few days and see what i can come up with.

:thumbup:
 
Joined
May 18, 2014
Messages
14
Motherboard
GA-Z97N-WiFi
CPU
i7-4790K
Graphics
GTX 1060
Mac
MacBook Air, Mac mini
Mobile Phone
Android, iOS, , Other
Well after a long delay, i finally got a replacement NUC back today! Better late than never Intel!

Ill start looking at the latest Yosemite stuff in the next few days and see what i can come up with.

:thumbup:
Great, looking forward to your guide.
 
Joined
Oct 30, 2012
Messages
53
Motherboard
Gigabyte B85M Gaming 3
CPU
Core i5-4590
Graphics
MSI N750TI-2GD5/OC
Mac
Classic Mac
Mobile Phone
Broadcom BCM943224HMS device id fix?

Thanks WonkeyDonkey for this amazing tutorial! I followed it last weekend and got my NUC running smoothly. I stayed with Mavericks, as I've experienced major freeze issues with Yosemite on my other (MUCH more compatible) systems, which were miraculously cured by going back to Mavericks.

I have a two-part question though:

First, has anyone experienced issues with their ethernet port? Mine stops working intermittently, on one boot it'll work, the next one it won't. My NUC is dual-boot, and under windows I get "device cannot start error 10" with an exclamation mark in device manager, while in Mavericks it is simply "disconnected".
I am really not sure when it started, but I suspect it was when I updated the BIOS to v. 38 prior to this install. I have since tried downgrading to 37, 35, 28, back to 37 - no difference. It was working perfectly for several months before this change. I do not rule out hardware failure though.

So I figured, whatever, as long as I get a compatible wifi adapter, which brings us to Part 2:

I made the mistake of purchasing the Broadcom BCM943224HMS, which was mentioned in several posts as fully supported. Well, Mavericks doesn't recognize it, and further digging around I found mentions of something called "device id fix" in relation to a Probook laptop, which I am not sure applies here. What is it, and how do I do it? Should I just buy a natively supported card?

Thank you in advance.

My hardware:
D54250WYKH
G. Skill Ripjaws F3-2133C11D-8GRSL
Mushkin Enhanced Atlas MKNSSDAT120GB-V mSata ssd
Broadcom BCM943224HMS half-size (Dell DW 1520) wifi


P.S. Something I wanted to mention for those who may experience what I did during the install. It may be due to my RAM being 2133, but I couldn't get past the flags in Step 7, getting the "freed zone" panic regardless of maxmem setting, so I simply tried -x without any other flags and it worked like a charm.
 
Top