Contribute
Register

Install Bootloader and Extra to EFI Partition

Joined
Feb 28, 2015
Messages
1
Motherboard
Asus P9X79 Pro (12GB)
CPU
Intel i7 4820K @4.5GHz
Graphics
ATI Radeon HD 7950
Mac
Classic Mac
Mobile Phone
  1. iOS
I rebooted. No gibberish, but booting stops when the bar is in the middle. Any ideas?
EDIT: fixed that too. But booting is quite slow.
EDIT2: Slow booting solved too. Thanks guys!

can you share how exactly did you do it?
 
Joined
Nov 14, 2014
Messages
47
Motherboard
Z97X-UD3H
CPU
i7-4790K
Graphics
RX 580 + HD4600
Booted with -x GraphicsEnabler=No and installed again the boot loader and Extras folder to EFI partition. Apparently I've messed up the first time.
 
Joined
Mar 17, 2012
Messages
106
Graphics
Nvidia Quadro K2000m
Mobile Phone
  1. Android
Hello,

ThX for the tuto.

Why when i re mount my EFI partition later (than tweaks) everything in disappeared?
 
Joined
Nov 15, 2014
Messages
3
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
Hi Guys,

I recently tried this guide, and whenever I boot, it gets hung up upon booting. The 'Read HFS+ Files' just stop. I see that when I boot from the USB (which I can do), it shows me booting from HDD 0,1 whereas the EFI partition is trying to read from 0,2. Is there any way I can change the EFI partition to read from 0,1?

Any help is appreciated!
 
Joined
Jun 14, 2010
Messages
2
Motherboard
GA-Z77MX-D3H
CPU
3570K
Graphics
ATI 6850
Mac
Classic Mac
Mobile Phone
i have one problem, when i try to install new options or updates to the mounted efi partition with multibeast, multibeast cancels with error !?

05/20/15 21:40:11 - Installing 'Customize > System Definitions > Mac Pro > Mac Pro 5,1'
05/20/15 21:40:11 - Install of '/Users/milo/Desktop/MultiBeast - Yosemite Edition 2/MultiBeast.app/Contents/Resources/MacPro5,1.pkg' failed.
'installer: Error trying to locate volume at /Volumes/EFI
'. Exiting.

/Volumes/EFI is present and mounted
 
Joined
Jun 20, 2015
Messages
1
Mac
Classic Mac
Mobile Phone
My Setup:
ASUS G751JT
NVDIA GTX970m
16GB RAM
SSD with normal windows install
1TB HDD with two data partitions and a 100GB partitions for Yosemite at the end.

=====

Hello,
so I downloaded the script and used that to mount the EFI and copied over the Extra folder. Then I followed Step 5 to make this the EFI partition active. Not only does this not seem to work, but now I have no way of accessing my Windows 8.1 OS.

1. How to I do this process correctly?
2. How do I restore the ability to boot directly into windows? I tried using Disk Part from a Windows installer to reinstate the windows side as active but that evidently doesn't work.

Please help. Right now I can only get into Yosemite via my Unibeast USB. Windows is completely inaccessible.

:banghead:



EDIT:
I was able to restore Windows by wiping the SSD and using installation media (USB). I had to use a program called Rufus to correctly format the USB installer though because I initially created it on a BIOS system and Windows was returning an error saying that it could restore my disk image that was created on UEFI firmware. Weird, huh?

Still sorting out what went wrong with the terminal. May have followed the guide to a tee and accidentally performed fdisk commands on my SSD instead of the HDD where Yosemite/Chimera are located.
 
Joined
Jul 11, 2013
Messages
175
Motherboard
Z170 Asus Hero VIII
CPU
i7 6700K @47 1.29V
Graphics
AMD 390X Asus Strix
Mac
  1. MacBook Pro
Classic Mac
  1. Classic
Mobile Phone
  1. Android
Super Duper not copy to other disk EFI partition.

If you clone your hard disk - like me to do the test before - use this method again, even if you have your EFI with all extras an SSDT.

Devs could be very interesting in Clover days, to add in Multibeast or Unibeast a command to transfer all the files to EFI Partition.

Thanks!
 
Joined
Jun 28, 2015
Messages
48
Motherboard
ASRock h77 pro4/mvp
CPU
i7 3770
Graphics
ATI 7870
Mac
Classic Mac
Mobile Phone
People told me to use this guide to fix the boot0 gibberish error.

So, if I install Yosemite completely new and when I'm on the Desktop, do I have to do the Multibeast stuff first to install the Bootloader and all the drivers? Or do I have to do all these steps here bevore I use Multibeast?
 
Top