Contribute
Register

Install Bootloader and Extra to EFI Partition

Joined
Jan 13, 2010
Messages
681
Motherboard
GA-X58A-UD5 - 18G 1600Mhz DDR3 OSX-10.10
CPU
980x
Graphics
Radeon r9 290x + ATi 6850
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
Mobile Phone
  1. Android
Verifying DMI pool is very slow after moving to EFI folder.

Moving boot and /Extra to EFI went smooth. But getting very slow verifying DMI pool now.

I checked all my AWARD BIOS settings,even flashed a newer BIOS, and I only get the issue booting from the drive I moved boot and /Extra to.

When booting from other drives there is no delay on DMI pool.

The drive I am booting from is intel SSD 80G with Yosemite (GPT journaled) installed on it and nothing else. It is plugged into Sata0 and even if I remove all other drives I still get the delayed verifying DMI pool. The system does boot but is very slow about 20-30 second delay at DMI pool message.

Any thoughts?

r.
 
Joined
May 15, 2013
Messages
5
Motherboard
Lifebook P771
CPU
Intel(R) Core(TM) i7-2617M CPU @ 1.50GHz
Graphics
Intel HD3000, 1280 x 800
Mac
Classic Mac
Mobile Phone
I followed this guide three times again and again. My system tries hard disk, but system doesn't start. I still have to use usb stick. System is yosemite, and it's booting perfectly via usb. from hdd i even don't get the boot menu displayed. via usb i can choose to boot from usb or hdd. I'm stuck now. Any help would be appreciated. thanks in advance
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,477
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Other
I followed this guide three times again and again. My system tries hard disk, but system doesn't start. I still have to use usb stick. System is yosemite, and it's booting perfectly via usb. from hdd i even don't get the boot menu displayed. via usb i can choose to boot from usb or hdd. I'm stuck now. Any help would be appreciated. thanks in advance

Check that the bootloader is installed. boot into OS X and run MultiBeast - select only the bootloader and try this process again. Make sure that you are using the correct disk partition for your installation. This guide uses disk0s1. If you have windows installed first then this may be different in your installation.
 
Joined
May 15, 2013
Messages
5
Motherboard
Lifebook P771
CPU
Intel(R) Core(TM) i7-2617M CPU @ 1.50GHz
Graphics
Intel HD3000, 1280 x 800
Mac
Classic Mac
Mobile Phone
Check that the bootloader is installed. boot into OS X and run MultiBeast - select only the bootloader and try this process again. Make sure that you are using the correct disk partition for your installation. This guide uses disk0s1. If you have windows installed first then this may be different in your installation.

I did so. I reinstalled chimera, all drivers, and the problem persists. Here's my log:
Code:
[FONT=Menlo]AdminLs-MacBook-Pro:~ adminl$ diskutil list[/FONT]
[FONT=Menlo]/dev/disk0[/FONT]
[FONT=Menlo]   #:                       TYPE NAME                    SIZE       IDENTIFIER[/FONT]
[FONT=Menlo]   0:      GUID_partition_scheme                        *500.1 GB   disk0[/FONT]
[FONT=Menlo]   1:                        EFI                         209.7 MB   disk0s1[/FONT]
[FONT=Menlo]   2:                  Apple_HFS YOSEMITE                499.2 GB   disk0s2[/FONT]
[FONT=Menlo]   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3[/FONT]
[FONT=Menlo]/dev/disk1[/FONT]
[FONT=Menlo]   #:                       TYPE NAME                    SIZE       IDENTIFIER[/FONT]
[FONT=Menlo]   0:     FDisk_partition_scheme                        *16.0 GB    disk1[/FONT]
[FONT=Menlo]   1:                  Apple_HFS USB                     16.0 GB    disk1s1[/FONT]
[FONT=Menlo]AdminLs-MacBook-Pro:~ adminl$ sudo -s[/FONT]
[FONT=Menlo]Password:[/FONT]
[FONT=Menlo]bash-3.2# newfs_hfs -v EFI /dev/disk0[/FONT]
[FONT=Menlo]disk0    disk0s1  disk0s2  disk0s3  [/FONT]
[FONT=Menlo]bash-3.2# newfs_hfs -v EFI /dev/disk0s1 [/FONT]
[FONT=Menlo]Initialized /dev/rdisk0s1 as a 200 MB case-insensitive HFS Plus volume[/FONT]
[FONT=Menlo]bash-3.2# mkdir /Volumes/EFI[/FONT]
[FONT=Menlo]bash-3.2# mount_hfs /dev/disk0s1 /Volumes/EFI/[/FONT]
[FONT=Menlo]ash-3.2# cd /Volumes/USB/usr/standalone/i386/[/FONT]
[FONT=Menlo]bash-3.2# ls[/FONT]
[FONT=Menlo]EfiLoginUI    boot        boot.efi    boot0        boot0md        boot1h[/FONT]
[FONT=Menlo]bash-3.2# fdisk -f boot0 -u -y /dev/rdisk0[/FONT]
[FONT=Menlo]bash-3.2# dd if=boot1h of=/dev/rdisk0s1 [/FONT]
[FONT=Menlo]2+0 records in[/FONT]
[FONT=Menlo]2+0 records out[/FONT]
[FONT=Menlo]1024 bytes transferred in 0.039035 secs (26233 bytes/sec)[/FONT]
[FONT=Menlo]bash-3.2# cp boot /Volumes/EFI/[/FONT]

and content of EFI-Extra Folder
Code:
[FONT=Menlo]bash-3.2# mkdir /Volumes/EFI[/FONT]
[FONT=Menlo]bash-3.2# mount -t hfs /dev/disk0s1 /Volumes/EFI[/FONT]
[FONT=Menlo]bash-3.2# find /Volumes/EFI/[/FONT]
[FONT=Menlo]/Volumes/EFI/[/FONT]
[FONT=Menlo]/Volumes/EFI//.fseventsd[/FONT]
[FONT=Menlo]/Volumes/EFI//.fseventsd/0000000000b152bb[/FONT]
[FONT=Menlo]/Volumes/EFI//.fseventsd/0000000000b152bc[/FONT]
[FONT=Menlo]/Volumes/EFI//.fseventsd/fseventsd-uuid[/FONT]
[FONT=Menlo]/Volumes/EFI//boot[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/.DS_Store[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/modules[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/modules/HDAEnabler.dylib[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/modules/Keylayout.dylib[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/org.chameleon.Boot.plist[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/smbios.plist[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/.DS_Store[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/background.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/boot.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_befs.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_befs_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_cdrom.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_cdrom_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_ext3.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_ext3_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_fat.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_fat_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_freebsd.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_freebsd_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_generic.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_generic_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_leo.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_leo_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_lion.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_lion_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_mav.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_mav_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_ml.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_ml_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_sl.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_sl_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_tiger.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_tiger_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_yos.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsplus_yos_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_leo.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_leo_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_lion.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_lion_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_mav.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_mav_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_ml.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_ml_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_sl.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_sl_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_tiger.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_tiger_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_yos.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_hfsraid_yos_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_ntfs.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_ntfs_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_openbsd.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_openbsd_o.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_scroll_next.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_scroll_prev.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/device_selection.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/font_console.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/font_small.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/logo.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_boot.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_help.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_ignore_caches.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_ignore_caches_disabled.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_memory_info.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_selection.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_single_user.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_single_user_disabled.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_verbose.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_verbose_disabled.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/menu_video_info.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/progress_bar.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/progress_bar_background.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/text_scroll_next.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/text_scroll_prev.png[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/theme.plist[/FONT]
[FONT=Menlo]/Volumes/EFI//Extra/Themes/Default/thumb.png
[/FONT]
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,477
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Other
James - What text is coming up on screen when you try to boot direct from the HDD? Boot0 or Boot1? I assume that the BIOS is set to boot the HDD as PO1
 
Joined
May 15, 2013
Messages
5
Motherboard
Lifebook P771
CPU
Intel(R) Core(TM) i7-2617M CPU @ 1.50GHz
Graphics
Intel HD3000, 1280 x 800
Mac
Classic Mac
Mobile Phone
James - What text is coming up on screen when you try to boot direct from the HDD? Boot0 or Boot1? I assume that the BIOS is set to boot the HDD as PO1

Wether boot0 not boot1, the lifebook boots, access harddisk and afterwards bios boot menu appears. choosing harddisk produces black screen and again bios boot menu... is there anything i can do to debug? is the boot file currupt?
 
Joined
Dec 7, 2014
Messages
29
Motherboard
gigabyte z97x ud3h bk rev 1.1
CPU
i7 4770k
Graphics
Nvidia gtx 970 HOF
Mac
Classic Mac
Mobile Phone
After following this guide I get boot0 error at reboot. What should I do? I did same things James did.
I have an asrock z97 and i7 4770k
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,477
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Other
Joined
Nov 14, 2014
Messages
47
Motherboard
Z97X-UD3H
CPU
i7-4790K
Graphics
RX 580 + HD4600
HELP! While typing the last command "rm -R /boot /Extra" I get the following message: "rm: /Extra: No such file or directory". What should I do?
EDIT: That's because I've removed the Extra file manually! No boot file on the system drive though, there is one on the EFI. Is that OK?
 
Joined
Nov 14, 2014
Messages
47
Motherboard
Z97X-UD3H
CPU
i7-4790K
Graphics
RX 580 + HD4600
I rebooted. No gibberish, but booting stops when the bar is in the middle. Any ideas?
EDIT: fixed that too. But booting is quite slow.
EDIT2: Slow booting solved too. Thanks guys!
 
Top