Contribute
Register

Info on Some Fixes for Gigabyte ga-z77x-ud5h Motherboard + My Build Story

Joined
Dec 14, 2013
Messages
2
Mac
Classic Mac
Mobile Phone
Alright, I recently finished my very first build and it's been working great! Being my first build, I went with the recommended motherboard for the 1155 socket. However, there were a few wrinkles that I had to iron out, and I thought I might spare some other first time builders using this mobo a little frustration (most senior builders will probably know all of these problems :p). Might as well get my build out of the way first so here it is:

Gigabyte ga-z77x-ud5h Rev. 1.1
Intel 3770K 3.5 Ghz Turbo 3.9 Ghz
Cooler Master Hyper 212 EVO
2 x 8GB G. Skill 1600 mhz RAM
EVGA Superclocked GTX 770
Seagate 1TB 7200 RPM (Windows Drive)
WD 1TB 7200 RPM Blue (Mac Drive)
Corsair HX 750 Watt PSU

Ok, now that that's out of the way, I thought I might tell you guys some of the troubles/oddities that I had with this build, and how I ended up fixing them.

1. Alright, first up is the network driver hiccup. What's interesting about this board is that it's network capabilities work out of the box with OS X 10.9.0. However, just to be safe, I installed the Atheros driver whilst doing my MultiBeast configuration. The Gigabyte site says that it uses Intel gigabit drivers AND Atheros Ethernet controllers, but I thought that you were only supposed to install one. Upon reboot, the Ethernet no longer worked! I wasn't sure why it wasn't working, so I decided to install another driver for the Intel gigabit one and, viola, the Ethernet was working again immediately after quitting MultiBeast! I almost did another install of OSX to try and fix it and just not install the network driver but turns out that wasn't necessary (yes, I know I could've probably attempted to remove the driver somehow but I couldn't really figure out how to do that, and I didn't really have that much patience after a bunch of other troubles I'll explain at the bottom of this post). In short: If you are about to install drivers: Don't install the network drivers AT ALL. or If you are having network issues after installing: Install BOTH the Atheros AND Intel drivers, otherwise your Ethernet won't work! (Correct me if you've done this build and found otherwise).

2. Secondly, I have, or more accurately had, the rather annoying sleeping issue that this motherboard appears to have. I received the revision 1.1 version from my Amazon order, and it appeared to work flawlessly. The only thing that I noticed was that my computer would magically turn on overnight after being put to sleep. At first, I looked up this problem on Google and was greeted with answers saying that sleep mode didn't work normally on most desktops. I bought it (even thought something inside of me was saying that that wasn't the case), and just lived with the problem. The thing that motivated me to really start searching was when I booted it up today from sleep and it got stuck in an infinite power cycle loop. This first happened when I was using windows, but I tested it on Mac and got the same result. After searching around, I actually found the solution on this very forum! Apparently, the problem resides in the BIOS for some reason. I updated it to version 15o and sleep is working great again! So, the solution is:If you are having problems sleeping your computer, update your BIOS to version 15o, and it should fix the problem.

The following is simply my story of this build so that someone else may understand what they might expect to encounter while putting together their build. You may gain some background info if this is your first time, or if you're a senior builder, you might be able to give me some feedback after reading my build story after reading this :D:
Well, that's what I've encountered up until now and if you're interested, here's my complete story so that you guys can get a complete understanding of my situation(there's a lot of noobish stuff in there so don't bash me please :angel:): So after considering all the parts for about 1 year, I finally decided to build my own rig. The main points why I decided to build my own were 1. The price and 2. Hackintosh compatibility I ordered all the parts as they went on sale for Black Friday, and eventually they all came in. I'd watched Newegg's series on how to build your PC so I built the whole thing following the instructions step by step. At first, I only had one HDD, and I wanted to install Windows on it first and then install OS X on a separate partition. So I loaded Windows on my rig, and ran a bunch of tests to make sure that the thing was working properly and it was! The feeling of accomplishment :headbang:! I forgot about installing OS X for a while, and just enjoyed my PC. Ok, here's where it starts to get interesting. Eventually, I decided to install OS X so I downloaded a copy of OS X Mavericks off of an external source (Not the app store) and attempted to make the flash drive with my friend's mac (the reason I did it off the external source was because I wanted to be prepared so that when my friend came over with the mac later that day we would be instantly ready, no I didn't ask him to pre-download it on the mac because his internet is slow and that download would've clogged it up). Well, the unofficial version didn't work and UniBeast kept giving me an error, so we tried to install mavericks directly onto the drive from the mac with a special HDD enclosure that my friend had. During the process of taking out my HDD from my case, I accidentally broke the SATA cable somehow cause the end of it broke off on the SATA part of the HDD :evil: The SATA cables that come with the z77x-ud5h are really fussy for some reason, and don't come out without applying force with a screwdriver to the little thing that you're supposed to push down, and tugging really hard. I found this out when I had to remove the broken SATA cable from my build. Taking it out of the SATA port on my motherboard was a lot harder than just breaking it off on a HDD. Eventually, I used the screwdriver trick and pulled hard and it came off. Not sure why this is, and that resulted in me breaking that cable on accident. Turns out, the enclosure couldn't supply enough power to my 3.5" drive, as he bought it for his laptop drive, so it was useless :p. In the end, I did it with the original version off of the app store, and it worked :p So now it comes to the installation, and being the nutcase that I am, I didn't realize that I couldn't install OSX on a drive that had already been formatted by windows :banghead: (I later found out about the MBR patch, but when I had searched at that time, nothing came up. Probably not using the right keywords :p) Therefore I backed out of the install after realizing that I couldn't set the drive to GUID Partition Table without completely formatting my windows drive. Guess what happened next?! Somehow, booting from the USB had managed to delete my boot manager for windows, and I couldn't boot windows either!!! So I just decided to format the drive, and install mac, then install windows on a partition of that drive since I knew that that would work. Installed mac, and installed drivers so that I could boot. Hit the disk0 error and looked that up. Found some other guide on how to fix it instead of the tonymac one and didn't even bother fixing it since it was so ridiculously crazy and stuff. I booted from the USB to find that now my network drivers were also broken, and just decided that it was hopeless. Installed windows again and just rolled with it for a while. Eventually, I decided to get another HDD so that there was no way that I could break my windows installation whiled installing OSX this time. Got a WD HDD and had to install it in my case. Used the screwdriver trick and the SATA cable came loose. I ended up plugging the WD HDD into the "Disk 0" position and the Seagate one back where I originally had it which was in the "Disk 1" position (you'll see how this affects something else later). This time, I had a lot more patience (although ironically less time). Finally found a video on how to do it that was just the tonymacx86 tut in video form and fixed the disk0 issue (at first I was really confused, but then I realized that I had typed a '1' instead of an 'i' in the command XD). I also resolved the network issue with the method that I listed above, and everything was good to go! Today, I fixed my sleeping problem with the solution mentioned above, and that included learning how to flash a BIOS and reset it to operating condition after you've flashed it. One interesting thing that I found during this was that when I went to set the boot order, the Seagate HDD wasn't showing up in the place where you can change your boot order, but it was showing it in the place where you can see all your connected devices. Eventually I found out that the BIOS only displays the HDD that you've set to be your primary drive on the boot priority screen, and if you recall, I said I had put the WD HDD into the "Disk 0" SATA port. I tried searching it online but to no avail, and eventually figured out that the BIOS only displays one drive in the boot priority. So, I just set the Seagate, which has my windows install, as the primary drive, and then I could set it to automatically boot to windows instead of OSX. This brings us to me typing my complete experience on this page :D

Hope that this post doesn't look like a wall of text XD. I had a lot of fun building my own hackintosh, and I gained a lot of experience along the way as well as new knowledge on computers. I had previously considered myself rather adept at working with computers and now I know that I still have a lot to learn. tonymacx86 has been a great help to me and I hope I'm helping someone out with the solutions I gave above. :headbang:Happy early new year 2K14!:headbang:
 
Top