Contribute
Register

[INFO] ASUS ROG STRIX G531GT bios mod and hackintosh Mojave and/or Catalina install

Joined
Aug 22, 2018
Messages
367
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I installed Monterey and when starting I got this error:
20210925_093721.jpg
 
Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
it seems that is not completely installed, how did you performed the install? the reboot message looks alike a scheduled reboot during install
 
Joined
Aug 22, 2018
Messages
367
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I tried multiple times starting it. I used the installer in Big Sur and installed on a seperated partition. Or am I supposed to start Big Sur after installing..? I started using the new partition.
 
Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
I think does not work on other partition, you need to install other bigsur on that partition first then upgrade
 
Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
but note, i never used or installed Monterey, my EFI does not support yet Monterey, however has all required variables compiled-in and can boot in secure mode
 
Joined
Aug 22, 2018
Messages
367
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I tried to use the installer this time. It's stuck in a loop of this text. Did you get the same error?
20210925_170420.jpg
 
Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
No, a different boot loop, in regards some services not running and not found, your screen show something about bluetooth, maybe you remove all kexts just to boot the installer. I am not having the Asus again, so i am not able to test anything.
 
Joined
Aug 22, 2018
Messages
367
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
You don't have it with you or you don't have it anymore? I didn't remove any kexts if that's what you think. If it's meant as advice I could test that.
 
Joined
Oct 19, 2019
Messages
688
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
  2. iOS
  3. Other
You don't have it with you or you don't have it anymore? I didn't remove any kexts if that's what you think. If it's meant as advice I could test that.
Y don't have access as my wife is actively using the laptop, i moved my SSD drive on other laptop. The kexts from my EFI are for original WiFi card, if you replaced that card probably will not work, also i didn't tested Monterey, only Mojave, Clover and BigSur
If you tested to install from BigSur. i suggested you to test to install first BigSur on that extra partition, then use in place upgrade to upgrade to Monterey, could work, but probably not.
 
Joined
Aug 22, 2018
Messages
367
Motherboard
Asus ROG Strix G531GT
CPU
i7-9750H/HM370
Graphics
GTX 1650, UHD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
I did that only I didn't upgrade Big Sur, but installed it on another partition. That's where I got the error in the first picture
 
Top