Contribute
Register
Joined
Jan 5, 2020
Messages
196
Motherboard
Gigabyte Z390 Gaming M
CPU
i9-9900K
Graphics
RX 590
Mac
  1. MacBook Pro
The flashes for Alpine cause video pass threw to not function so you probably do not want to flash it. Try removing the cable and placing a jumper between pin 3 and 5. I know that when I use the cable it breaks my sleep.

P.S. Most reports say the thunderbolt display will work on warm boot the entire time on the Titan.

Is Pin 5 the one closest to the PCI connector? I may give that a try.

I had mixed results with TR. Sometimes the display would say on during a restart, other times not. Sometimes it would come back on after sleep, sometimes I would have to unplug the thunderbolt cable and plug back in again to get the display to turn back on again. I saw you had better results with firmware for the designare board with your TR AIC. I may try that one instead of the one I am using now which is GC-TITAN-RIDGE-NVM23-Elias64Fr.bin.
 
Joined
Jul 13, 2016
Messages
2,716
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Is Pin 5 the one closest to the PCI connector? I may give that a try.

I had mixed results with TR. Sometimes the display would say on during a restart, other times not. Sometimes it would come back on after sleep, sometimes I would have to unplug the thunderbolt cable and plug back in again to get the display to turn back on again. I saw you had better results with firmware for the designare board with your TR AIC. I may try that one instead of the one I am using now which is GC-TITAN-RIDGE-NVM23-Elias64Fr.bin.
Pin 5 is the one farthest away from the PCI-E slot. The best flash IMO for the Titan is NVM33 for the designar Z390 motherboard. I have been using that one for about 9 months I tested all the other choices and found that one gave the best implementation I want to say 23 was the worst of them all.
 
Joined
Jan 5, 2020
Messages
196
Motherboard
Gigabyte Z390 Gaming M
CPU
i9-9900K
Graphics
RX 590
Mac
  1. MacBook Pro
Pin 5 is the one farthest away from the PCI-E slot. The best flash IMO for the Titan is NVM33 for the designar Z390 motherboard. I have been using that one for about 9 months I tested all the other choices and found that one gave the best implementation I want to say 23 was the worst of them all.

No luck with the jumper instead of the THB-C header. The card wasn't even recognized in the BIOS anymore. Strange.
 
Joined
Jul 13, 2016
Messages
2,716
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
No luck with the jumper instead of the THB-C header. The card wasn't even recognized in the BIOS anymore. Strange
Here is a picture of my alpine ridge, the wire you can not see is just a loop I have it taped to the card. Honestly it should not matter since the cable only does a few things, the first is to power the card on (that is what the jumper does), second is control sleep that is why you remove it to allow the OS to control sleep. I normally use the alpine in a system that does not have a THB-C header, but my Titan is flashed with nvm33 and uses the jumper wire on 3-5 and the bios still sees the card is there.

IMG_0160.jpg
 
Joined
Jan 5, 2020
Messages
196
Motherboard
Gigabyte Z390 Gaming M
CPU
i9-9900K
Graphics
RX 590
Mac
  1. MacBook Pro
Here is a picture of my alpine ridge, the wire you can not see is just a loop I have it taped to the card. Honestly it should not matter since the cable only does a few things, the first is to power the card on (that is what the jumper does), second is control sleep that is why you remove it to allow the OS to control sleep. I normally use the alpine in a system that does not have a THB-C header, but my Titan is flashed with nvm33 and uses the jumper wire on 3-5 and the bios still sees the card is there.

View attachment 502701
I definitely connected the correct pins. I used one of the elegoo F-F jumper wires. I tried a couple different ones after the first one didn't seem to work. I'll try it again when I feel like messing with it some more.
 
Joined
Jul 13, 2016
Messages
2,716
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
I definitely connected the correct pins. I used one of the elegoo F-F jumper wires. I tried a couple different ones after the first one didn't seem to work. I'll try it again when I feel like messing with it some more.
Guess you do not have the bang your head against it till it works bug! I could not tell you that the jumper works for sure on an unflashed card since both my cards are flashed and I did not use the jumper till after!
 
Joined
Jan 5, 2020
Messages
196
Motherboard
Gigabyte Z390 Gaming M
CPU
i9-9900K
Graphics
RX 590
Mac
  1. MacBook Pro
Guess you do not have the bang your head against it till it works bug! I could not tell you that the jumper works for sure on an unflashed card since both my cards are flashed and I did not use the jumper till after!


I tried to use the THB-C header cable to short pins 5-3, no luck either. Maybe it does need to be flashed or I need to run a separate 3V connection in from the SATA power. Not sure I am ready to try that one yet though.

I think the next thing I am going to try is flashing my TR card again with the firmware you like to see if that works any better than 23.
 
Joined
Jul 13, 2016
Messages
2,716
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
I think the next thing I am going to try is flashing my TR card again with the firmware you like to see if that works any better than 23.
It is not a matter of like it is just a matter of what works and what does not. Early on I found that 33 just worked where the others did not work as well. In the end as far as I can tell it works as well as a real mac. However, I do think there are some issues with cold boot and some devices.
 
Joined
Jan 5, 2020
Messages
196
Motherboard
Gigabyte Z390 Gaming M
CPU
i9-9900K
Graphics
RX 590
Mac
  1. MacBook Pro
It is not a matter of like it is just a matter of what works and what does not. Early on I found that 33 just worked where the others did not work as well. In the end as far as I can tell it works as well as a real mac. However, I do think there are some issues with cold boot and some devices.


I just installed the DESIGNARE-Z390-NVM33-Elias64Fr.bin firmware on my TR card. I'll let you know how it goes. So far working OK, although it woke from sleep unexpectedly. Hopefully not a indicator of a new problem.

When you switch firmware, were you also using the corresponding SSDT generated using HackinDROM?
 
Joined
Jul 13, 2016
Messages
2,716
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
Vega 64
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
I just installed the DESIGNARE-Z390-NVM33-Elias64Fr.bin firmware on my TR card. I'll let you know how it goes. So far working OK, although it woke from sleep unexpectedly. Hopefully not a indicator of a new problem.

When you switch firmware, were you also using the corresponding SSDT generated using HackinDROM?
I use these files but you should customize it for your system using the following guide:

 

Attachments

  • Archive.zip
    2.7 KB · Views: 13
Top