Contribute
Register
Joined
Nov 26, 2012
Messages
1,743
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
FYI, the rebuild of this machine (2nd unit in my build signature) involved a lot of work to get the TB card (slot 4, Titan Ridge) working and recognized in BIOS and Windows 10. A couple weeks have gone by and now my TB card is no longer recognized in BIOS or Windows.
I have an unproven anecdote somewhere around here about BIOS rot. Or maybe the card is dead. Or the AIC bus is dying, or the MOBO itself is dying. IDK. Strange stuff. I'll also may try reinstalling the Alpine Ridge card, though I think that one only let me use one TB3 port at a time in OS X, though daisy chaining still worked.

Anyway, I'll pull everything out on Saturday and flash the BIOS. Does anyone have a preferred BIOS for the Gigabyte Z370 Aorus Gaming 7, Rev. 1?
If you are referring to the BIOS update, I am using Gaming 5 (IDK if this is the same for "7") F11 is the limit. I tried F12 when it first came out and it did not work. It has been a while so I do not remember what happened.
 
Joined
Nov 26, 2012
Messages
1,743
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thank you. I will give it a try when I get my hack working again.
Since this post, I have re-installed my 10.14.6 drive since the 10.15.3 was not sleeping at all, forced or automatically and I was unable to rectify the problem. 10.14.6 has auto sleep and forced sleep but it wakes automatically anywhere from 5 minutes to 1.5 hours. I have made a list of steps that I used that I will post later to see if anyone has some insights.
 
Joined
Jul 26, 2018
Messages
748
Motherboard
Asus Z370-A Prime II
CPU
i7-8700
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Have you tried this in Hackintool?

Screen Shot 2020-02-12 at 10.17.14 AM.png
Screen Shot 2020-02-12 at 10.18.38 AM.png
 
Joined
Sep 21, 2013
Messages
781
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
  6. Quadra
  7. SE/30
Mobile Phone
  1. iOS
If you are referring to the BIOS update, I am using Gaming 5 (IDK if this is the same for "7") F11 is the limit. I tried F12 when it first came out and it did not work. It has been a while so I do not remember what happened.

It's a different BIOS for the Ultra Gaming 7. Here's the link for the patch by @mattystonnie that I forgot about for the later BIOS updates: https://www.tonymacx86.com/threads/fix-for-boot-hangs-after-bios-update-acpi-patch.275091/page-31
 
Joined
Nov 26, 2012
Messages
1,743
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
Nov 26, 2012
Messages
1,743
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
It's a different BIOS for the Ultra Gaming 7. Here's the link for the patch by @mattystonnie that I forgot about for the later BIOS updates: https://www.tonymacx86.com/threads/fix-for-boot-hangs-after-bios-update-acpi-patch.275091/page-31
@jiffyslot - I found the patch. :crazy: Will look at that tomorrow. Enough headaches for one day (Not related to the Hack) Must get back to making Art. Now I just have to figure out how to rescue my 10.15.3 drive from "No Sleep At All"
 
Last edited:
Joined
Nov 26, 2012
Messages
1,743
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS

Attachments

  • Screen Shot 2020-02-13 at 5.25.21 PM.png
    Screen Shot 2020-02-13 at 5.25.21 PM.png
    133.4 KB · Views: 77
Joined
Nov 26, 2012
Messages
1,743
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ah, but there's a hitch. Even after running Hackintool, the 10.15.3 drive still will not stay in sleep, nor will it sleep automatically. So the problem persists. I thought that if I copied the functioning EFI folder from 10.14.6 to the Catalina drive that that would fix the problem. Not so much. Very confusing. I'm back to Mojave and will stay here for now. Maybe I will create a fresh install on a blank SSD one day when I have nothing else to do.
 
Joined
Sep 8, 2011
Messages
73
Motherboard
Asus Rampage VI Extreme
CPU
i9-7960X
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
In this Link uploaded SSDT files for modified Titan Ridge AIC.
 
Top