Contribute
Register
Joined
May 30, 2016
Messages
983
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
I notice the SSDTs our efforts are all derived from are from working X299/Skylake-X builds. I wonder if it's worth testing iMacPro1,1 SMBIOS with Z170/270/370 builds to see if it enables hotswap with these SSDTs without affecting other features (like quicksync) Might try it when I have time...
 
Joined
Aug 17, 2017
Messages
308
Motherboard
ASUS Prime X299 Edition 30
CPU
i9-10980XE
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
May 30, 2016
Messages
983
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Original iMac Pro IOReg
Download - Use IOReg 3.0.2 to open it

In following the insanelymac thread I noticed you had problems with Above 4G decoding enabled. If you want to use Above 4G decoding, try using Aptiomemoryfix.efi instead of the OSXAptioDrv/2/3/ etc drivers :)
 
Joined
Aug 17, 2017
Messages
308
Motherboard
ASUS Prime X299 Edition 30
CPU
i9-10980XE
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
In following the insanelymac thread I noticed you had problems with Above 4G decoding enabled. If you want to use Above 4G decoding, try using Aptiomemoryfix.efi instead of the OSXAptioDrv/2/3/ etc drivers :)
Problem already solved after the last clean installation of 10.13.4 :)
However the 4G decoding does not seem to bring differences
 
Joined
Aug 1, 2012
Messages
605
Motherboard
Asus ProArt Z690 Creator
CPU
i7-12700KF
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Starting from the beginning ...
The goal is to make the hotplug work for Gigabyte Alpine Ridge.
The tests were performed with two chain-connected Thunderbolt devices (UAD Satellite and Apollo Twin), and this hardware:

What adapter did you use to connect your UAD devices to Gigabyte Alpine Ridge?

I read this article: https://www.studiocare.com/blog/uad-thunderbolt-interfaces-now-compatible-with-windows-10-systems/
where it seems most TH UAD devices are not compatible with Apple TH3 to TH2 adapter when it has used on Windows (PCs) machines. Probably you can go and give a try with the suggested adapters in the article.
 
Joined
Aug 17, 2017
Messages
308
Motherboard
ASUS Prime X299 Edition 30
CPU
i9-10980XE
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
What adapter did you use to connect your UAD devices to Gigabyte Alpine Ridge?

I read this article: https://www.studiocare.com/blog/uad-thunderbolt-interfaces-now-compatible-with-windows-10-systems/
where it seems most TH UAD devices are not compatible with Apple TH3 to TH2 adapter when it has used on Windows (PCs) machines. Probably you can go and give a try with the suggested adapters in the article.
I currently use the Thunderbolt 3/2 Apple adapter without problems. When I installed the Alpine Ridge drivers in Windows, everything worked fine with the adapter, also hotplug (only in windows)!
 
Joined
Aug 1, 2012
Messages
605
Motherboard
Asus ProArt Z690 Creator
CPU
i7-12700KF
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Try my kext with this clover hotpatch:
(note, you'll have to replace the PciADDr value with the address your card is assigned, which should be visible in the clover boot log)

I tried but not sure if the address is correct... in clover boot.log there is no explicit reference to a Thunderbolt device like mine CG-Alpine Ridge but I used the 1578 identification to derive the PCI address (I got the 1st one out of 4).

Anyway I’ve already had the hot plug with ssdt type B, but the hdd or usb stick doesn’t survive the sleep/wake cycle... I still get a “disk not ejected properly” error.

But UAD Apollo Twin is still extremely luggish and unstable. I cannot use under these conditions...
 
Top