Contribute
Register

In need of a little audio help

Status
Not open for further replies.
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Dear Toleda

I've been at this for way too long now not to ask for a little Help. And need to start video editing instead of kext editing as soon as possible. I did read all the sound related threads tried the different injections methods (with, withou dsdt etc), yet so far: I can't get audio from my green jack jack (did read the gree jack thread too), nor can I get hdmi sound. Since I want to be able to set-up 5.1 surround (analog) as well, seems i'm gonna have to find a way to get it through the green port some how.

-I got hdmi once but without any onboard sound
-On a first install attempt from a 10.8.3, and I did get sound from the green jack and i think it was with the native apple hda kext and thick i used 5MB 5.4.3 at the time.

Any how, with the amount of guides revisions and the number of posts in each this is really getting confusing for me...Sorry. I've been trying to achieve this for over a week now.

I installed 10.8.5 from a clean install (needed to upgrade osx on my MacBookPro) following slugnet's i5-3570k z77-ud5h as well as other (enrogbilias) mobo threads. Currently i can get sound from the orange or black output of the board. Tried to install with MB 5.5.2, 5.5.1. I've included the required files so if someone could try to help me resolve the issues and or point me inn the right directions to set up the rest i'd be much obliged. Don't want to use the head banging emoticon as this is my first post but that's what i've been doing this week. Hell Yeah!

I hope i'm placing this thread in the right place but could not seem to do it from sumbit audio problems thread. kindly move it

P.S. the last screen shot replaces the one in the zip file sorry.
So should i use

ud5h rev 1.1 r 14 (flashed)
i5-3570k z77 oc'ed to 4.2
10.8.5 from app store
realtec is 898 on tho board
I have DSDT ssdt (dont really know it it's still needed but)
 

Attachments

  • DSDTHGcopy.aml.zip
    15.7 KB · Views: 34
  • hg42occopy.ioreg.zip
    638 KB · Views: 29
  • Screen Shot 2013-10-03 at 8.49.02 PM.png
    Screen Shot 2013-10-03 at 8.49.02 PM.png
    124.9 KB · Views: 86
  • screenshots.zip
    265.1 KB · Views: 38
  • SSDTHGCOPY.aml.zip
    613 bytes · Views: 34

toleda

Moderator
Joined
May 19, 2010
Messages
22,960
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I can't get audio from my green jack jack (did read the gree jack thread too), nor can I get hdmi sound. Since I want to be able to set-up 5.1 surround (analog) as well, seems i'm gonna have to find a way to get it through the green port some how.
Notice in your screenshot, 2 Intel High Definition Audio entries; that is your problem.
Remove S/L/E/HDAEnabler1.kext. Wait 1 minute and restart.

Reply with new IOReg.
 
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Thanks for you kind reply

deleted - waited - restarted and as you said only have one intel now. Still no audio in green rear jack and no hdmi sound on on tv screen. New IO provided. Perhaps other steps are needed for me to set up things in either dsdt ot midi or I have a board that needs soldering? Audio HDMI does not appear in the sound panes options. Do I have to create an agregate device in midi for HDMI audio? I've noticed the 5.1 one i tried to set up appears in it now...
 

Attachments

  • Screen Shot 2013-10-04 at 5.21.04 PM.png.zip
    117.1 KB · Views: 31
  • hg42oc_2.ioreg.zip
    624.3 KB · Views: 35

toleda

Moderator
Joined
May 19, 2010
Messages
22,960
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Black and orange port work for computer speakers...and have always worked. Just trying to figure out the rest : green port, front port and hdmi audio to tv. I thought i did install HDMI audio so what you are telling me is I haven't?

HG
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,960
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Just trying to figure out the rest : green port, front port and hdmi audio to tv. I thought i did install HDMI audio so what you are telling me is I haven't?
Your rev 1.1 is behaving like a rev 1.0; no green port audio.
Wrong Audio ID for HD4000 HDMI audio, edit dst/HDEF/layout-id to 0x03, 0x00, 0x00, 0x00.
HD4870 needs a framebuffer edit. see Lion HDMI Audio - Part 3a: Kext Edits - AMD
 
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
edit dst/HDEF/layout-id to 0x03, 0x00, 0x00, 0x00

Ok for that method = open dsdt with mac iasl patch with
file://localhost/Users/GBHackPro/Desktop/ML_hdef_audio_ids_v1-1/hdef_audio_id_3.txt

repair permissions and caches then restart? Am i right.
 
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
And to be clear the hdmi sound i'm trying to get is from the hd4000 graphics, not from the radeon 4870 ( but i'll look into these biffers still. New Ioreg with layout id 3 + sc shot. At this moment I have neither enabler 898 or hdaenabler-1 installed.file://localhost/Users/GBHackPro/Desktop/hg42oc_V3_aid3.ioreg
file://localhost/Users/GBHackPro/Desktop/Screen%20Shot%202013-10-05%20at%201.34.33%20PM.png
 
Joined
Jan 24, 2013
Messages
182
Motherboard
AsRock Taïchi Z-370
CPU
i7-8700K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Attachments sorry
 

Attachments

  • hg42oc_V3_aid3.ioreg
    2.5 MB · Views: 41
  • Screen Shot 2013-10-05 at 1.34.33 PM.png
    Screen Shot 2013-10-05 at 1.34.33 PM.png
    122.3 KB · Views: 80
Status
Not open for further replies.
Top