Contribute
Register

Impossible to shutdown Mojave. An infinite issue :-(

Joined
Jun 12, 2012
Messages
7
Motherboard
Gigabyte Z87X-UD5H - Kingston 16GB Ram 1600MHz
CPU
Intel Core i7 4770K 3.70GHz
Graphics
EVGA Nvidia GTX760
Hello there!
I know that hundreds of posts have been written about shutdown on Mojave.
So, I'm re-opening this issue again, because, after having tried every single method/solution provided by @CaseySJ or @MACAK and read all the 512 posts.

I followed word by word and double checked the Casey's guide to avoid any error but the only issue I'm unable to solve is the shutdown. It continues to restart by itself. when I hit "shutdown" button on Apple icon.

Here is my new baby for music production:

I9 9900K (not oc, for now)
Corsair H150i (no usb connected)
Z390 Designare (bios ver. F7 - untouched)
MSI RX580 Armor 8GB DDR5 (pci-e slot1 PCIEX16)
Crucial Sport AT 64GB (XMP profile 1 @ 3200Mhz)
Samsung 970 EVO Plus 1TB on M2P slot
2x Sandisk Ultra 3D 2TB (sata 1 & 2)
Startech PEX1394B3

Waiting for Fenvi T919 ( I don't know if buy it or not, 'cause I can use ethernet cable when needed)

Mojave 10.14.6.02 installed.

I don't need FaceTime, iMess and stuff like that.
Only music production & occasional internet connection for plug-ins authorization / update is my real goal.

------ ------- -------

What happened:
After post-installation completed (only mouse and keyboard connected) everything seemed to work properly. No issues.
I've only tested internet connection with ethernet cable for 3-4 hours to check random freeze I had in my previous build never solved. Finally this time no issues.

With nothing installed, sleep, wake, shutdown works flawlessly.

Then I installed my Startech Firewire card (tried on PCIEX8, PCIEX1_2, PCIEX4) and it was natively recognizabled on every slot.

BUT the shutdown doesn't work. N-O-T-H-I-N-G.

I tried all the suggestions listed in the mai thread and others but they don't worked for me. I don't know what to do anymore.


I tried fixing the problem checking on "Fix Firewire", but the next booting was locked.

Then I inserted my USB bootable, pressed F12, selected SSD, and Mojave started. At this time, I re-opened again config.plist with Clover Configurator and removed "Fix Firewire".

Result? System goes on desktop flawlessly (without USB stick), no issues at all, but shutdown still not working.

I tried Halt enabler alone: nothing on all slots.
I tried Halt enable + Fix Firewire: nothing on all slots.

Sincerely I'm pretty annoyed of rebooting the machine this way, and I don't want to press the power button for some seconds every time to shutdown it. I rebooted so many times that I fell down in panic when BIOS start screen disappeared. I was unable to access to bios pressing DEL or F12 button. Yes. Fortunately then I solved this thing.

I need to solve this issue before backup everything and then install all my music apps and libraries.

Does anybody help me?

I'm online. Let me know what you need.

Waiting for your help.
Thank you.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,814
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@Phoenix83

Some suggestions:
  • Set BIOS parameters again starting with Save & Exit --> Load Optimized Defaults. This sets various power parameters as well. BIOS parameters are listed in Post #1 of the Designare build guide.
  • Check "Fix Shutdown" in Clover Configurator --> ACPI.
  • Check that EmuVariableUefi.efi or EmuVariableUefi-64.efi is present in the CLOVER/drivers/UEFI folder.
  • Check that only one memory fix driver is present. We've replaced OsxAptioFix2Drv-free2000 with both of these:
    • OcQuirks-4.efi
    • FwRuntimeServices.efi
    • (These may be 2 files, but they work together and count as 1 memory driver.)
  • It may also be a good idea to install Clover RC scripts as described in Step 3, Bullet 9 of the Catalina Mini-Guide.
 
Joined
Jun 12, 2012
Messages
7
Motherboard
Gigabyte Z87X-UD5H - Kingston 16GB Ram 1600MHz
CPU
Intel Core i7 4770K 3.70GHz
Graphics
EVGA Nvidia GTX760
Thank you @CaseySJ !
I tried your suggestions.

BIOS parameters are exactly identical to your guide.

I followed your instructions:
- Fixshutdown ON (it was already ON)
- Emuvariableuefi64 OK
- Replaced OsxAptioFix2Drv.efi with OcQuirks-4.efi and FwRuntimeServices.efi
RC scripts installed as mentioned in the guide.

Shutdown doesn't work. KP appeared :(

See attached .jpg


UPDATE
Kernel Panic during shutdown continues, so I restored the previous settings using backup-ed EFI folder:
- Fixshutdown (always ON)
- replaced the newer OcQuirks-4.efi and FwRuntimeServices.efi with the OscAptioFix2Drv.efi

No KP during shudown, but the same shutdown still not working, exactly as before.

I preferred to restore what was previously in order not to add errors on errors. The problem continues to exist, but remains with the configuration of the first question with which I opened the thread.
 

Attachments

  • KP Shutdown.jpg
    KP Shutdown.jpg
    3 MB · Views: 41
Last edited:
Joined
Jun 12, 2012
Messages
7
Motherboard
Gigabyte Z87X-UD5H - Kingston 16GB Ram 1600MHz
CPU
Intel Core i7 4770K 3.70GHz
Graphics
EVGA Nvidia GTX760
I tried again and again but shutdown works only with Pci-e Firewire card disconnected. How can I solve?
 
Joined
Jun 12, 2012
Messages
7
Motherboard
Gigabyte Z87X-UD5H - Kingston 16GB Ram 1600MHz
CPU
Intel Core i7 4770K 3.70GHz
Graphics
EVGA Nvidia GTX760
@CaseySJ Any news?

Just to inform: I noticed that if I change CSM Support on Enable, then I'm unable to enter on BIOS... The build locks completely and I have to force Clear CMOS. It happened 3 times, and I don't want to risk it happens another time. Why?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
14,814
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Does shutdown work with FireWire card installed, but without any FireWire devices attached?

Have you examined the system log from the point where shutdown begins? A kernel panic might be occurring. If so, the log might provide some hints about the panic.

Another suggestion is to try a different FireWire card (three of them are mentioned at the end of the Designare build guide). If it also fails, you may return it if purchased from a reputable retailer.
 
Joined
Jun 12, 2012
Messages
7
Motherboard
Gigabyte Z87X-UD5H - Kingston 16GB Ram 1600MHz
CPU
Intel Core i7 4770K 3.70GHz
Graphics
EVGA Nvidia GTX760
@CaseySJ this is the point:
1. the shutdown doesn't work with Firewire card installed (with or without my Fireface 800 connected);
2. the shutdown works well when the Firewire card is not installed.

But --

the strange thing is that when I installed the Firewire card, it was recognized by Mojave, and my Fireface800 worked flawlessly, except for the shutdown.

The FireWire card I used is a Startech you mentioned in your guide.
I've just ordered FW800 to T2 and T2 to T3 cables.
Let's see what happens...

I don’t know where to start with the system log. For this reason I've attached a screenshot for the kernel panic in post #3
If you need something let me know.
 
Last edited:
Joined
Aug 25, 2012
Messages
1,021
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
  2. Power Mac
  3. PowerBook
  4. Quadra
Mobile Phone
  1. iOS
My original Avid approved Startech FW card worked fine on my Z68 board, but not on my z170x. Reboot instead of shutdown. I swapped it for a delock card(EAN 4043619891535), and the problem was solved.
On my Z390, I've been using Startech TB3-TB2 -> Apple TB2-FW with some succes.
 
Top