Contribute
Register

iMessage not working at all -> El Capitan 10.11.1

Status
Not open for further replies.
Joined
Oct 11, 2015
Messages
35
Motherboard
ga-h97-d3h
CPU
Intel i7 4970k
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
  1. iOS
i have CONFIRMED working - following link

https://www.******.com/r/hackintosh/comments/2wohwn/getting_imessage_working_on_10102_generating/


Hello! Before I begin I just want to credit /u/johnnyfortune for their write-up here. Their instructions were mostly correct for me, but I had to add a few extra steps that I believe others will need to include as well. This may only apply to those that have never used iMessage on their machine in the past.
As for the instructions:

  1. Open CloverConfigurator and mount your EFI
  2. Open your config.plist
  3. In the Rt Variables section, make sure everything is clear.
  4. Go to the SMBIOS section and click on the magic wand. Match the specs options as best you can to your machine. On the two sections that say shake, click a few times to generate a random serial. Click ok.
  5. Go to https://selfsolve.apple.com/ and search for that serial number that was generated. If you get an error message, that is good. It means you aren't using a serial number assigned to a real Mac. If you don't get an error, repeat step 4 and search for the new serial instead.
  6. Open terminal and run "uuidgen".
  7. Copy this UUID and paste it in the "SmUUID" field in the SMBIOS section.
  8. In the "Board Serial Number" field, paste in your system serial number (the one generated by the magic wand) and add 5 random letters and numbers to the end to reach a total of 17 characters.The reason for step 7 and 8 is to keep your ROM (last 12 digits of the UUID that was generated) and MLB (Board Serial Number) values constant and unique on each boot of the OS. If the values change from boot to boot, iMessage will notice and fail to activate and there is potential that Apple will notice and blacklist your UUID, serial, or Apple ID. All Clover-generated ROM and MLB values are automatically blacklisted, as well.
  9. Export config.plist
  10. In terminal, run the commands:
    1. defaults write com.apple.finder AppleShowAllFiles TRUE
    2. killall Finder
  11. Navigate to /Users/[Username]/Library/Chaches and delete all files or folders beginning with: (if there is nothing there with these file names, that is ok)
    1. com.apple.Messages
    2. com.apple.imfoundation.IMRemoteURLConnectionAgent
  12. Navigate to /Users/[Username]/Library/Preferences and delete all files or folders beginning with: (if there is nothing there with these file names, that is ok)
    1. com.apple.iChat.
    2. com.apple.imagent.
    3. com.apple.imessage.
    4. com.apple.imservice.
  13. Navigate to /Users/[Username]/Library and delete the folder "Messages"(if there is nothing there with that file name, that is ok).
  14. Empty the trash. If it says files are still in use, reboot and empty it immediately upon startup.
  15. Open up Disk Utility, select your OSX partition, and rebuild the permissions. Reboot when this is completed.
  16. The moment of truth: open up iMessage and attempt to sign in. It worked for me on the first try.
  17. If it worked, you can re-hide hidden files and folders with the terminal commands:
    1. defaults write com.apple.finder AppleShowAllFiles FALSE
    2. killall Finder
Feel free to ask me any questions! I hope this is helpful.
Edit: As some users have pointed out, your primary network must be set as en0. You can check this by opening up System Profiler, clicking on either Ethernet or Wifi and making sure that your internet network is listed as en0. If it is not, reset your network preferences by going to /Library/Preferences/SystemConfiguration and deleting "NetworkInterfaces.plist" and "preferences.plist".
 
Joined
Nov 13, 2015
Messages
1
Motherboard
GA-H97M-D3H
CPU
Haswell
Graphics
Intel HD 4600
Mac
Classic Mac
Mobile Phone
If you are on Clover, try this. It's very easy and should maybe help.

https://www.******.com/r/hackintosh/comments/2wohwn/getting_imessage_working_on_10102_generating/

Thanks a lot!! It works also for me!! :headbang: :thumbup:
 
Joined
Mar 7, 2016
Messages
28
Motherboard
Asus Z170A
CPU
Intel i7 6700
Graphics
1070TI
If you are on Clover, try this. It's very easy and should maybe help.

https://www.******.com/r/hackintosh/comments/2wohwn/getting_imessage_working_on_10102_generating/


this helped a lot :)
 
Joined
Nov 11, 2013
Messages
77
Graphics
Intel hd 4000
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
I'm on 10.11.4 follow the guide but it didn't work...delete all the files/ doesn't work ...im using clover
 
Joined
Nov 11, 2013
Messages
77
Graphics
Intel hd 4000
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
In the "Board Serial Number" field, paste in your system serial number (the one generated by the magic wand) and add 5 random letters and numbers to the end to reach a total of 17 characters.


should i copy and paste my serial number to "board serial number" then add 5 random numbers and letters?and how do i rebuild permission by disk utility?

MEl0wjZ.png
 
Joined
Aug 11, 2011
Messages
3
Motherboard
Asus P8P67 Deluxe
CPU
i7-2600K
Graphics
GTX 760
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
If you are on Clover, try this. It's very easy and should maybe help.

https://www.******.com/r/hackintosh/comments/2wohwn/getting_imessage_working_on_10102_generating/


I had the problem where I could log into iMessage, but everything I tried said "Not registered with iMessage" and would turn red. This link worked for me too on the first try! I did not have to call Apple at any point. Thanks!!
 
Joined
Nov 11, 2013
Messages
77
Graphics
Intel hd 4000
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
I had the problem where I could log into iMessage, but everything I tried said "Not registered with iMessage" and would turn red. This link worked for me too on the first try! I did not have to call Apple at any point. Thanks!!
el capitan 10.11.4?
 
Joined
Dec 10, 2012
Messages
6
Motherboard
WIN 7
CPU
Six Core AMD
Graphics
Integrated
Mac
Classic Mac
Mobile Phone
No go for me either. If I try to use the aforementioned "fix" I get a completely unbootable machine. Even comparing the two and adding into the second what is in my original doesn't change it. Could it be my DSDT not agreeing with the plist.config file?
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,115
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Status
Not open for further replies.
Top