Contribute
Register

imessage facetime

Joined
Aug 9, 2017
Messages
10
Motherboard
Gigabyte G1 Gaming GA-Z170X Gaming 7
CPU
Intel Core i7 - 7700K Kaby Lake Quad-Core 4.2Ghz
Mac
MacBook Pro
Mobile Phone
iOS
Hey guys,

So I got hackintosh sierra on my rig I got icloud to work but for whatever reason. iMessage and Facetime refuse to work.


Below is my clover configurator.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DSDT</key>
<dict>
<key>Debug</key>
<false/>
<key>DropOEM_DSM</key>
<false/>
<key>Fixes</key>
<dict>
<key>AddDTGP</key>
<false/>
<key>AddHDMI</key>
<false/>
<key>AddIMEI</key>
<false/>
<key>AddMCHC</key>
<false/>
<key>AddPNLF</key>
<false/>
<key>DeleteUnused</key>
<false/>
<key>FakeLPC</key>
<false/>
<key>FixACST</key>
<false/>
<key>FixADP1</key>
<false/>
<key>FixAirport</key>
<false/>
<key>FixDarwin</key>
<false/>
<key>FixDisplay</key>
<false/>
<key>FixFirewire</key>
<false/>
<key>FixHDA</key>
<false/>
<key>FixHPET</key>
<false/>
<key>FixIDE</key>
<false/>
<key>FixIPIC</key>
<false/>
<key>FixIntelGfx</key>
<false/>
<key>FixLAN</key>
<true/>
<key>FixRTC</key>
<false/>
<key>FixRegions</key>
<false/>
<key>FixS3D</key>
<false/>
<key>FixSATA</key>
<false/>
<key>FixSBUS</key>
<false/>
<key>FixShutdown</key>
<true/>
<key>FixUSB</key>
<false/>
</dict>
<key>Name</key>
<string>DSDT.aml</string>
<key>ReuseFFFF</key>
<false/>
</dict>
<key>HaltEnabler</key>
<false/>
<key>SSDT</key>
<dict>
<key>DropOem</key>
<false/>
<key>Generate</key>
<dict>
<key>CStates</key>
<false/>
<key>PStates</key>
<false/>
</dict>
</dict>
</dict>
<key>Boot</key>
<dict>
<key>Arguments</key>
<string>dart=0 nvda_drv=1 -disablegfxfirmware</string>
<key>DefaultVolume</key>
<string>SSD 1TB</string>
<key>Fast</key>
<true/>
<key>Log</key>
<true/>
<key>Secure</key>
<false/>
<key>XMPDetection</key>
<string>Yes</string>
</dict>
<key>Devices</key>
<dict>
<key>Audio</key>
<dict>
<key>Inject</key>
<integer>1</integer>
</dict>
<key>FakeID</key>
<dict>
<key>ATI</key>
<string>0x0</string>
<key>IMEI</key>
<string>0x0</string>
<key>IntelGFX</key>
<string>0x0</string>
<key>LAN</key>
<string>0x0</string>
<key>NVidia</key>
<string>0x0</string>
<key>SATA</key>
<string>0x0</string>
<key>WIFI</key>
<string>0x0</string>
<key>XHCI</key>
<string>0x0</string>
</dict>
<key>USB</key>
<dict>
<key>FixOwnership</key>
<false/>
<key>Inject</key>
<false/>
</dict>
<key>UseIntelHDMI</key>
<false/>
</dict>
<key>DisableDrivers</key>
<array>
<string>Nothing</string>
</array>
<key>GUI</key>
<dict>
<key>Hide</key>
<array>
<string>\EFI\BOOT\BOOTX64.EFI</string>
<string>Windows</string>
</array>
<key>Language</key>
<string>en:0</string>
<key>Mouse</key>
<dict>
<key>Enabled</key>
<true/>
<key>Speed</key>
<integer>8</integer>
</dict>
<key>Scan</key>
<dict>
<key>Entries</key>
<true/>
<key>Legacy</key>
<false/>
<key>Linux</key>
<true/>
<key>Tool</key>
<false/>
</dict>
<key>ScreenResolution</key>
<string>1920x1080</string>
<key>Theme</key>
<string>tonymacx86</string>
</dict>
<key>Graphics</key>
<dict>
<key>Inject</key>
<dict>
<key>ATI</key>
<false/>
<key>Intel</key>
<true/>
<key>NVidia</key>
<false/>
</dict>
</dict>
<key>KernelAndKextPatches</key>
<dict>
<key>#FakeCPUID</key>
<string>0x010676</string>
<key>AppleIntelCPUPM</key>
<true/>
<key>AppleRTC</key>
<true/>
<key>KernelCpu</key>
<false/>
<key>KernelLapic</key>
<false/>
<key>KernelPm</key>
<true/>
<key>KernelXCPM</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
RXh0ZXJuYWw=
</data>
<key>InfoPlistPatch</key>
<false/>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>
SW50ZXJuYWw=
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 20 in XHCI kext (9-series)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g710////EA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.12.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g710////FQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 26 in XHCI kext (100-series)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g710////EA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.12.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g710////Gw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 30 in XHCI kext (200-series)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g710////EA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.12.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g710////Hw==
</data>
</dict>
</array>
</dict>
<key>RtVariables</key>
<dict>
<key>BooterConfig</key>
<string>0x28</string>
<key>CsrActiveConfig</key>
<string>0x3</string>
<key>MLB</key>
<string>D25PW04PF8JCASDFG</string>
<key>ROM</key>
<data>
wMs4OPfw
</data>
</dict>
<key>SMBIOS</key>
<dict>
<key>BiosReleaseDate</key>
<string>12/19/2018</string>
<key>BiosVendor</key>
<string>Apple Inc.</string>
<key>BiosVersion</key>
<string>IM142.88Z.F000.B00.1812191208</string>
<key>Board-ID</key>
<string>Mac-27ADBB7B4CEE8E61</string>
<key>BoardManufacturer</key>
<string>Apple Inc.</string>
<key>BoardSerialNumber</key>
<string>D25PW04PF8JCASDFG</string>
<key>BoardType</key>
<integer>10</integer>
<key>BoardVersion</key>
<string>1.0</string>
<key>ChassisAssetTag</key>
<string>iMac-Aluminum</string>
<key>ChassisManufacturer</key>
<string>Apple Inc.</string>
<key>ChassisType</key>
<string>0x0D</string>
<key>EfiVersion</key>
<string>134.0.0.0.0</string>
<key>Family</key>
<string>iMac</string>
<key>FirmwareFeatures</key>
<string>0xE00FE137</string>
<key>FirmwareFeaturesMask</key>
<string>0xFF1FFF3F</string>
<key>LocationInChassis</key>
<string>Part Component</string>
<key>Manufacturer</key>
<string>Apple Inc.</string>
<key>Mobile</key>
<false/>
<key>PlatformFeature</key>
<string>0x01</string>
<key>ProductName</key>
<string>iMac14,2</string>
<key>SerialNumber</key>
<string>D25PW04PF8JC</string>
<key>SmUUID</key>
<string>F07B3986-A56E-4E2A-ABE2-DCEA32D37174</string>
<key>Version</key>
<string>1.0</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>Yes</string>
<key>InjectSystemID</key>
<true/>
<key>NvidiaWeb</key>
<true/>
</dict>
</dict>
</plist>
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
2,164
Motherboard
Gigabyte Z370M D3H
CPU
i3-8350K
Graphics
RX 560
Mac
iMac, Mac mini
Classic Mac
eMac, iBook
Mobile Phone
iOS
Hey guys,

So I got hackintosh sierra on my rig I got icloud to work but for whatever reason. iMessage and Facetime refuse to work.


Below is my clover configurator.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DSDT</key>
<dict>
<key>Debug</key>
<false/>
<key>DropOEM_DSM</key>
<false/>
<key>Fixes</key>
<dict>
<key>AddDTGP</key>
<false/>
<key>AddHDMI</key>
<false/>
<key>AddIMEI</key>
<false/>
<key>AddMCHC</key>
<false/>
<key>AddPNLF</key>
<false/>
<key>DeleteUnused</key>
<false/>
<key>FakeLPC</key>
<false/>
<key>FixACST</key>
<false/>
<key>FixADP1</key>
<false/>
<key>FixAirport</key>
<false/>
<key>FixDarwin</key>
<false/>
<key>FixDisplay</key>
<false/>
<key>FixFirewire</key>
<false/>
<key>FixHDA</key>
<false/>
<key>FixHPET</key>
<false/>
<key>FixIDE</key>
<false/>
<key>FixIPIC</key>
<false/>
<key>FixIntelGfx</key>
<false/>
<key>FixLAN</key>
<true/>
<key>FixRTC</key>
<false/>
<key>FixRegions</key>
<false/>
<key>FixS3D</key>
<false/>
<key>FixSATA</key>
<false/>
<key>FixSBUS</key>
<false/>
<key>FixShutdown</key>
<true/>
<key>FixUSB</key>
<false/>
</dict>
<key>Name</key>
<string>DSDT.aml</string>
<key>ReuseFFFF</key>
<false/>
</dict>
<key>HaltEnabler</key>
<false/>
<key>SSDT</key>
<dict>
<key>DropOem</key>
<false/>
<key>Generate</key>
<dict>
<key>CStates</key>
<false/>
<key>PStates</key>
<false/>
</dict>
</dict>
</dict>
<key>Boot</key>
<dict>
<key>Arguments</key>
<string>dart=0 nvda_drv=1 -disablegfxfirmware</string>
<key>DefaultVolume</key>
<string>SSD 1TB</string>
<key>Fast</key>
<true/>
<key>Log</key>
<true/>
<key>Secure</key>
<false/>
<key>XMPDetection</key>
<string>Yes</string>
</dict>
<key>Devices</key>
<dict>
<key>Audio</key>
<dict>
<key>Inject</key>
<integer>1</integer>
</dict>
<key>FakeID</key>
<dict>
<key>ATI</key>
<string>0x0</string>
<key>IMEI</key>
<string>0x0</string>
<key>IntelGFX</key>
<string>0x0</string>
<key>LAN</key>
<string>0x0</string>
<key>NVidia</key>
<string>0x0</string>
<key>SATA</key>
<string>0x0</string>
<key>WIFI</key>
<string>0x0</string>
<key>XHCI</key>
<string>0x0</string>
</dict>
<key>USB</key>
<dict>
<key>FixOwnership</key>
<false/>
<key>Inject</key>
<false/>
</dict>
<key>UseIntelHDMI</key>
<false/>
</dict>
<key>DisableDrivers</key>
<array>
<string>Nothing</string>
</array>
<key>GUI</key>
<dict>
<key>Hide</key>
<array>
<string>\EFI\BOOT\BOOTX64.EFI</string>
<string>Windows</string>
</array>
<key>Language</key>
<string>en:0</string>
<key>Mouse</key>
<dict>
<key>Enabled</key>
<true/>
<key>Speed</key>
<integer>8</integer>
</dict>
<key>Scan</key>
<dict>
<key>Entries</key>
<true/>
<key>Legacy</key>
<false/>
<key>Linux</key>
<true/>
<key>Tool</key>
<false/>
</dict>
<key>ScreenResolution</key>
<string>1920x1080</string>
<key>Theme</key>
<string>tonymacx86</string>
</dict>
<key>Graphics</key>
<dict>
<key>Inject</key>
<dict>
<key>ATI</key>
<false/>
<key>Intel</key>
<true/>
<key>NVidia</key>
<false/>
</dict>
</dict>
<key>KernelAndKextPatches</key>
<dict>
<key>#FakeCPUID</key>
<string>0x010676</string>
<key>AppleIntelCPUPM</key>
<true/>
<key>AppleRTC</key>
<true/>
<key>KernelCpu</key>
<false/>
<key>KernelLapic</key>
<false/>
<key>KernelPm</key>
<true/>
<key>KernelXCPM</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
RXh0ZXJuYWw=
</data>
<key>InfoPlistPatch</key>
<false/>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>
SW50ZXJuYWw=
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 20 in XHCI kext (9-series)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g710////EA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.12.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g710////FQ==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 26 in XHCI kext (100-series)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g710////EA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.12.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g710////Gw==
</data>
</dict>
<dict>
<key>Comment</key>
<string>change 15 port limit to 30 in XHCI kext (200-series)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g710////EA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.12.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>
g710////Hw==
</data>
</dict>
</array>
</dict>
<key>RtVariables</key>
<dict>
<key>BooterConfig</key>
<string>0x28</string>
<key>CsrActiveConfig</key>
<string>0x3</string>
<key>MLB</key>
<string>D25PW04PF8JCASDFG</string>
<key>ROM</key>
<data>
wMs4OPfw
</data>
</dict>
<key>SMBIOS</key>
<dict>
<key>BiosReleaseDate</key>
<string>12/19/2018</string>
<key>BiosVendor</key>
<string>Apple Inc.</string>
<key>BiosVersion</key>
<string>IM142.88Z.F000.B00.1812191208</string>
<key>Board-ID</key>
<string>Mac-27ADBB7B4CEE8E61</string>
<key>BoardManufacturer</key>
<string>Apple Inc.</string>
<key>BoardSerialNumber</key>
<string>D25PW04PF8JCASDFG</string>
<key>BoardType</key>
<integer>10</integer>
<key>BoardVersion</key>
<string>1.0</string>
<key>ChassisAssetTag</key>
<string>iMac-Aluminum</string>
<key>ChassisManufacturer</key>
<string>Apple Inc.</string>
<key>ChassisType</key>
<string>0x0D</string>
<key>EfiVersion</key>
<string>134.0.0.0.0</string>
<key>Family</key>
<string>iMac</string>
<key>FirmwareFeatures</key>
<string>0xE00FE137</string>
<key>FirmwareFeaturesMask</key>
<string>0xFF1FFF3F</string>
<key>LocationInChassis</key>
<string>Part Component</string>
<key>Manufacturer</key>
<string>Apple Inc.</string>
<key>Mobile</key>
<false/>
<key>PlatformFeature</key>
<string>0x01</string>
<key>ProductName</key>
<string>iMac14,2</string>
<key>SerialNumber</key>
<string>D25PW04PF8JC</string>
<key>SmUUID</key>
<string>F07B3986-A56E-4E2A-ABE2-DCEA32D37174</string>
<key>Version</key>
<string>1.0</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>Yes</string>
<key>InjectSystemID</key>
<true/>
<key>NvidiaWeb</key>
<true/>
</dict>
</dict>
</plist>
Hi there,

Check out:

https://www.tonymacx86.com/threads/an-idiots-guide-to-imessage.196827/

That covers most things.

:)
 
Joined
Mar 17, 2018
Messages
87
Motherboard
ASUS ROG Maximus XI Hero (Wi-Fi)
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro
Mobile Phone
iOS
This guide really is quite amazing!

Also, if that doesn't work, it might have to do with your 15 port limit for USB in MacOS. Sometimes, if you haven't made a working SSDT for the port limit, the USB 2.0 header on your motherboard (that you've plugged your bluetooth into from your wifi/bluetooth adapter) won't work properly, thus giving you all kinds of issues with bluetooth looking as if it's working, but it really isn't because you can't actually connect anything bluetooth up to your computer.

To solve this, you can follow Rehabman's guide, or this amazing guide by Utterdisbelief:


I hope this helps!

-Kyle

Edit: I forgot to mention that working wifi and bluetooth is necessary to get most apps like iMessage and Facetime to work.
 
Top