Contribute
Register

iMessage doesn't work

Joined
May 31, 2016
Messages
154
Motherboard
Thinkpad X240
CPU
i5-4300U
Graphics
HD4400
Mobile Phone
Android
i have very carefully followed
https://www.tonymacx86.com/threads/an-idiots-guide-to-imessage.196827/
and
http://www.tonymacx86.com/threads/how-to-fix-imessage.110471/
more than 10 times, but without a success. Errors are always the same:
Screen Shot 2018-08-11 at 2.28.24 PM.png
i have tried my account with rMBP, it works, i think my account isn't in blacklist. Other accounts don't work on hackintosh either.
What did i check about my system:
Build-in Ethernet
Screen Shot 2018-08-11 at 2.38.15 PM.png
native support for NVRAM:
nvram -p | grep Hello
TestVar HelloWorld

What did i do every time:
1. check 'Find my phone' at www.icloud.com, remove any devices, sign out
2. sign out iCloud in MacOS, turn off wifi
3. clean iMessage caches completely
4. generate new SMBIOS information, new Serial/Board Serial Number with Clover Configurator, ROM dropdown list select UseMacAddr0, MLB box is empty
5. check Serial Number in EveryMac with phone/another computer
6. check Serial Number in https://checkcoverage.apple.com with phone/another computer
7. run uuidgen 10 times and use last uuid in smuuid, save
8. restart + run iMessageDebug twice, all datas are same.
9. turn on wifi and sign in iMessage with no hope.
 
Joined
May 31, 2016
Messages
154
Motherboard
Thinkpad X240
CPU
i5-4300U
Graphics
HD4400
Mobile Phone
Android
I think i have done all things right...
 
Joined
May 31, 2016
Messages
154
Motherboard
Thinkpad X240
CPU
i5-4300U
Graphics
HD4400
Mobile Phone
Android
Updated: I tried after 24 hours to reconnect network and login again, no hope.
So... i gave up and decided to use real Mac values.
It turns out that it works immediately. I get the email that my iMessage Account is signed in a new Mac, which i hadn't before until now. My iCloud account has no devices until now, too.
So i'm quite doubting that Apple can now easily knowing which Serial Number/MLB/ROM is generated and never register it.
But it doesn't mean that i will use the real Mac value tomorrow or later. it's just a test. I still want this problem to be solved.:)
 
Last edited:
Joined
May 31, 2016
Messages
154
Motherboard
Thinkpad X240
CPU
i5-4300U
Graphics
HD4400
Mobile Phone
Android
So it confirms that my hardware/account isn't a problem, which is very helpful
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,241
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
MacBook Air
Mobile Phone
iOS
So it confirms that my hardware/account isn't a problem, which is very helpful
Inject custom ROM/MLB values. Also use a unique SmUUID.
 
Joined
May 31, 2016
Messages
154
Motherboard
Thinkpad X240
CPU
i5-4300U
Graphics
HD4400
Mobile Phone
Android
Just an example:

Code:
**********************iMessage Debug**********************
Credits: ElNono, mdmwii,flux84, sugarface, pokenguyen


              Model: MacBookAir6,2
           Board-id: Mac-7DF21CB3ED6977E5
       SerialNumber: C02ND2TJF5V7
      Hardware UUID: 4094825F-0518-57F2-9BEE-44F787E08BB0

          System-ID: C04CE6B8-A417-4777-8E7D-A26905874701
                ROM: 68f7283df96a
  BoardSerialNumber: C02437500CDF64VJC

         Gq3489ugfi: d8cfc3781f5e52198f1d780983348a1332
          Fyp98tpgj: 9b010a41dcb638877aa12bf360cc262195
         kbjfrfpoJU: cf0fd1a3aa0c6c315824381a6db6f1322a
       oycqAZloTNDm: 4cccc058a6dad19f9774a721a9975c2eec
       abKPld1EcMni: 7e5354b62a2a58e04fb511157d9269a2ed
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,241
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
MacBook Air
Mobile Phone
iOS
Attach "Problem Reportin" files requested in the FAQ.
 
Top