Contribute
Register

iMac Pro X99 - Live the Future now with macOS 10.14 Mojave [Successful Build/Extended Guide]

Status
Not open for further replies.

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,620
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
Joined
Mar 7, 2013
Messages
103
Motherboard
GA-X99M-Gaming 5
CPU
i7-5820K
Graphics
RX560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hello,
I can't seem to get xcpm working. Terminal command {sysctl machdep.xcpm.mode} keeps coming back with 0.
Also using IOregistry isn't showing any CP00@0 . anyhelp would be great.
 
Joined
Oct 7, 2016
Messages
24
Motherboard
X99 Taichi
CPU
i7-6800K
Graphics
RX580
Hi @amgclk65,

can you please upload your EFI folder here so that we can check it?

Thank you
 
Joined
Mar 7, 2013
Messages
103
Motherboard
GA-X99M-Gaming 5
CPU
i7-5820K
Graphics
RX560
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hi @amgclk65,

can you please upload your EFI folder here so that we can check it?

Thank you
I sure can, Also I just noticed I was using PMDrvr.kext under 10.13 to provide power management.
I didn't transfer that kext over to my 10.14 build. I tried the kext under 10.14. It appears to be working via intel app.
Now no sleep. Which I'm aware of the kext killing sleep. Is there a way for power management without kext?
 

Attachments

Last edited:
Joined
Aug 3, 2018
Messages
1
Motherboard
Asus X99 Deluxe II
CPU
i7-5820K
Graphics
2X GTX 980
Hi,
This is my first hackintosh build and I'm a little lost with the SSDT part. I'd like to get things like bluetooth and ethernet working and I've got IORegistryExplorer and the SSDT opened in MaciASL, I'm just not sure on how to actually implement the various patches.

Other than the above (and nvidia not supporting their drivers yet) everything else seems to be working okay. However, I am having the same issue with xcpm as the guy above.

Any help would be appreciated!
 

kgp

Retired
Joined
May 30, 2014
Messages
6,902
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Hi,
This is my first hackintosh build and I'm a little lost with the SSDT part. I'd like to get things like bluetooth and ethernet working and I've got IORegistryExplorer and the SSDT opened in MaciASL, I'm just not sure on how to actually implement the various patches.

Other than the above (and nvidia not supporting their drivers yet) everything else seems to be working okay. However, I am having the same issue with xcpm as the guy above.

Any help would be appreciated!
For SSDT adaptation, see example in post #4806...
 
Joined
Oct 7, 2016
Messages
24
Motherboard
X99 Taichi
CPU
i7-6800K
Graphics
RX580
I'm running 10.14 Beta (18A347e). Under 10.13, the PMdrvr.kext works wonders.
OK, I had a look a your EFI folder.
First, you don't need WhateverGreen.kext any more. The Radeon RX cards are now natively working.

For XPCM, please verify the following BIOS settings:
  • Advanced\CPU Configuration\CPU Power Management Configuration\
  • Enhanced Intel SpeedStep Technology (EIST): Disabled
  • Turbo mode: Enabled
  • CPU C-State: Enabled
  • Enhanced C1 State: Enabled
  • CPU C3 Report: Enabled
  • CPU C6 Report: Enabled
  • Package C State Limit: C6(non Retention) state
I haven't found any other errors in your EFI so far, but I solved many of my problems (I had also problems with CPU speed and XCPM) with reinstalling macOS from the recovery partition. If you don't format your drive, this doesn't delete any data or settings, but it refreshes the system. I solved many problems with this method.

Best regards
 
  • Like
Reactions: kgp
Status
Not open for further replies.
Top