Contribute
Register

iMac Pro X299 - Live the Future now with macOS 10.14 Mojave [Successful Build/Extended Guide]

Status
Not open for further replies.

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
GC-Alpine Ridge Thunderbolt 3 with X299-WU8





I made this patch & SSDT for X299 with Alpine Ridge


Comment PC01 -> PCI1 patch for GC-Alpine Ridge By N.Mano
Find 50433031
Replace 50434931

Apply this patched with your clover config turn off your pc.
Connect your thunderbolt devices and USB -C devices
Now start your system.
XXXXX
Without this patch -sleep worked
With patch-Alpine Ridge worked


Hi, my friend!

I don't get the point.

The attached SSDT just performs a few DSM cosmetical corrections and introduces an Apple like TB ACPI device naming, but else does not even add the necessary HotPlug capable entries neither under DSB0 and nor DSB2, thus it is not even a HotPlug SSDT injector.

Else I do not understand why a simple PC01 -> PCI1 replacement should affect the overall system sleep/wake functionality, while all your other SSDT ACPI replacements anyway do only apply in case of your particular motherboard and PCIe slot population. The global PC01 -> PCI1 replacement anyway also affects all other PCIe devices and respective SSDTs attributed to PC01.

No idea what this is all for.

Nevertheless, good luck and enjoy,

KGP
 
Joined
Oct 12, 2010
Messages
730
Motherboard
X299-WU8
CPU
i9-9880XE
Graphics
Vega 64
Mac
  1. iMac
  2. Mac Pro
Hi, my friend!

I don't get the point.

The attached SSDT just performs a few DSM cosmetical corrections and introduces an Apple like TB ACPI device naming, but else does not even add the necessary HotPlug capable entries neither under DSB0 and nor DSB2, thus it is not even a HotPlug SSDT injector.

Else I do not understand why a simple PC01 -> PCI1 replacement should affect the overall system sleep/wake functionality, while all your other SSDT ACPI replacements anyway do only apply in case of your particular motherboard and PCIe slot population. The global PC01 -> PCI1 replacement anyway also affects all other PCIe devices and respective SSDTs attributed to PC01.

No idea what this is all for.

Nevertheless, good luck and enjoy,

KGP
With hotplug SSDT Alpine ridge not work my system.
Device PC01 Alpine Ridge not work.
Thanks.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
it seems to me that you did not remember the important part of my message that the performance depends on the temperature ... regarding the tone and the way of addressing, how would you like to talk about something that is wrong? to boast somehow? ... it seems you did not get the idea ... and to stay quiet I did not use anything you got posted here ... you do not even know how deep I dug ... anyway I see you have accepted that the presence of the id in WEG can influence many ...

Hmmm...

Temps have not been wrong in my former personal VII system configuration, but they might now be wrong after your recent modifications of the original WEG source code distribution, while nobody knows so far if those changes have been complete or adequate in any case, as you also resist in asking @VIT9696 to account for a correct VII consideration within the current WEG source code distribution.

Moreover, are you using at all the respective HWSensor kexts in my original 10.14.5 EFI-Folder distribution or about which GPU Temps are we talking about actually?

I fully understood your current results about a WEG dependent VII performance and I also understood that you think that the yet partly too low VII performance is due to GPU temperature issues, while I think that the latter is mainly due to lacking optimisations of the current BETA VII macOS implementation and in particular also of the current Geekbench distribution.

However, as I do not know what you exactly do, use or dig into at the moment (how could I?), it might be better not to comment on anything your are posting here actually.

I tried to establish some common approach to interpret, think and deal with your current findings in line with respective personal suggestions, although I am afraid that there might not exist any really common base in addressing or exchanging things or information between us.

Thus, the only thing I am able to do for now seems to wish you best luck in all your respective endeavours.

KGP
 
Last edited:

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
With hotplug SSDT Alpine ridge not work my system.
Device PC01 Alpine Ridge not work.
Thanks.

I see several flaws in your current ACPI replacements. Could you please upload an IOREG.save after booting your system without your attached TB SSDT in your EFI-Folder?

Thanks.

Edit: Which other PCIe devices do you actually have under PC01.BR1A.SL01?

Is the former SSDT-X299-SL01-FRWR-XHC2.aml I wrote for XHC2 and your firewire adapter still valid or did you properly adapt the latter SSDT after like moving your firewire adapter to a different PCIe slot?

This anyway is the correct SSDT, where the entire TB stuff must go to. And this SSDT also contains the correct PC01.BR1A.SL01 -> PEGP-> EGP3.EGP4 and EGP5 replacements!
 
Last edited:
Joined
Feb 16, 2012
Messages
358
Motherboard
Z690 Gaming X
CPU
i9-12900K
Graphics
RX560
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
My system is i9 9900x, Gigabyte x299 Master, with Quadro P1000 & P4000. 64gb ram. I have tried many procedures to install Mojave in my system. But no progress. Please help me, what should i do. I have attached my configuration.
Did you use any additional Clover entries to run i9 9900X?
 

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
@nmano,

after inspecting the IOREG.save you attached above, the entire PC01.BR1A ACPI table seems totally messed up after all recent changes you apparently introduced to the EFI-Folder distribution, I originally provided for your system.

Better provide an IOREG.save without any SSDT in your EFI-Folder on boot, please do not change your PCIe slot population in the meanwhile, and please also remove any additional config.plist ACPI replacements you introduced subsequently.

No idea why you guys come up with all that stuff on a Sunday afternoon/night, where at least me I am used to dedicate my time to other things than to Hackintosh systems.

Thus, any necessary modifications from my side, next week, ok?

Cheers,

KGP
 
Last edited:

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Did you use any additional Clover entries to run i9 9900X?

@Akibkhanpostcircle,

did you actually ensure that the microcodes of your recent Gigabyte X299 Master BIOS firmware actually support the i9-9900X?

@ori69, never heard about any necessity of additional Clover entries for the i9-9XXX series..
 
Last edited:
Joined
Oct 12, 2010
Messages
730
Motherboard
X299-WU8
CPU
i9-9880XE
Graphics
Vega 64
Mac
  1. iMac
  2. Mac Pro
@nmano,

after inspecting the IOREG.save you attached above, the entire PC01.BR1A ACPI table seems totally messed up after all recent changes you apparently introduced to the EFI-Folder distribution, I originally provided for your system.

Better provide an IOREG.save without any SSDT in your EFI-Folder on boot, please do not change your PCIe slot population in the meanwhile, and please also remove any additional config.plist ACPI replacements you introduced subsequently.

No idea why you guys come up with all that stuff on a Sunday afternoon/night, where at least me I am used to dedicate my time to other things than to Hackintosh systems.

Thus, any necessary modifications from my side, next week, ok?

Cheers,

KGP
Hi KGP
X99 system If I install thunderbolt card show ioreg all THB Devices.
But X299 system thunderbolt card work very silent.If I connect the THB devices Its show in IOREG.If not connect not show there.
Hi friend If hot plug need any setting in bios?
 

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hi KGP
X99 system If I install thunderbolt card show ioreg all THB Devices.
But X299 system thunderbolt card work very silent.If I connect the THB devices Its show in IOREG.If not connect not show there.
Hi friend If hot plug need any setting in bios?

@nmano,

see my comments in post #2,711 and please exactly provide the information I asked for.

Don't you see that your entire PC01.BR1A.SL01 ACPI tree is messed up? All respective SSDTs for firewire, AHCI, XHC2 and TB devices need to be corrected once more and after all combined!

To make TB work, no TB SSDT is really required. TB devices would also connect without any TB SSDT, as long they are connected at boot. A wrong TB SSDT implementation can however make things worse. And your actual PC01.BR1A.SL01 SSDTs device implementations very likely also break your system's sleep/wake functionality again finally.

All devices on different PCI bridges under PC01.BR1A.SL01 MUST be considered within the SAME SSDT, which in your case always was SSDT-X299-SL01-FRWR-XHC2.aml so far.

If you do not know how to do all that properly, I can help you in any case. But please don't distribute instructions or SSDTs like

I made this patch & SSDT for X299 with Alpine Ridge
Comment PC01 -> PCI1 patch for GC-Alpine Ridge By N.Mano
Find 50433031
Replace 50434931
Apply this patched with your clover config turn off your pc.
Connect your thunderbolt devices and USB -C devices
Now start your system.
XXXXX


to the community or at least here in this thread. Such comments force me to act immediately and to even work on a Sunday just to keep this thread consistent at least.

Thanks in advance,

KGP
 
Last edited:
Joined
Oct 12, 2010
Messages
730
Motherboard
X299-WU8
CPU
i9-9880XE
Graphics
Vega 64
Mac
  1. iMac
  2. Mac Pro
@nmano,

see my comments in post #2,711 and please exactly provide the information I asked for.

Don't you see that your entire PC01.BR1A.SL01 ACPI tree is messed up? All respective SSDTs for firewire, AHCI, XHC2 and TB devices need to be corrected once more and after all combined!

To make TB work, no TB SSDT is really required. TB devices would also connect without any TB SSDT, as long they are connected at boot. A wrong TB SSDT implementation can however make things worse. And your actual PC01.BR1A.SL01 SSDTs device implementations very likely also break your system's sleep/wake functionality again finally.

All devices on different PCI bridges under PC01.BR1A.SL01 MUST be considered within the SAME SSDT, which in your case always was SSDT-X299-SL01-FRWR-XHC2.aml so far.

If you do not know how to do all that properly, I can help you in any case. But please don't distribute instructions or SSDTs like

I made this patch & SSDT for X299 with Alpine Ridge
Comment PC01 -> PCI1 patch for GC-Alpine Ridge By N.Mano
Find 50433031
Replace 50434931
Apply this patched with your clover config turn off your pc.
Connect your thunderbolt devices and USB -C devices
Now start your system.
XXXXX


to the community or at least here in this thread. Such comments force me to act immediately and to even work on a Sunday just to keep this thread consistent at least.

Thanks in advance,

KGP
Thanks KGP
I remove patch Can you look this ioreg
Can you make SSDT for Alpine Ridge I will test
Thank you.
 

Attachments

  • navaratnam’s iMac Pro (2) with PC01.ioreg
    8.3 MB · Views: 49
Status
Not open for further replies.
Top