Contribute
Register

iMac Pro X299 - Live the Future now with macOS 10.14 Mojave [Successful Build/Extended Guide]

Status
Not open for further replies.

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
ok ... I understand your position ...
I'm sorry if you are upset or indisposed by my insistence ... you're right ... I'm wrong for reasons of excitement ... sorry once again

My friend, I am not upset or indisposed because of your further insistence. The opposite is the case. Please don't get me wrong. Any discussion, as long it is constructive, precise, documented, polite and inoffensive, is also in my interest and I guess also in the interest of all others.

As it was important that @vincek8s confirmed your initial statement of a missing Radeon VII device ID/Radeon VII implementation in the current WEG source code distribution, it was also important that you now demonstrate that there are some Geekbench score improvements, after adding at least the Radeon VII device ID to the current WEG source code distribution. Yet we do not know all other implications of your recent modification and if there would be still missing something else to be added or considered in the actual WEG source code distribution for a correct WEG Radeon VII consideration.

I really think that @VIT9696 is the best suited person to properly implement the VII within the WEG source code distribution. That's why I think that you should better address your findings and anything related directly to him and respective WEG threads than continuing here with a discussion, which is likely of minor importance for the respective Radeon VII community.

Be once more ensured in having my personal interest and support in your actual endeavour, although I do not know how to provide further active help by myself, as I do not have anymore any VII at the moment for respective testing purposes.

I hope this sufficiently clarifies the current situation and personal point of view from my side.

And please don't feel bad because of any personal excitements we all use to have in any case and certain situations :thumbup:

All the best,

KGP
 
Last edited:

corint1

Suspended
Joined
Aug 16, 2017
Messages
417
Motherboard
ASUS MAXIMUS X HERO WI-FI AC
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. Mac mini
Mobile Phone
  1. iOS
is this fine ?
or is there room for the better? I set everything to the maximum



Screenshot 2019-04-11 at 03.11.56.png
 

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
is this fine ?
or is there room for the better? I set everything to the maximum



View attachment 399150

Yes it looks fine, but I don't know if there is still room for better. You have double Valley scores I used to have for the VII on my X99 system without any VII ID in WEG (although under 3360x1418 full screen resolution). In contrary, your actual Geekbench scores of 180.000 in your other post are still just slightly above those currently obtained with a Vega 64 under 10.14.5, whereas the Geekbench software might require some separate update anyway, as also Vega 64 Geekbench scores are much better under 10.14.4, while one also finds better Cinebench and Luxmark Scores for the Vega 64 under 10.14.5.

Although your current results already look very promising, I would still ask @Vit9696, if WEG needs further modifications for fully considering all necessary changes with respect to a full VII consideration. And an official, fully VII compatible WEG version would be a nice thing to have anyway, the sooner the better after your recent findings.

Else, the VII macOS performance anyway will further improve during the 10.14.5 beta development.
 
Last edited:
Joined
Dec 31, 2013
Messages
797
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
Hi everyone.
I'm having a strange issue with more than one HDD connected through USB.
These hard disks are formatted with MBR / HFS+.
Basically they start copying and then error 36 appears and the HDD becomes unusable.
Mojave 10.14.4.
The same HDD has been used successfully on a MacBook Pro.
Does anyone have a clue what's going on here?
 
Joined
Dec 7, 2017
Messages
133
Motherboard
MSI H81M-P33
CPU
i5-4670
Graphics
GTX 750
Mobile Phone
  1. Android
Hi everyone.
I'm having a strange issue with more than one HDD connected through USB.
These hard disks are formatted with MBR / HFS+.
Basically they start copying and then error 36 appears and the HDD becomes unusable.
Mojave 10.14.4.
The same HDD has been used successfully on a MacBook Pro.
Does anyone have a clue what's going on here?

For external USB drives that are readable & writable in both macOS & Windows, try using the exFAT format.
However, an exFAT drive won't be boot enabled, AFAIK.
If using an HFS+ drive format (& exclusively with macOS), then also use the GPT partition table, instead of the older MBR.
 
Joined
Jul 16, 2011
Messages
11
Motherboard
Asus X299 Deluxe
CPU
i9-9900X
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
How do you think that your current USB configuration should ever work such? Did you carefully read the corresponding section of my guide?

You are using the fully implemented XHC USB kext with all 20 ports (you did not drop any ports as incorrectly stated above) but have all USB port limit patches disabled, thus only 15 HS/SS ports are allowed by macOS, all SSPx ports apart from SSP1 are dropped in consequence and all respective USB3.0 connectors except one fail to work.

Either enable the port limit patches or use the 15-port XHC USB kext I attached below!

Good luck,

KGP

Side comment: Your SSDT implementation is a mess. E.g., what for you implement SSDT-X299-ACQU.aml, SSDT-X299-P2EI0G-2T.aml, SSDT-X299-X540-T1.aml? Are you really using all 3 different 10GB NICs on your system and also why do you use VegaTab_56.kext instead of a properly adapted SSDT-X299-Vega56.aml and WEG.kext anyway? Other SSDTs like SSDT-X299-ARPT.aml and SSDT-X299-TB3HP.aml have been properly adopted to your hardware and PCIe slot population? Do you use any BT/WIFI and TB adapters at all? If not also drop respective SSDTs not required for your system!

Good luck,

KGP


Hi @kgp,

Oh my goodness, thanks so much for your help. I certainly didn't mean to incorrectly say I'd done something, I did indeed misread your initial post. Thank you so much for taking the time to actually format the USB kext for me, I get it now and it's working. This is my first hackintosh so a lot of this is still very new to me.

I am using the ASUS TBEX 3 adapter so have kept TB3HP.aml in the directory but have removed all the ones you've suggested. When I was following your guide initially I was following it exactly (or at least I thought I was) so that's why I installed all those other aml files, I see what you're saying and have removed them. I am not using the 10 GBps aml's and also the OSX wifi card (I don't have wifi on this machine).

Honestly I got very confused by the graphics card setup and was reading various things online about fan speeds etc and that the tool that produced the VegaTAB_56.kext was needed. I have replaced the VegaTAB_56 with WhateverGreen and also your SSDT-X299-Vega56.aml file, I'm still not 100% sure if that's all I need to do [I suspect not]. My card is the XFX Vega 56. I have my screen connected by Display port right now and it appears to be working correctly - although I don't see anything until the Mac Login screen appears (I think that's a setting in the BIOS I need to change, which I'll experiment with).

Here is my new (hopefully improved) EFI folder, if you have 2 minutes just to look at it, again it's very much appreciated. Thank you so much for your guides, they are truly invaluable.
 

Attachments

  • EFI.zip
    35.5 MB · Views: 151

kgp

Retired
Joined
May 30, 2014
Messages
6,778
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hi @kgp,

Oh my goodness, thanks so much for your help. I certainly didn't mean to incorrectly say I'd done something, I did indeed misread your initial post. Thank you so much for taking the time to actually format the USB kext for me, I get it now and it's working. This is my first hackintosh so a lot of this is still very new to me.

I am using the ASUS TBEX 3 adapter so have kept TB3HP.aml in the directory but have removed all the ones you've suggested. When I was following your guide initially I was following it exactly (or at least I thought I was) so that's why I installed all those other aml files, I see what you're saying and have removed them. I am not using the 10 GBps aml's and also the OSX wifi card (I don't have wifi on this machine).

Honestly I got very confused by the graphics card setup and was reading various things online about fan speeds etc and that the tool that produced the VegaTAB_56.kext was needed. I have replaced the VegaTAB_56 with WhateverGreen and also your SSDT-X299-Vega56.aml file, I'm still not 100% sure if that's all I need to do [I suspect not]. My card is the XFX Vega 56. I have my screen connected by Display port right now and it appears to be working correctly - although I don't see anything until the Mac Login screen appears (I think that's a setting in the BIOS I need to change, which I'll experiment with).

Here is my new (hopefully improved) EFI folder, if you have 2 minutes just to look at it, again it's very much appreciated. Thank you so much for your guides, they are truly invaluable.

Only the EFI-Folder does not really help. Also upload IOREG.save and PCI and BIOS setting screenshots if you have time that me and others can have a look to it.

But please once more verify before that everything is really set according to the guidelines.

Good night, world
 
Joined
Dec 31, 2013
Messages
797
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
For external USB drives that are readable & writable in both macOS & Windows, try using the exFAT format.
However, an exFAT drive won't be boot enabled, AFAIK.
If using an HFS+ drive format (& exclusively with macOS), then also use the GPT partition table, instead of the older MBR.

Hi, thanks for your reply.

Sure I always do that, BUT since some people at times connect their drives (formatted the way they want) to my PC, it becomes problematic to have those drives get corrupted and be unable to copy data. There seem to possibly be an issue on a hackintosh where an original Mac would indeed work correctly even on those dodgy file systems volume format combinations.
So I'm enquiring about that.

Thanks.
 
Joined
Jun 26, 2014
Messages
111
Motherboard
ASUS Prime X299 Deluxe II
CPU
i9-9920X
Graphics
Radeon RX 6900 XT



thanks. hope the new bios also solve the Q-CODE 00 error.

my Deluxe II died and they will send me a new one next week.

btw: i get a new Radeon VII today and attach two monitors to it via DP port. in Windows system, the primary monitor flickering if you dont play game or movie/video... idle

do you guys also have the same problem?
 
Status
Not open for further replies.
Top