Contribute
Register

iconservicesagent Crashes and uses all RAM and SwapSpace

Status
Not open for further replies.
Joined
Jan 6, 2011
Messages
14
Motherboard
Aorus Master Z490
CPU
i9-10900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi, I install clean high sierra on SSD, the iconservicesagent keeps on bogging down the system while eating up all the memory in a few seconds and then filling up my OS drive (an SSD) with swap space. I can force quit it in Activity Monitor, and I need to do it several times, before I can use my Mac again.

I happen to internal and external hdd with custom icons in videos, there are not many system utilities ready for High Sierra, but deleting caches does not help anything.

With the 27-inch iMac me the same happened is a disaster!!

the solution they give me in apple care is to reinstall the system from 0, I have already done it 2 times and the problem persists, that you have made apple, you have no solution for this?

High Sierra disaster, with macos saw not the problem of ICONSERVICESAGENT

Help!!
 

Attachments

  • image.png
    image.png
    130.2 KB · Views: 446
  • image2.png
    image2.png
    157.2 KB · Views: 412
  • image3.png
    image3.png
    153.3 KB · Views: 415
Joined
Jan 6, 2011
Messages
14
Motherboard
Aorus Master Z490
CPU
i9-10900K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
It's curious, I have 2 build:

1: Mobo: Gigabyte Z97X-UD5H
CPU: i7-4790K
RAM: 32GB 2100 GHz
Graphics: Gigabyte GTX 1060 G1

2: Mobo: Z270M-D3H
CPU: i5 7600K
RAM: 16GB 2400 GHz
Graphics: EVGA GTX 750 TI

In the 1 Build I do not have the problem of the iconservicesagent crazy, its operation is correct and I use the same installer for the Build 2.
will it be by Kaby lake?

I attach my config.plist
 

Attachments

  • config.plist.zip
    4.5 KB · Views: 109
Joined
Jul 13, 2012
Messages
91
Motherboard
Ignore Me
CPU
I'm Ignoring
Graphics
Forum RULES !!!!!
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Same here, tried on 4 different computers.

MacMini bought in 2015 (HDD)
Gigabyte z77 DS3h (SSD)
Gigabyte z97 (SSD)
Asus Deluxe z170 (SSD)

I can reproduce this 100%.
Open my USB Drive with my Movie collection.
My iconserviceagent starts with 11,5 MB as soon as I open my movie collection within matter of seconds it jumps up to 500 MB, 800 MB, 1.2 GB, 2.4, 3.8, 14, 20, 35, 45 GB etc.

Only way to solve this is to force quit iconserviceagent. But it won't last, it starts adding up again. But this time force quit again and eject the USB Drive. 16 GB is enough time to force quit icon and find the hard drive to eject. On 4 GB system there is not enough time between force quit and eject. It starts freeze-jump-skip immediately.

I don't get it, I don't have 45 GB of icon pictures on the drive, if I have 200 files and each file has a 4MB icon size, it would add up to 800 MB not 45 GB. I tried this on Sierra and iconserviceagent is always stuck at 11,7 MB. Even a folder with 62 files which all have icons freeze.
 
Joined
Mar 7, 2011
Messages
8
Motherboard
GA Z87X-UD7 TH
CPU
i7 4790K
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. Android
Hi, i had the same problem. Was the old HD sata not working with Mojave. I changed the HD and all ok no more iconserviceagent.
 
Status
Not open for further replies.
Top