Contribute
Register

ICH7, SATA Drives Not Shown in DiskUtility

Joined
Jun 10, 2020
Messages
5
Motherboard
D2750
CPU
E8400
Graphics
GMA 3100
I want to install Big Sur via USB. OpenCore does not display the internal disk in Disk Utility. It is about ICH7.

I tried CtlnaAHCIPort.kext, which I adapted with my SATA-ID.
In Disk Utility, "Media Uninitialized Zero KB" is displayed.
When I try AHCIPortInjector.kext, kernel panic occurs.

Also, I tried to block the original AHCIPort.kext and apply the patch:

Name = com.apple.driver.AppleAHCIPort
Find = 40600200
Replace = 00000000
Enabled = YES

No effect.

Finally, is there a solution?
 

Attachments

  • 1.jpg
    1.jpg
    5.9 MB · Views: 18
  • 2.jpg
    2.jpg
    8.1 MB · Views: 18
  • block.jpg
    block.jpg
    70.1 KB · Views: 17
  • config_1.jpg
    config_1.jpg
    106.1 KB · Views: 14
  • config_2.jpg
    config_2.jpg
    105.6 KB · Views: 14
  •  CtlnaAHCI.png
    CtlnaAHCI.png
    52.1 KB · Views: 12
  • patch.jpg
    patch.jpg
    71.3 KB · Views: 16

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,596
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Please read and comply with the rules, in particular the one regarding profiles.
Link to profile - Just three items - Motherboard (or prebuilt system), Processor (CPU) and Graphics.
 
Joined
Jun 10, 2020
Messages
5
Motherboard
D2750
CPU
E8400
Graphics
GMA 3100
Please take a look at my profile now: is it okay?
 
Joined
Jun 10, 2020
Messages
5
Motherboard
D2750
CPU
E8400
Graphics
GMA 3100
However, Catalina 10.15.7 with Clover legacy worked.
 
Joined
Jul 21, 2019
Messages
10
Motherboard
Asus Z170-A
CPU
I5-6500
Graphics
GTX770
However, Catalina 10.15.7 with Clover legacy worked.
Hi, i am trying to install catalina on my asusP5Kpl-am, monave works fine, but the installer of catalina does not show my hard drive. Can you share with me your efi? Thanks vert much
 
Joined
Jun 10, 2020
Messages
5
Motherboard
D2750
CPU
E8400
Graphics
GMA 3100

chrisparu

You need to replace the original plugin with the one I am sending you, due to an unsuitable graphics card.

After installation, restart again from USB installer, go to Terminal and install this com.apple.telemetry.plugin on
/System/Library/UserEventPlugins /
First, rename the original com.apple.telemetry.plugin to com.apple.telemetry.plugin.bak
 

Attachments

  • com.apple.telemetry.plugin.zip
    13.9 KB · Views: 3
Last edited:
Joined
Jun 10, 2020
Messages
5
Motherboard
D2750
CPU
E8400
Graphics
GMA 3100
Hi, i am trying to install catalina on my asusP5Kpl-am, monave works fine, but the installer of catalina does not show my hard drive. Can you share with me your efi? Thanks vert much
Catalina 10.15.7 Clover EFI
 

Attachments

  • Catalina_10.15.7_Clover_EFI.zip
    13.2 MB · Views: 11
Top