Contribute
Register
Joined
Feb 27, 2017
Messages
59
Motherboard
Gigabyte Gaming 3 GA-H270
CPU
i7-7700K
Graphics
GTX 1050 Ti
Mac
iMac
I can't get iBooks to work. It comes up as a completely see through window when I open it.

I found a "solution" that didn't work on tonymac.

It said all I needed to do is use my integrated graphics.

I went to my BIOS and enabled them. set the DVTM pre-allocated to 256 and DVTM total FGX memory to MAX

booted up. The Intel 530 and the Geforce 1070 both appear in the system report now. ( previously it was just the Geforce)

when I open iBooks now instead of a clear window it is all pixelated and such. Or the system would crash. the apple icon and all finder icons become pixelated as well.( that was when I had the Pre allocated DVTM set to 64 Mb. changed it to 256Mb and I believe that helped)

the system doesn't seem stable though.

Any help would be appreciated.

TL;DR
iBooks window clear.
enabled integrated graphics.
iBooks bow pixelated. or system crashes.
 

Attachments

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
3,088
Motherboard
Gigabyte Z370M D3H
CPU
i3-8350K
Graphics
RX 560
Mac
iMac, Mac mini
Classic Mac
eMac, iBook
Mobile Phone
iOS
Hi there! :)

This is problem discussed on another thread as well:

https://www.tonymacx86.com/threads/nvidia-web-driver-ibooks-bug.203229/

Up to 15-pages now. Take a look and see if there is anything there to help.

I have been trying to solve the iBooks see-through window for some time but unfortunately have had no luck. It seems to be a conflict in the Nvidia Web-drivers.

:)
 
Joined
Apr 4, 2017
Messages
1,026
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
If you have an Intel 530/630 IGPU, you can get iBooks working with the nVidia web drivers. Thanks to @pastrychef for this!

NOTE: The BIOS settings are for Asus Gene VIII and Maximus IX HERO - adjust for your build as needed. Your mileage may vary.
  1. Re-enable the on-board graphics as per initial build. You might also want to reference Pastrychef's post here.
  2. Make sure you have moved the Rename GFX0 -> IGPU PRIOR TO the nVidia PEGP -> GFX0!!! Otherwise, you'll end up with graphics card overlap and it won't work.
  3. Set the ig-platform-id to 0x19120000. 0x19120001 will NOT work with iBooks.
  4. Reboot, and temporarily move your monitor cable to the IGPU input. - no longer necessary.
  5. In BIOS, Advanced, System Agent (SA) Configuration > Graphics (under VT-d) > Primary Display -> AUTO, and set the DVMT Prealloc to 512 (1024 will NOT work!).
  6. Save & reboot.
  7. At the present moment, iBooks will give you some icon glitches. Strangely, these seem to resolve themselves, but the Apple menu remains glitched when not selected. I think there is a fix for that somewhere...
EDIT: After a few reboots (doing other things), the Apple icon has corrected itself.
 
Last edited:
Top