Contribute
Register

<< Solved >> i9-9900K+MSI Z390 Stuck on boot

Joined
Sep 24, 2019
Messages
24
Motherboard
MSI MPG Z390
CPU
i9-9900K
Graphics
UHD 630
My the first attempt to build hackintosh. Trying to install Monterey to i9-9900K on MSI-MPG-Z390 EDGE AC (MS-7B50), but it hangs on boot proccess. Found near exact hackintosh config on github so used as it is.
Created bootable Opencore USB on Linux following official guide. The drive structure looks like that (used latest opencore 0.8.4 to create BaseSystem.dmg/)
zdownload.png


Edited config.plist and enabled logging none else changed. Then copied entire EFI to USB drive.
To use latest OPC 0.8.4 debug version added
  • BOOTx64.efi replaced in EFI/BOOT
  • OpenRuntime.efi to EFI/OC/Drivers/
  • OpenCore.efi to EFI/OC/
 

Attachments

  • EFI.zip
    4.1 MB · Views: 22
  • opencore-2022-09-13-114837.txt
    37.9 KB · Views: 13
Last edited:
Joined
Mar 2, 2014
Messages
1,596
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
First look at your EFI folder:

1. You need to add "SSDT-PLUG.aml" to your OC/ACPI folder, from the "docs" section of the OpenCore 0.8.4 Release folder.

2. Update the following kexts in OC/Kexts:
AppleALC.kext 1.6.7 -> 1.7.5
Lilu.kext 1.5.8 -> 1.6.2
VirtualSMC.kext 1.2.8 -> 1.3.0
WhateverGreen.kext 1.5.5 -> 1.6.1

3. In OC/config.plist:
In ACPI/Add: add a listing for SSDT-PLUG.aml
In Booter/Quirks: SetupVirtualMap YES -> NO
In Kernel, move Lilu.kext from second (>1) to first (>0) position.
 
Joined
Sep 24, 2019
Messages
24
Motherboard
MSI MPG Z390
CPU
i9-9900K
Graphics
UHD 630
Tried as you suggested not helped. I did clean install OPC 0.8.4 Release, used sample config.plist, updated Kexts to actual versions then since i have only iGpu available followed that guide and added lines from"iGPU as main card" in Device Properties. Anyway boot process stopping at
Code:
08:596 00:044 AAPL: #[EB.LD.OFS|OPEN!] Err(0xE) <"usr\\standalone\\OS.dmg.root_hash">
08:641 00:044 AAPL: #[EB.RH.LRH|P!] Err(0xE) <- EB.LD.LF
08:685 00:044 AAPL: #[EB.BST.FBS|!] Err(0xE) <- EB.RH.LRH
 

Attachments

  • EFI.zip
    3.9 MB · Views: 13
  • opencore-2022-09-15-071631.txt
    256 KB · Views: 12
Joined
Sep 24, 2019
Messages
24
Motherboard
MSI MPG Z390
CPU
i9-9900K
Graphics
UHD 630
All right after some googling i found that problem in CFG lock. This option should be disabled in BIOS but i don't have it, so to remove CFG limitation in Kernel ->Quirks need set AppleCpuPmCfgLock and AppleXcpmCfgLock to True
It allowed to pass above errors but boot process stuck on that one below.
IMG_20220915_120024.jpg
 

Attachments

  • EFI.zip
    3.9 MB · Views: 15
Joined
Mar 2, 2014
Messages
1,596
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
My bad leaving the external graphics in my EFI folder, sorry. Looks like you fixed that.

Looking at your latest uploaded EFI folder...

1. Your ACPI files are quite different from mine... maybe because your motherboard is an MSI and mine is a Gigabyte. Cant't comment on their validity.

2. In config.piist:
In Booter/Quirks you have DevirtualiseMmio NO, I have YES.
You have EnableWriteUnprotector YES, I have NO.
You have SyncRuntimePermssions NO, I have YES.

In DeviceProperties/Add you have more stuff than I've seen before. The format seems a bit strange to me following AAPL,ig-platform-id. But I'm certainly not an expert... a moderator should have a look at that, IMHO.

In Kernel/Quirks, you have XhciPortLimit set to YES; in Monterey that is a no-no. You don't need it anyway since you have a USBPorts.kext that delineates your desired USB ports. You should set that to NO.

In Misc/Security you have AllowSetDefault NO, I have YES. Also you have SecureBootModel set to Default (which is recommended). I have left mine at Disabled... has always worked better for me. YMMV.

In UEFI/Drivers/3/LoadEarly you have YES. Should be NO. (Also, you can delete all the listings for drivers that are not enabled. They are not in EFI/OC Drivers anyway.)
In UEFI/Quirks you have DisableSecurityPolicy YES; I have NO.

Best of luck!
 
Last edited:
Joined
Sep 24, 2019
Messages
24
Motherboard
MSI MPG Z390
CPU
i9-9900K
Graphics
UHD 630
I got it working! But i have some questions remained.

1221index.png

My steps: I made many tests enabling and disabling Quirks including the ones you have suggested.
Generated SSDs with SSDTTime from Linux LiveUSB.
Used ProperTree to add SSDs and Patches to config.plist by following this guide.

So the questions i have.
First - the MacOSX only boots if USB drive with OCR inserted. May i install it to hard drive and boots from it? I guess it done in same way as installing to USB drive but instead EFI from internal drive should be used.

Second - Audio output is not working. Probably i missed some Kexts for audio chip. Also built-in Bluetooth and Wifi not working.
At least i wish to get external Bluetooth donge dbt-122 functional and connect audio system via bluetooth. I may live without wifi as internal Network card working fine.
 

Attachments

  • EFI.zip
    3.9 MB · Views: 21

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,516
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I got it working! But i have some questions remained.

View attachment 554739
My steps: I made many tests enabling and disabling Quirks including the ones you have suggested.
Generated SSDs with SSDTTime from Linux LiveUSB.
Used ProperTree to add SSDs and Patches to config.plist by following this guide.

So the questions i have.
First - the MacOSX only boots if USB with OCR inserted. May i install it to hard drive and boots from it? I gues it done in same way as installing to USB drive but instead EFI from internal drive should be used.

Second - Audio output is not working. Gues i missed some Kexts for it. Also built-in Bluetooth and Wifi not working.
At least i wish to get external Bluetooth donge dbt-122 functional and connect audio system via bluetooth. I may live without wifi as internal Network card working fine.
should be able to replace the EFI folder from the USB EFI partition to the hard drive EFI partition
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,516
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I got it working! But i have some questions remained.

View attachment 554739
My steps: I made many tests enabling and disabling Quirks including the ones you have suggested.
Generated SSDs with SSDTTime from Linux LiveUSB.
Used ProperTree to add SSDs and Patches to config.plist by following this guide.

So the questions i have.
First - the MacOSX only boots if USB drive with OCR inserted. May i install it to hard drive and boots from it? I guess it done in same way as installing to USB drive but instead EFI from internal drive should be used.

Second - Audio output is not working. Gues i missed some Kexts for it. Also built-in Bluetooth and Wifi not working.
At least i wish to get external Bluetooth donge dbt-122 functional and connect audio system via bluetooth. I may live without wifi as internal Network card working fine.
oh, you have set all your USB ports to internal (255) that is not correct:
 
Joined
Sep 24, 2019
Messages
24
Motherboard
MSI MPG Z390
CPU
i9-9900K
Graphics
UHD 630
should be able to replace the EFI folder from the USB EFI partition to the hard drive EFI partition
Copied EFI from USB drive. Also remained that file which was on EFI /Volumes/EFI/EFI/APPLE/FIRMWARE/IM191.fd
And you right some problem with USB ports. When i booted from internal Hard Drive EFI, some USB ports became not working.
 
Top