Contribute
Register

i7-4930K - Asus Rampage IV Extreme - 32GB RAM - GTX 770 4GB [Success!!]

Joined
Jan 21, 2019
Messages
1
Well, I almost have this thing working! One problem still remains. I've successfully installed High Sierra I'm running two Geforce 670 cards in slots 1 and 4 on R4E with three monitors.

Both GPUs are recognized. They both work fine on the login screen and all of the monitors light up.

However, when I go to actually login, the screen turns black momentarily and I get kicked back to the login screen.

With only one GPU enabled, it works fine and I can login normally.

One further twist: I tried installing a web driver and with that in place, I could in fact login with both GPUs and all three screens. However, this is not a good solution because the web driver does not perform nearly as well as the built in driver. I also noticed that the first GPU seemed to be running on the web driver while the second gpu was using the built-in driver!

I've since purged the web driver and so I'm back to being stuck with a fully working login screen running on both GPUs, but unable to actually login without getting kicked back to this screen.

Any insight appreciated!

Ken
 

Attachments

Joined
Aug 1, 2014
Messages
9
Motherboard
Asus X79 deluxe
CPU
Intel core i7 4930k
Graphics
GTX 980 amp! omega
Mac
iMac
Mobile Phone
iOS
Hi,

I'm looking for some advices about installing High Sierra 10.13.6 on a Asus X-79 Deluxe / 4930K.

1/ I tried the shilohh tutorial (Clover) but I have problems :

  • Nothing for High Sierra (old tutorial)
  • Custom install on Clover USB : The Clover version is not the same anymore, so under UEFI Drivers, there is not the same options to check... And I cannot find the OSXAptioFix2dvr anymore (there is the OSXAptioFix3dvr)...
Can someone advice me? What should I check/uncheck in the new Clover versions?

Thank you very much :)

Jeff
 
Joined
Mar 1, 2014
Messages
109
Motherboard
Rampage IV Extreme X79
CPU
i7-4930K
Graphics
RX Vega 56
Mac
iMac, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
Android, iOS
And I cannot find the OSXAptioFix2dvr anymore (there is the OSXAptioFix3dvr)...
You can get OsxAptioFix2Drv-64.efi from my previous post.
 
Joined
Aug 1, 2014
Messages
9
Motherboard
Asus X79 deluxe
CPU
Intel core i7 4930k
Graphics
GTX 980 amp! omega
Mac
iMac
Mobile Phone
iOS
Joined
Mar 28, 2011
Messages
179
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
EVGA Gtx 980Ti SC+
Mobile Phone
iOS
Hi,

I'm looking for some advices about installing High Sierra 10.13.6 on a Asus X-79 Deluxe / 4930K.

1/ I tried the shilohh tutorial (Clover) but I have problems :

  • Nothing for High Sierra (old tutorial)
  • Custom install on Clover USB : The Clover version is not the same anymore, so under UEFI Drivers, there is not the same options to check... And I cannot find the OSXAptioFix2dvr anymore (there is the OSXAptioFix3dvr)...
Can someone advice me? What should I check/uncheck in the new Clover versions?

Thank you very much :)

Jeff
I don't use OSXAptioFix2dvr or 3 , I use AptioMemoryFix-64.efi work flawless.
 
Joined
Jul 16, 2010
Messages
390
Motherboard
Dell 15-3567
CPU
i3-7100U
Graphics
HD620 (1366 x 768)
Mac
Mac Pro
Mobile Phone
iOS
We still need a speedstep kext or Clover Hotpatch would anyone have the Kernel and kext section binary patching or will Shilohh's X79speedstepfix for 10.13 work in Mojave? I enabled PluginType 1 in ACPI section of Clover Config but that is not good enough still need additional fix for speed step. Is the CPUPM handled by the CPUPM kext or kernel XCPM in Mojave you know how Apple changes this in later version of macOS.

I actually have the E5-2697 v2 Ivy Bridge and I beleive I this CPU does not need the CPUPM kext patching for speedstep but what needs to be enabled in Clover config? I have PluginType enabled wonder is I need XCPM support as well for speedstep? Looks like my 12 core is stuck at 1.20GHZ.

Edited: Clover XCPM caused panic so that setting is out.

Edited: Solved, I removed PluginType 1 from Clover Config that won't work for E5-Cpu's. I re-enabled Piker SSDT Generated SSDT and speedstep starting working again, also enabled SmartUSB according to Shilohh's X79 Controlled SpeedStep Thread.


Question is which SSDTs are we to use in Shilohh's X79 package? Also not sure if we need to set CPU type hex to 0x0A01 and Bus Speed to 100000 as the thread mentions above?
 
Last edited:
Joined
Mar 28, 2011
Messages
179
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
EVGA Gtx 980Ti SC+
Mobile Phone
iOS
We still need a speedstep kext or Clover Hotpatch would anyone have the Kernel and kext section binary patching or will Shilohh's X79speedstepfix for 10.13 work in Mojave? I enabled PluginType 1 in ACPI section of Clover Config but that is not good enough still need additional fix for speed step. Is the CPUPM handled by the CPUPM kext or kernel XCPM in Mojave you know how Apple changes this in later version of macOS.

I actually have the E5-2697 v2 Ivy Bridge and I beleive I this CPU does not need the CPUPM kext patching for speedstep but what needs to be enabled in Clover config? I have PluginType enabled wonder is I need XCPM support as well for speedstep? Looks like my 12 core is stuck at 1.20GHZ.

Edited: Clover XCPM caused panic so that setting is out.

Edited: Solved, I removed PluginType 1 from Clover Config that won't work for E5-Cpu's. I re-enabled Piker SSDT Generated SSDT and speedstep starting working again, also enabled SmartUSB according to Shilohh's X79 Controlled SpeedStep Thread.


Question is which SSDTs are we to use in Shilohh's X79 package? Also not sure if we need to set CPU type hex to 0x0A01 and Bus Speed to 100000 as the thread mentions above?

I have clover patch, try.

FF0F84D3
to
FF0F85D3


0100010F84
to
0100010F85


C974140F3225FF0F00006B
to
C9EB140F3225FF0F00006B


C9740C0F3283E01F4289443B
to
C9EB0C0F3283E01F4289443B


017461
to
01EB61


3E7538
to
3E9090


7511B9
to
EB11B9

for me work flawless.
 

Attachments

Joined
Jul 16, 2010
Messages
390
Motherboard
Dell 15-3567
CPU
i3-7100U
Graphics
HD620 (1366 x 768)
Mac
Mac Pro
Mobile Phone
iOS
I have clover patch, try.

FF0F84D3
to
FF0F85D3


0100010F84
to
0100010F85


C974140F3225FF0F00006B
to
C9EB140F3225FF0F00006B


C9740C0F3283E01F4289443B
to
C9EB0C0F3283E01F4289443B


017461
to
01EB61


3E7538
to
3E9090


7511B9
to
EB11B9

for me work flawless.

According to Shiloh's post for X79 speedstep thread, the E5-2697 v2 12 core processor which is Ivy Bridge doesn't need the patching only the correct SSDT which is generated by Piker's SSDTGen application. I tried using PluginType1 instead of that SSDT in Clover config but for E5 series processor that won't work. Speedstep starting working again once I re-enabled that SSDT. I have the X79 Sabertooth motherboard in which the USB may be arranged differently so I will look over all of Shilohh's SSDT's, I know he has some for PCIe ports and not sure if his USB SSDT will work on my Motherboard.

The sleep/wake issue is related to the USB I figured that part out now have to see what AAPL setting might fix it or possibly getting the correct kexts from Rehabman's FakePCIID package combining with a USB SSDT specific to my USB hardware may help resolve the sleep/wake I am unsure, and most likely not. The non intel USB 3 sure does not help matters either and this could also be why wake from sleep is broken, other than that Mojave 10.14.3 is running flawless on my setup.
 
Last edited:
Joined
Mar 28, 2011
Messages
179
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
EVGA Gtx 980Ti SC+
Mobile Phone
iOS
According to Shiloh's post for X79 speedstep thread, the E5-2697 v2 12 core processor which is Ivy Bridge doesn't need the patching only the correct SSDT which is generated by Piker's SSDTGen application. I tried using PluginType1 instead of that SSDT in Clover config but for E5 series processor that won't work. Speedstep starting working again once I re-enabled that SSDT. I have the X79 Sabertooth motherboard in which the USB may be arranged differently so I will look over all of Shilohh's SSDT's, I know he has some for PCIe ports and not sure if his USB SSDT will work on my Motherboard.

The sleep/wake issue is related to the USB I figured that part out now have to see what AAPL setting might fix it or possibly getting the correct kexts from Rehabman's FakePCIID package combining with a USB SSDT specific to my USB hardware may help resolve the sleep/wake I am unsure, and most likely not. The non intel USB 3 sure does not help matters either and this could also be why wake from sleep is broken, other than that Mojave 10.14.3 is running flawless on my setup.
I have rampage iv formula and the p9x79, I need clover patch, ssdt and fix the dsdt for other factors like the usb.

Asus usually has msr loqued.
 
Joined
Jul 16, 2010
Messages
390
Motherboard
Dell 15-3567
CPU
i3-7100U
Graphics
HD620 (1366 x 768)
Mac
Mac Pro
Mobile Phone
iOS
I have rampage iv formula and the p9x79, I need clover patch, ssdt and fix the dsdt for other factors like the usb.

Asus usually has msr loqued.
I have the option in BIOS to lock or unlock I think the option is called CFG lock/unlock. So I don’t have to worry about it.
 
Top