i7-4930K - Asus Rampage IV Extreme - 32GB RAM - GTX 770 4GB [Success!!]

Not open for further replies.
I had a fresh install question. I've seen a few posts about it on here, but I wasn't 100% clear on how to proceed.

My current hackintosh was built in Jan 2017, is 10.11.3 (El Capitan), and I've added the rest of the hardware components to my profile. So I want to completely overhaul my system and start again using this excellent guide. I'll be using a brand new SSD but the hardware hasn't changed.

Even though I've built two machines using this guide I still don't really understand it :mrgreen: Do I need to change/erase any BIOS settings or Kext things or DSDTs (I don't know what those are exactly, but I've installed them before)? or can I just install the new SSD and start again as if it's a completely new build?

Without knowing much about your situation I think I just did a similar update. I pulled out my old boot drive, swapped in my new one, kept my BIOS settings the same but check them through the guide since it has been updated since I last used it. I installed fresh on the new drive and just followed the updated guide. This time around I was done pretty quickly, and everything seems to be working aside from the sleep/wake issue. Once I was all done I popped in my old boot drive and snagged anything I needed before wiping.

If you're talking about doing something similar, i'd suggest going with everything from scratch, there are new files, etc., for thumb drive. And yea, kexts will be on your old drive so will lose them with a new SSD. BIOS should be the same as before since it's stored on your board; but it's easy to flip through the settings while following along the guide to confirm and avoid a headache later.

This is an excellent guide, and I can vouch it works right now for Sierra. Thanks again Shiloh, amazing work.
@shilohh, thanks so much for providing these files and detailed instructions! I am using a Asus P9X79 Pro board with a 3930k and your files/kexts/config are the only way I was able to get full speed stepping and OC recognized in Sierra! However, I am having a small issue that I cannot solve and need some help.

When I use your provided config.plist file, only 40GB of my 48GB of ram are being recognized (5 out of 6 chips). Also I get some crazy results with activity monitor (see screenshot) 16TB of wired memory?!
Screen Shot 2018-07-17 at 1.23.08 AM.png

I tried manually adding memory information in the SMBIOS section of the config.plist file via text edit (the provided config.plist file would not open in Clover Configurator) but now the "About This Mac" application will not launch, and, when I open "system information" app, the memory section only says "There was an error while gathering this information". Any advice?
Last edited:
Only showing 15,99GB of wired memory is nothing to worry about, Apples own description of what it means goes as follows:
Wired Memory: Memory that can’t be compressed or paged out to your startup drive, so it must stay in RAM. The wired memory used by a process can’t be borrowed by other processes. The amount of wired memory used by an app is determined by the app's programmer.
40 of 48GB sounds like more of an issue; here are some ideas:
Perhaps one module is bad? Test the modules in smaller configurations and see if one is dead.

If they weren't bought as one set, perhaps one is incompatible with the rest? Are the modules listed as being supported by ASUS, or maybe it's a timing issue? Is there a way to see installed modules in your MB's BIOS and if so, do they all show up there?

BTW, that serial number looks like the default one, you may way to make your own as per the instructions...
Thanks for the response neofusion and the assistance, much appreciated. The wired memory show 16 terabytes not GB, which is why I freaked out. I have a separate boot drive setup from stock without shilohh's files and kexts in which wired memory shows 2 GB at boot.

As for the RAM chips, I have tested the modules and they all show up in Windows. They also all look fine in the BIOS, so I don't know what the issue is. It could be a timing thing, I'm not great at the BIOS area. In the BIOS, I tried turning off X.M.P. and used manual settings and there was no change. In my other boot that shows all chips but I had to add all the RAM via SMBIOS for it to recognize the last chip. However, on that boot, I have the system defined as iMac 14,2 where shilohh's uses Mac Pro 6,1. So maybe I need to delete the ECC RAM kext (I think it's called AppleTYMECD or something)?

And yes, I know about the serial number. I have not finished the setup yet. It is also odd that the clover config.plist file will not open in clover configurator.
Last edited:
Well, I spent all day redoing my install from scratch a few more times to see if I missed something, and I still run into this 15TB wired memory on boot. No idea why? I don't want to continue installing all my applications and transferring all my data if this is going to cause issues with my work machine. I assume After effects will not be happy not only missing 8 more GB of RAM, but seeing 15TB already wired might cause some issues. I know using a Asus P9X79 Pro is not fully supported by @shilohh files but any further help would be greatly appreciated!
Last edited:
Apologies for not reading your first post properly.

I don't have anything else to suggest but I did find another thread in the forum describing a similar problem with incorrectly reported RAM (different amounts however). What's curious is that it involves the same motherboard. No resolution sadly, but perhaps bmoag's reply can give you some ideas...

I advice against deleting the ECC kext, if that was a problem I would rather have expected kernel panics.
Last edited:
No worries at all @neofusion, just glad you took the time to try and help, very much appreciated!:D And the link was very helpful as well.

So I figured out a possible solution (which is working so far) and wanted to share (will post as well on the other link you sent too). As can be seen on my original screenshot, the wired memory was way to big and would cause strange issues with Photoshop and other "pro" software. I was able to fix it by doing the following (not sure which step fixed it exactly)

1. Updated Clover Configurator to latest version ( from version 4)
2. Added boot flag
3. Reboot (no change)
3. Cleared out all ram entries in SMBIOS Section, unchecked "Trust"
4. reboot (no change)
5. Re-added all memory details as follows
  • Channels: Triple Channel
  • Slot Count = 8
  • Re-enable "Trust"
  • Add all 6 chips individually in the memory area with slots labeled 1-6 consecutively (even though slots 2 and 7 are empty per Asus instructions on optimal memory installation for 6 chips) Size = 8192, 1600 MHz, Vendor = Kingston, Part = KHX1600C9D3/8GX, Type = DDR3, Serial = unknown (I actually put in the real serial number for the 1st RAM chip but left the rest as unknown)
  • reboot
As you can see from the screenshot attached to the bottom of this post, Activity Monitor is now showing normal Mac numbers for Wired Memory, Memory Pressure and Physical Memory. About this Mac shows all RAM even though the "empty" ram slots graphic is inaccurate. And, in the system profiler, the RAM shows as ECC: Disabled, so there is no need to worry about kernel panics and/or removing AppleTYMECD.kext. Most importantly, I am very happy :lol:

I read on another forum that syntax on the SMBIOS for RAM is very finicky, so pay attention that all information is entered as per instructions here

Screen Shot 2018-07-19 at 8.03.46 PM.png
Thanks, @neofusion, for the help and hope this helps someone else (or me) in the future.
Anybody else having difficulty getting their USB 3 ports working on Rampage IV Black? Had it working in 10.12.6 using GenericUSBXHCI.kext , but no longer working in 10.13.6. Any suggestions?
Hi all...need help with a graphics card upgrade that broke my setup. =(

I've been running Sierra (pretty sure it's at 10.12.6) with a couple of EVGA Nvidia GTX 780's just fine in my R4BE 4930.

I swapped the card in the first slot out for a Gigabyte 1070Ti. From there on out I can't get it to boot up, even with nv_disable=1 set. I just get the rapidly scrolling text errors after 5 seconds or so.

I've created a completely fresh USB install drive from the Shiloh's instructions here (ie. latest Clover, fresh config.plist, kexts, etc) , but still no go. I don't see any obvious errors in the long list scrolling by, but I'm not much of an expert with this voodoo.

I've scoured various forums but haven't found a solution yet. Most are just mentions of disabling nvidia drivers and then updating the web driver. But like I said, I can't even get it to boot with them disabled, so I'm pretty stuck.

FYI, I was able to get the card up and running in my Windows7 side after updating drivers in Windows.

One thing I've noticed is that in Clover, if I go to the Graphics Injection screen, it doesn't recognize the newer card model (it just says 'Unknown'. Not sure if that matters much, especially if I am trying to bypass the Nvidia drivers.

Is there anything I need to do on the hardware/motherboard side? Some sort of reset button, etc? I figure if Windows7 is working, then probably not.

Any help or suggestions much appreciated!
@chadfx, please update your profile (personal details) with your Motherboard, CPU and iGPU or Graphics Card(s).
The Rules said:
Profiles are mandatory so that others can assist you.
Not open for further replies.