Contribute
Register

Hyper-V and Triple Boot - KERNEL_SECURITY_CHECK_FAILURE

Status
Not open for further replies.
Joined
Jul 12, 2015
Messages
8
Motherboard
Gigabyte Z97 HD3
CPU
i5 4690K
Graphics
GTX 980
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I just encountered a strange Error, that bugged me yesterday. The back story:
My initial plan was to update my existing Hackintosh (Triple Boot with Ubuntu, Windows 10 and El Capitan) to High Sierra. I had several minor errors while updating, but in the end my Hackintosh was stable and running again on macOS High Sierra. So i thought, well, let's boot into Windows. Unfortunately, i instantly got the BSoD with Error Code "KERNEL_SECURITY_CHECK_FAILURE" and rebooted. Well, k then.
Me being annoyed by all the hassle that had been involved with the whole update situation, then decided to reset my Windows installation to an earlier state. It started. Great!
I then had to install all my previously installed Applications again, which is not a big deal imo. BUT, when i tried to install Docker, a great piece of software btw!, and therefore attempted to enable Intel Hyper-V in order to run the containers, the all so familiar Error Code came up again. So there we got the culprit. I deactivated the Hyper-V feature in the BIOS and everything worked fine again. Should have known earlier.... Nevermind. That's the reason i want to share this experience with you. Unfortunately i cannot use Docker on Windows now, which is not that big of a deal for me but hey, would be nice.
Perhaps someone has an explanation for this behavior or maybe even a solution. Feel free to ask for any further information regarding this problem.

On my old system, everything worked without errors or crashes. I didn't even touch my Windows partiton during updating. I'm curious to see, what may be the issue here :)

System Specs:
Intel Core i5 4690K @ 4,3 GHz
Gigabyte Z97-HD3
GeForce GTX 980 FE
250 GB SSD for Windows Professional on latest update
250 GB SSD for MacOS High Sierra 10.13.6
128 GB SSD for Ubuntu 16.something
All partions running in UEFI Mode with lastest Clover Installation
 
Status
Not open for further replies.
Top