Contribute
Register

HWSensors no longer work in El Capitan

Status
Not open for further replies.

nobodynose

Moderator
Joined
Sep 30, 2012
Messages
3,960
Motherboard
ASRock Z370M Pro4
CPU
i7-8700
Graphics
RX 560
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iBook
  2. iMac
  3. Quadra
Mobile Phone
  1. Android
  2. iOS
The HWSensors kexts that are used along with FakeSMC by the HWMonitor app no longer work after updating to El Capitan; HWMonitor only shows drive SMART data now (no CPU core temperatures, fan speeds, etc.). I hope they are updated sometime soon by the developer to work with El Capitan.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,595
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
The HWSensors kexts that are used along with FakeSMC by the HWMonitor app no longer work after updating to El Capitan; HWMonitor only shows drive SMART data now (no CPU core temperatures, fan speeds, etc.). I hope they are updated sometime soon by the developer to work with El Capitan.

The sensors are now acknowledged to be processor inefficient and should be discarded in favour of apps like the Intel Power Gadget.
 

nobodynose

Moderator
Joined
Sep 30, 2012
Messages
3,960
Motherboard
ASRock Z370M Pro4
CPU
i7-8700
Graphics
RX 560
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iBook
  2. iMac
  3. Quadra
Mobile Phone
  1. Android
  2. iOS
The sensors are now acknowledged to be processor inefficient and should be discarded in favour of apps like the Intel Power Gadget.

I did not know that. But I don't like Power Gadget's interface; it doesn't present the information as clearly as HWMonitor.
 
Joined
Mar 6, 2013
Messages
83
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i3-9100
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
Yeah same problem too. I thought this have something to do with FakeSMC Kext and i was messing around with those Kext and ran into trouble, so i left them with HwMonitor not working. Not even iStats seems to work in my case.
 
Joined
Jan 6, 2012
Messages
439
Motherboard
GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000
Mobile Phone
  1. iOS
Yeah same problem too. I thought this have something to do with FakeSMC Kext and i was messing around with those Kext and ran into trouble, so i left them with HwMonitor not working. Not even iStats seems to work in my case.

I had the same issue with my GA-Z77X-UP5 TH. I had to reinstall FakeSMC, HWMonitor app and sensors (plugins) from MultiBeast.

-bth
 

nobodynose

Moderator
Joined
Sep 30, 2012
Messages
3,960
Motherboard
ASRock Z370M Pro4
CPU
i7-8700
Graphics
RX 560
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iBook
  2. iMac
  3. Quadra
Mobile Phone
  1. Android
  2. iOS
I had the same issue with my GA-Z77X-UP5 TH. I had to reinstall FakeSMC, HWMonitor app and sensors (plugins) from MultiBeast.

-bth

Does yours work? I reinstalled HWSensors (latest version) from the Sourceforge site, and it still didn't work - I only got drive temperatures (via SMART).
 
Joined
Jan 28, 2013
Messages
224
Motherboard
Asrock Z370 Taichi
CPU
8700K
Graphics
AMD Fury X/Intel UHD 630
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I had the same problem. I reinstalled with version 6.18.1394 and everything works. Using El Capitan 10.11.1 and Clover 3270



HWMonitor.jpg
 

nobodynose

Moderator
Joined
Sep 30, 2012
Messages
3,960
Motherboard
ASRock Z370M Pro4
CPU
i7-8700
Graphics
RX 560
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iBook
  2. iMac
  3. Quadra
Mobile Phone
  1. Android
  2. iOS
I had the same problem. I reinstalled with version 6.18.1394 and everything works. Using El Capitan 10.11.1 and Clover 3270

When was El Cap 10.11.1 released? I thought 10.11 just came out two days ago!?
 
Joined
May 19, 2015
Messages
442
Motherboard
Asus ROG STRIX Z270G GAMING
CPU
i7-7700
Graphics
RX 560
assume you're using Clover, use the dmg (instead of the pkg) to install hwsensors app manually, and then put the kexts in the Clover kext directory (i.e., Clover/kext/10.11). i believe both the one that comes with hwsensors and the one you get from here are 6.16.1372.

remove all those kext from S/L/E (if you used the pkg install) and rebuild kernel cache.
 
Status
Not open for further replies.
Top