Contribute
Register

HWMonitor reports 127°C for Vega 56 constantly

Joined
Nov 28, 2016
Messages
19
Motherboard
MSI Z170A Gaming M5 ATX
CPU
i7-6700K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I recently upgraded my graphics card to a Sapphire Radeon RX Vega 56 Pulse 8GB and also updated to the Mojave 10.14.6. It works fine in general but I can't get any sensor readings from it. I have the following installed kexts:
AppleALC.kext
AtherosE2200Ethernet.kext
FakeSMC_ACPISensors.kext
FakeSMC_CPUSensors.kext
FakeSMC_GPUSensors.kext
FakeSMC_LPCSensors.kext
FakeSMC_SMMSensors.kext
FakeSMC.kext
Lilu.kext
NoVPAJpeg.kext
WhateverGreen.kext
HWMonitor constantly reports a temperature value of 127 which seems to be invalid. How can I get proper sensor readings? Is it possible to get more sensors like fan speed or other temperature sensors? Also I have more than 2 fans but only 2 fans are being displayed. I used to see all 4 fans (in High Sierra) but that is gone now.
Screenshot 2019-08-11 at 17.56.15.png
 
Joined
Dec 23, 2011
Messages
41
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
I have the same issue.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,293
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I have the same issue.

You should go to insanelymac site and check out Slice’s HWMonitor kexts and use his combination. I tested last year and it went from 120 - 37 degrees. If you are getting a reading of 137 C feel the backplate “carefully” of the card it will burn your fingers if it’s really that hot. It should only be warm at idle. This will confirm that the reading is incorrect.
 
Joined
Dec 23, 2011
Messages
41
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
You should go to insanelymac site and check out Slice’s HWMonitor kexts and use his combination. I tested last year and it went from 120 - 37 degrees. If you are getting a reading of 137 C feel the backplate “carefully” of the card it will burn your fingers if it’s really that hot. It should only be warm at idle. This will confirm that the reading is incorrect.

That worked. Thank you.
Here's a link to Slice's download, in case anyone is interested. (Read the readme file)
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,293
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
That worked. Thank you.
Here's a link to Slice's download, in case anyone is interested. (Read the readme file)

Nice, Slice is awesome he makes many things possible in the world of Hackintosh!
 
Joined
Nov 28, 2016
Messages
19
Motherboard
MSI Z170A Gaming M5 ATX
CPU
i7-6700K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Even after downloading and installing the latest version of HWSensors (which only installed a new copy of HWMonitor since I already have FakeSMC and the sensor kexts installed) the GPU reading is still 127°C on idle. I'm entirely confident this reading is an error since it is the maximum value of a signed byte (-128 to 127) and my GPU is currently idle. This number never changes with load. Installing this did not solve my problem.

How can I get proper sensor readings? Is it possible to get more sensors like fan speed or other temperature sensors?
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,293
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Even after downloading and installing the latest version of HWSensors (which only installed a new copy of HWMonitor since I already have FakeSMC and the sensor kexts installed) the GPU reading is still 127°C on idle. I'm entirely confident this reading is an error since it is the maximum value of a signed byte (-128 to 127) and my GPU is currently idle. This number never changes with load. Installing this did not solve my problem.

How can I get proper sensor readings? Is it possible to get more sensors like fan speed or other temperature sensors?

Slice setup requires his FakeSMCkext and other sensor Kexts. You should remove existing ones and try again.
 
Joined
Sep 24, 2016
Messages
8
Motherboard
GA-170X-UD5 TH
CPU
Intel Core i7 6700k
Graphics
Radeon RX Vega 56 8 GB
Mac
  1. iMac
Mobile Phone
  1. Android
I'm having the same problem, ended up replacing fakesmc and different types of hwmonitor and hwmonitorsmc but still 127 degree reading. somehow my system didn;t boot anymore, fixed that and now my internet isn't working.

Is there a simple way for hwmonitor and gpusensor to work properly for my system?

I ended up here after wanting to overclock my GPU, but now i'm at the point where I will leave it all alone
 
Joined
Apr 6, 2018
Messages
67
Motherboard
MSI Z370M Gaming Pro AC
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Even after downloading and installing the latest version of HWSensors (which only installed a new copy of HWMonitor since I already have FakeSMC and the sensor kexts installed) the GPU reading is still 127°C on idle. I'm entirely confident this reading is an error since it is the maximum value of a signed byte (-128 to 127) and my GPU is currently idle. This number never changes with load. Installing this did not solve my problem.

How can I get proper sensor readings? Is it possible to get more sensors like fan speed or other temperature sensors?
I had the same problem, I actually had to modify/add missing video card declarations to add Vegas. Then compiled the app myself. I have it in my computer at home. In a few hours I can upload here, but you could do this yourself if you got Xcode and time. I will post back later with the upload
 
Joined
Apr 6, 2018
Messages
67
Motherboard
MSI Z370M Gaming Pro AC
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS

Attachments

  • FAKESMC-SENSORS.zip
    143.8 KB · Views: 71
  • Screen Shot 2020-01-30 at 11.28.31 AM.png
    Screen Shot 2020-01-30 at 11.28.31 AM.png
    180.3 KB · Views: 92
Top