Contribute
Register

Huge News! Gigabyte UEFI Sleep/Wake with NO DSDT! [TESTING]

Status
Not open for further replies.
Joined
May 27, 2012
Messages
56
Motherboard
ASUS ProArt Z490-Creator
CPU
i9-10900
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
[Update]This turned out to be a faulty stick of ram as i had my 16gb set replaced and no issues so far with optimized defaults + XMP profile![/Update]

I think things are looking good now (although not the first time i thought that so still crossing fingers!). I called up the company who i brought all my parts from (except for graphics card) and the service guy recommended to me (after i explained everything i had tried) to try setting the ram voltage from 1.5v to 1.6-1.7 as he said he has to often do that with systems there to get stability. He also said if that failed they would swap the ram no worries.

1.6 didn't work for me but 1.65v seems rock solid so far. Memtest running fine, no KP's etc. I was also able to run geekbench for the first time in 64bit with ram at 1600mhz without issue (13067 - will look to OC once i've burned everything in and run stability checks for a couple of days):


http://browser.primatelabs.com/geekbench2/762392
 
Joined
Mar 23, 2011
Messages
81
Motherboard
hackintosh
CPU
3770k
Graphics
hd6870
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I have the same board, 3770k, and everything works except after the computer sleeps, either way, manually or by a timed sleep due to inactivity, upon wake up, no USB.

I have to pull out the apple keyboard USB cable and plug it back in to gain functionality.

Any ideas? :banghead:
 
Joined
Jun 2, 2012
Messages
47
Motherboard
MacPro 3.1
CPU
i5 2500K - 4.3GHz
Graphics
XFX HD 6870 1 GB
Mac
Classic Mac
Mobile Phone
Hey guys I'm having some issues with my sleep all of a sudden. I had it working perfectly before but now for some reason when I wake up from sleep my monitors don't turn on and there is no way to get back into OSX without rebooting.

The only real recent change I've had is adding a DSDT to enable proper sound with Toleda's
Interim Realtek Ivy Bridge Lion AppleHDA

Anyone else having issues?
 
Joined
Nov 11, 2011
Messages
104
Motherboard
Z97X-UD3H
CPU
i7 4790k
Graphics
RX 580
mine is working without problem, I installed attached kexts for audio
I'm using F3 bios, no DSDT... sleep/resume works

but I can't overclock, even if I overclock only to 34 multiplier, osx gives me a locked 1600 mhz. How did you overcome this problem? I installed overclock i5/i7 SSDT from Multibeast, but no luck...
 

Attachments

  • ds3h_audio.zip
    1.4 MB · Views: 77
Joined
Jun 2, 2012
Messages
47
Motherboard
MacPro 3.1
CPU
i5 2500K - 4.3GHz
Graphics
XFX HD 6870 1 GB
Mac
Classic Mac
Mobile Phone
Are you able to have sound output from all 3 outputs in the back?
 
Joined
Nov 11, 2011
Messages
104
Motherboard
Z97X-UD3H
CPU
i7 4790k
Graphics
RX 580
wh1tecastle said:
Are you able to have sound output from all 3 outputs in the back?

will try, line out is working...
 
Joined
Jun 2, 2012
Messages
47
Motherboard
MacPro 3.1
CPU
i5 2500K - 4.3GHz
Graphics
XFX HD 6870 1 GB
Mac
Classic Mac
Mobile Phone
Tried your solution, but it doesn't work for me.

If I don't use a DSDT my sleep works and my clock can go up to 4.2 Ghz, but I can't have 5.1 working.

Can anyone take a look at my DSDT and see what I need to have to make sleep and proper speed step work?
 

Attachments

  • DSDT.aml
    38.4 KB · Views: 124
Joined
Nov 11, 2011
Messages
104
Motherboard
Z97X-UD3H
CPU
i7 4790k
Graphics
RX 580
I found one bug. I installed Atheros kext by Maojl, but ethernet adapter is showing as bluetooth pan in network preferences (but acting as ethernet adapter). Anyone else have the same problem?
 
Status
Not open for further replies.
Top