Contribute
Register

HP Zhan Pro 66 G1 I7 8550U(Mac 惠普战66 PRO G1) fully working with QE/CI high Sierra 10.13.1 To 10.13.2

Joined
Oct 22, 2017
Messages
25
Motherboard
Hp Zhan 66 Pro G1
CPU
i7 8550
Graphics
Intel UHD 620+ Nvidia MX150
Mobile Phone
iOS
HP Zhan Pro 66 G1 I7 8550U(Mac 惠普战66 PRO G1) fully working with QE/CI high Sierra 10.13.1
Updated to 10.13.2 without any issues:works
Updated to 10.14.3 (18D109) without any issues:works.


HP ZHAN 66 PRO G1 i7-8550U,
Intel UHD 620+Nvidia MX150(Nvidia disabled in Bios HP),
8GB DDR4,500GB Sata HDD+256gb NVME M.2(INTEL 6000),Audio Conexant ISST Audio ,BCM BCM94352Z Wifi(Replaced)Wireless Adapter

Follow any simple guide to make Vanilla USB and install with attached efi folder in clover usb.
Things to be selected in Bios Setting

Note:-Video Memory selection to be 512Mb in bios(i tried 256,128mb but not able to boot),
Graphics with hybrid or UHD all okey.
I extracted native DSDT in 512mb Video memory bios selection and put in patched folder and worked,also patched same DSDT with some RehabMan patches to work for battery, & other things via maciasl.

Almost every things are working.
Working:-
-Nvidia disabled via DSDT SSDT patching.
-Almost every things are working well.
-Sleep/Wake working,
-Full QE/CI Working.
-Battery % Working after patching DSDT.
-APFS system and fast with trim enabled.
-Trackpad working.
-Wifi-bluetooth working(BCM94352Z).
-Native Audio working(Conexant CX8200,Codec: Intel Kabylake HDMI).
-All USB 3.0 working(USB-C:Only working USB2 speed 480mb/s)Looking for fix. Discovered its USB2.1 port only.
-Ethernet working.
-NVME SSD Intel works(Samsung 970Pro using now).
-Camera Works.
-Volume, Brightness key works with slider.
-HDMI Works with audio.
-SD Cared Reader working with
Sinetek-rtsx.kext.

Not working
HDMI works.But no hdmi sound. HDMI Audio-Video working fully.
(USB-C only working USB2 speed 480mb/s)Looking for fix. Discovered its USB2.1 port only & Working ok.
Most things working, If anything missing i am not aware yet.

Modified clover Config attached for working fixes.

Using Lilu & Whatevergreen kext.
Attached my Latest working EFI folder
 

Attachments

Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
9,082
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
HP ZHAN 66 PRO G1 i7-8550U,
Intel UHD 620+Nvidia MX150(Nvidia disabled in Bios HP),
8GB DDR4,500GB Sata HDD+256gb NVME M.2(INTEL 6000),Audio Conexant ISST Audio ,INTEL 8265 NGGF M.2+BT 4.2 Wireless Adapter

Hi i am trying to fix high sierra.
As per attached Problem & efi folder i can able to boot up high sierra with config.plist file in clover but i am not getting full QE CI.
I also tried other config but i got verbose mode some error.
My HP laptop have option to disable nvidia , video memory selection upto 512MB, i tried 64MB,128MB but still no luck.
Please help and fix my problem.
config.plist is corrupted

all kexts should be installed to system

you have OsxAptioFix2Drv-64 and OsxAptioFixDrv-64 you should only have one, try only OsxAptioFixDrv-64

also iMac17,1 is for a desktop

Read up on the FAQ first:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Link to laptop guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Oct 22, 2017
Messages
25
Motherboard
Hp Zhan 66 Pro G1
CPU
i7 8550
Graphics
Intel UHD 620+ Nvidia MX150
Mobile Phone
iOS
Thanks for reply,
i tried various config plist modification but still no luck in QE/CI.
Config plist fixed and can open in plist editor.
Kext installed to SLE.But still no luck.
Removed SMBIOS and used default Macbook air 6,2, no luck

1.config.plist i can boots up but Graphics just 7Mb.

2.Boot with config_HD615_620_630_640_650, got error as per attached picture.Geoscreenlockstate,and whole screen with some text dot dot. I can boot with safemode and graphics show 1536MB.

3.Installed BCM 94352Z NGGF WIFI it works, Bluetooth still not working.
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
9,082
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Thanks for reply,
i tried various config plist modification but still no luck in QE/CI.
Config plist fixed and can open in plist editor.
Kext installed to SLE.But still no luck.
Removed SMBIOS and used default Macbook air 6,2, no luck

1.config.plist i can boots up but Graphics just 7Mb.

2.Boot with config_HD615_620_630_640_650, got error as per attached picture.Geoscreenlockstate,and whole screen with some text dot dot. I can boot with safemode and graphics show 1536MB.

3.Installed BCM 94352Z NGGF WIFI it works, Bluetooth still not working.
config.plist still shows 17,1, thats for desktops

also your kexts are messed up according to your output, can't see evidence that you installed Fakesmc or all your other kexts to system, also a lot of unneeded kexts in clover/kexts/other, only essential kexts should be in there

also, clover will only read a config.plist named config.plist, your other plist - config_HD615_620_630_640_650 won't be read by clover
 
Joined
Oct 29, 2010
Messages
3
Motherboard
HP ENVY
CPU
i7-2860
Graphics
ATI
Mac
iMac
Classic Mac
Mobile Phone
Android
HP ZHAN 66 PRO G1 i7-8550U,
Intel UHD 620+Nvidia MX150(Nvidia disabled in Bios HP),
8GB DDR4,500GB Sata HDD+256gb NVME M.2(INTEL 6000),Audio Conexant ISST Audio ,INTEL 8265 NGGF M.2+BT 4.2 Wireless Adapter

Hi i am trying to fix high sierra.
As per attached Problem & efi folder i can able to boot up high sierra with config.plist file in clover but i am not getting full QE CI.
I also tried other config but i got verbose mode some error.
My HP laptop have option to disable nvidia , video memory selection upto 512MB, i tried 64MB,128MB but still no luck.
Please help and fix my problem.
Would you mind share your config.plist
i have the same laptop and having the same error in verbose mode

thanks
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Oct 22, 2017
Messages
25
Motherboard
Hp Zhan 66 Pro G1
CPU
i7 8550
Graphics
Intel UHD 620+ Nvidia MX150
Mobile Phone
iOS
HP Zhan Pro 66 G1 I7 8550U fully working with QE/CI high Sierra 10.13.1

Follow any simple guide to make Vanilla USB and install with attached efi folder in clover usb.
Things to be selected in Bios Setting

Note:-Video Memory selection to be 512Mb in bios(i tried 256,128mb but not able to boot),
Graphics with hybrid or UHD all okey.
I extracted native DSDT in 512mb Video memory bios selection and put in patched folder and worked,also patched same DSDT with some RehabMan patchs to work for battery, & other things via maciasl.

Almost every things are working.
Working:-
-Nvidia Spoofing visa SSDT, so no switching from bios needed.
-Almost all things are working well.
-Sleep/Wake working,
-Full QE/CI Working
-Battery % Working after patching DSDT.
-APFS system and fast with trim enabled.
-Trackpad working
-Wifi-bluetooth working(BCM94352Z)
-Native Audio working
-All usb working
-Ethernet working
-NVME SSD Intel works
-Camera Works
-Volume, Brightness key works with slider.

Attached my working EFI folder
 

Attachments

Joined
Feb 6, 2016
Messages
1
Mac
Classic Mac
Mobile Phone
HP Zhan Pro 66 G1 I7 8550U fully working with QE/CI high Sierra 10.13.1

Follow any simple guide to make Vanilla USB and install with attached efi folder in clover usb.
Things to be selected in Bios Setting

Note:-Video Memory selection to be 512Mb in bios(i tried 256,128mb but not able to boot),
Graphics with hybrid or UHD all okey.
I extracted native DSDT in 512mb Video memory bios selection and put in patched folder and worked,also patched same DSDT with some RehabMan patchs to work for battery, & other things via maciasl.

Almost every things are working.
Working:-
-Nvidia Spoofing visa SSDT, so no switching from bios needed.
-Almost all things are working well.
-Sleep/Wake working,
-Full QE/CI Working
-Battery % Working after patching DSDT.
-APFS system and fast with trim enabled.
-Trackpad working
-Wifi-bluetooth working(BCM94352Z)
-Native Audio working
-All usb working
-Ethernet working
-NVME SSD Intel works
-Camera Works
-Volume, Brightness key works with slider.

Attached my working EFI folder
Is HDMI output working now? I was think about buying this laptop just for hackintosh. Thanks.
 
Joined
Oct 22, 2017
Messages
25
Motherboard
Hp Zhan 66 Pro G1
CPU
i7 8550
Graphics
Intel UHD 620+ Nvidia MX150
Mobile Phone
iOS
Is HDMI output working now? I was think about buying this laptop just for hackintosh. Thanks.
i will check an feedback here.
Also i have successfully upgraded to Mojav too and having some minor bugs.
 
Top