Contribute
Register

HP ZBOOK G5 17

Joined
Jul 21, 2011
Messages
370
Motherboard
Zbook G5 17"
CPU
i7
Graphics
AMD WX-4170
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
My Thunderbolt 3 does not seem to work, it can only work on usb2.0, can yours work normally? It just doesn't seem to work if the TB3HP driver is loaded. Do I need to load other things?
20211101_124913.jpg
 
Last edited:
Joined
Jul 21, 2011
Messages
370
Motherboard
Zbook G5 17"
CPU
i7
Graphics
AMD WX-4170
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
I'm not sure why, but your logs don't show the debug messages, are you sure you used lilu.kext and whatevergreen.kext debug versions? (you can find in github acidantera in the releases page for these kexts the debug version), and you also need the debug flags as before.

Code:
debug=0x12a msgbuf=1048576 -wegdbg -igfxi2cdbg


The logs need to have lines that look like these:

Code:
2021-11-01 01:17:46.029584-0400 0x5e5      Default     0x0                  0      0    kernel: (Lilu) WhateverGreen      igfx: @ I2C: AdvReadI2COverAUX() Error: Failed to set the data offset.
2021-11-01 01:17:46.029587-0400 0x5e5      Default     0x0                  0      0    kernel: (Lilu) WhateverGreen      igfx: @ SC: LSPCON::probe() Error: [FB3] Failed to read the LSPCON adapter info. RV = 0xe00002d6.
2021-11-01 01:17:46.029591-0400 0x5e5      Default     0x0                  0      0    kernel: (Lilu) WhateverGreen      igfx: @ SC: fbSetupLSPCON() Error: [FB3] Failed to probe the LSPCON adapter.
2021-11-01 01:17:46.029594-0400 0x5e5      Default     0x0                  0      0    kernel: (Lilu) WhateverGreen      igfx: @ SC: fbSetupLSPCON() Error: [FB3] Abort the LSPCON driver initialization.
2021-11-01 01:17:46.029597-0400 0x5e5      Default     0x0                  0      0    kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO   ] [DPCD_Info] Getting DPCD Info Port = 0x64300, AuxPort=0x64310
2021-11-01 01:17:46.047175-0400 0x5e5      Default     0x0                  0      0    kernel: (AppleIntelCFLGraphicsFramebuffer) [IGFB][INFO   ] [DPCD_Info] Failed to read DPCD revision return 0xe00002d6

Code:
WhateverGreen      igfx: @ (DBG) framebuffer-patch-enable 1
WhateverGreen     iokit: @ (DBG) getOSData framebuffer-framebufferid was not found
WhateverGreen     iokit: @ (DBG) getOSData framebuffer-flags was not found
WhateverGreen     iokit: @ (DBG) getOSData framebuffer-camellia was not found
WhateverGreen     iokit: @ (DBG) getOSData framebuffer-mobile was not found
WhateverGreen     iokit: @ (DBG) getOSData framebuffer-pipecount was not found
WhateverGreen     iokit: @ (DBG) getOSData framebuffer-portcount has 4 value
WhateverGreen     iokit: @ (DBG) getOSData framebuffer-memorycount was not found
 
Joined
Jul 21, 2011
Messages
370
Motherboard
Zbook G5 17"
CPU
i7
Graphics
AMD WX-4170
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
NO.1
I think I solved the current problem. Both the frequency and power of the CPU are limited by the SMBIOS of the model. The default frequency and TDP of the i5 13.3 pro I originally chose are low, so there is no way to work in the I7 8750H working state. The 2020 13.3PRO I7 1068NG7 default clocked at 2.3G Boost4.1 4 cores, which is very similar to the 8750H frequency. So I chose the 13.3 Pro 2020 model, and the result was unexpected. It can work in UMA mode with single core 4.0-4.1G and multi-core 45W TDP at 3.2-3.3G, which is perfect and very happy.View attachment 532844
The best match is MacBookPro 15,1 it uses the same CPU, so I'm not sure why you want to change that. I tried your 16,2 and sustained performance was lower, maybe clock was a bit faster, but so was heat, and it isn't Mojave compatible, etc...
 
Joined
Jul 14, 2021
Messages
61
Motherboard
zbook 17 g5
CPU
i7 8750h
Graphics
hd630 p4200
The best match is MacBookPro 15,1 it uses the same CPU, so I'm not sure why you want to change that. I tried your 16,2 and sustained performance was lower, maybe clock was a bit faster, but so was heat, and it isn't Mojave compatible, etc...
I am using the Debug EC OC you provided. I will confirm again tomorrow. According to the prompt, I suspect that lilu.kext should not be the Debug version. I will revise it tomorrow.


I currently use the 16.1 i7 version and the performance is not bad. I ran the CINEBENCH R23 to achieve a performance of 8750H. Because I can connect an external monitor, if I don't have an external monitor, it is better to use the EFI of 8750H, and only use a single monitor.
 
Joined
Jul 14, 2021
Messages
61
Motherboard
zbook 17 g5
CPU
i7 8750h
Graphics
hd630 p4200
The best match is MacBookPro 15,1 it uses the same CPU, so I'm not sure why you want to change that. I tried your 16,2 and sustained performance was lower, maybe clock was a bit faster, but so was heat, and it isn't Mojave compatible, etc...
I downloaded WhateverGreen-1.5.5-DEBUG and Lilu-1.5.7-DEBUG version replacement, boot into the system and save it without the file you provided.

You can see if the OC-DEBUG guide I use is correct, I set it according to your requirements.
 

Attachments

  • test11.2.zip
    20 MB · Views: 31
  • OC-DEBUG.zip
    37.1 MB · Views: 35
Joined
Jul 14, 2021
Messages
61
Motherboard
zbook 17 g5
CPU
i7 8750h
Graphics
hd630 p4200
I'm sad, the system cannot detect the Thunderbolt 3 driver after I set it up. It recognizes Thunderbolt 3 but it doesn't work. Do I need to update the BIOS? Is my BIOS version too low? But the latest BIOS will limit TDP and voltage settings.


1.jpeg





WX20211102-082140@2x.png


WX20211102-082158@2x.png
 
Joined
Jul 21, 2011
Messages
370
Motherboard
Zbook G5 17"
CPU
i7
Graphics
AMD WX-4170
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Not sure why it doesn't work in your system, you may need to flash the newer firmware using windows. (no need to update bios)
Try device connected on boot, maybe it's just hotplug.
IOReg shows thunderbolt device tree working, so it could also be wrong SMBIOS.
And last, not all thunderbolt devices will work, drives, audio interfaces and nics, yes. but displays will most likely not. (unless you flash an apple native thunderbolt firmware to the chip)
 
Joined
Jul 14, 2021
Messages
61
Motherboard
zbook 17 g5
CPU
i7 8750h
Graphics
hd630 p4200
Not sure why it doesn't work in your system, you may need to flash the newer firmware using windows. (no need to update bios)
Try device connected on boot, maybe it's just hotplug.
IOReg shows thunderbolt device tree working, so it could also be wrong SMBIOS.
And last, not all thunderbolt devices will work, drives, audio interfaces and nics, yes. but displays will most likely not. (unless you flash an apple native thunderbolt firmware to the chip)
OK. See what else I need to do, my laptop has not been assembled yet.
 
Joined
Jul 14, 2021
Messages
61
Motherboard
zbook 17 g5
CPU
i7 8750h
Graphics
hd630 p4200
Everything in the list working on Mojave, Catalina, Big Sur and Monterey, dual GPU!!
** Updated to OC 6.9

# Specs
- CPU: Mobile HexaCore Intel Core i7-8750H, 2200 MHz
- Motherboard Hewlett-Packard HP ZBook 17 G5
- Motherboard Chipset: Intel Cannon Lake
- iGPU: Intel(R) UHD Graphics 630
- dGPU: AMD WX-4170
- Audio Adapter: Connexant CX-8400
- Thunderbolt 3 Titan Ridge 4C 2018
- WiFi: Intel(R) Dual Band Wireless-AC 9560 Jefferson Peak
- Ethernet: Intel(R) Ethernet Connection I219-LM
- RTS525A Realtek Express SDCard Reader

# Working
- AMD WX-4170 DGPU 4GB VRAM
- UHD630 with 1536MB VRAM - (2048MB in UMA mode)
- CPU, GPU and WX-4170 Power Managment
- Brightness controls (mapped to f3 and f4)
- Thunderbolt3 / USB type C data and video @4K + AppleVTD
- HDMI and Mini-DVI video @4K
- USB type A ports (2.0 & 3.0)
- Native NVRAM
- Audio - internal mic, speakers, headphone jack (+sense) and HDMI on all video outputs
- Intel Bluetooth, able to toggle on/off
- I2C ALPS trackpad w/2 button support and 5 finger gestures
- PS2 keyboard w/SSDT Brightness/Volume keys re-mapping
- Battery management
- intel WiFi up to 300mb/s
- Fan Sensors (left and right)
- Webcam
- SD Card Reader
- Gigabit Ethernet
- Sleep
- Full DRM in discrete mode (and in external displays in hybrid mode)
- File Vault

You need to download and add the Resources folder from https://dortania.github.io/OpenCore-Post-Install/cosmetic/gui.html

Then select a config.plist based on your setup and then you need to add your info for:
PlatformInfo/Generic/MLB
PlatformInfo/Generic/SystemSerialNumber
PlatformInfo/Generic/SystemUUID

-When you're done, rename it: config.plist

** WX-4170 GPU now works in Catalina/Big Sur and Monterey thanks to @EdwardGeo!! For these OS versions we need to use Hybrid config or Hybrid+Mux which is the new mode that has everything that Discrete mode plus IGPU for Intel quicksync.. (Discrete mode will stall in Catalina+ because our Bios injects it's enbedded rom which is not compatible) Will also work in UMA config.
** - Will need to flash the attached rom to your card.

* To control wifi you need to download HeliPort or you can switch to AirportItlwm (https://github.com/OpenIntelWireless)
* For DRM fixes follow this post: https://www.tonymacx86.com/threads/hp-zbook-g5-17.266012/post-2200447 or use shikigva

* I included SSDT-xNVME.aml which I use to completely disable my windows NVME drive that is not compatible with OSX and causes kernel panics if mounted read/write and also randomly at boot. I find it's more reliable than just not mounting the volume editing fstab. It needs to be enabled in the ACPI section in config.plist and adjusted to your non-compatible NVME drive path.

* Trackpad needs "Force Click" OFF in System Settings to work properly.

ACPI DMAC and DMAR tables have been updated in OC-VTD version to allow AppleVTD to load and have better Thunderbolt 3 support for devices like Apple's thunderbolt to ethernet adapter and (not tested yet) some audio interfaces.
** Bios VT-d option needs to be enabled for this feature.

Added a new low power UMA config that disables and powers OFF the (unsupported) DGPU on boot, so no more need to switch Bios mode, only IGPU will be enabled and the output mux is switched to IGPU.

Also for Thunderbolt 3 with most current HP firmware flashed, there's a Bios glitch that doesn't allow us to select "No Security" as an option. To fix it, you need to switch Thunderbolt to "Legacy Mode" in Bios/Advanced/Ports. then reboot, then go back to Bios/Advanced/Ports and under Thunderbolt security the option -No Security- appears, select it and reboot.
Now go back to Bios Setup again, and in Bios/Advanced/Ports/Thunderbolt, switch the "Legacy" option back to "Native+Low power"
You now have working TB3 ports with hot plug across all OS's

Notes:

HDMI audio should now work on external displays if using UMA mode. (Only one external video outputs will work in UMA mode if MXM card slot is populated when laptop is started with lid closed)
WX-4170 GPU needs to be flashed with the attached rom to work on Catalina / Big Sur / Monterey.

**For audio in Big Sur / Monterey you need to disable SIP and install VoodooHDA in S/L/E and rebuild kext cache.
**Bluetooth doesn't work in Monterey, need to deactivate the kext in config in order to boot.

Modified Kexts:
-CPUFriendDataProvider is specific to my CPU, will need to be modified if you have a different CPU.
-VoodooHDA info.plist is modified to only attach to the Connexant CX8400 Codec and leave the iGPU and dGPU codecs to AppleALC for HDMI hotplug function. It is also modified to automatically switch from speaker to headphone on plug insertion.
-PolarisZBook_WX4170 is custom plist kext to inject power play tables and device properties to the AMD Video driver for better power management.
-SMCSuperIO is custom built to include generic EC controller for fan support (now included in release)
-VoodooI2CHID is custom built to add 2 button support

Also attached is the VBios Rom I'm using for Mojave/Catalina since my WX-4170 MXM card came with an empty EEPROM.

--------------
*Config Discrete (IGPU=OFF, only compatible with supported MXM card and only High Sierra or Mojave)
*Config Hybrid (Both GPU's on, IGPU=LCD, DGPU external screens) Support up to Monterey w/compatible DGPU
*Config Hybrid Mux (Both GPU's on, IGPU=empty framebuffer, DGPU all screens) Same as Discrete mode but with IGPU Quicksync. Support up to Monterey w/compatible DGPU
*Config UMA (DGPU OFF, IGPU=LCD) (no need to switch Bios config, patches turn off DGPU)
--------------


Updated RealtekPCIe Card Reader now full speed native kext
Updated WX-4170 rom now working all MacOS versions since High Sierra!
Updated wifi kext to a more recent build
Updated DMAR and DMAC for TB3 VTD support.
Updated configs with Mux and DGPU power control, added Bluetoolfixup for Monterey.
Hello, I modified the settings part and updated some kext drivers on your EFI OC 0.6.9 to make OC more suitable for Mac OS12 Monterey. The Bluetooth and WIFI in the EFI you shared cannot work. The sound card I just used after my day's update test. At present, the touchpad, sound card, keyboard, camera, USB3.0 2.0, Wifi, Bluetooth, sound, etc. are all working normally. The CPU is The I7 8750H can basically work at the BIOS default 45W TDP, and the test score reaches the basic level. Choose the model 16.1 pro (Mackbook 13.3 2020 i7 1068NG7 version). If you don’t need an external dual monitor, you can modify it to 15.1 i7 8750H or the CPU version model suitable for you in OC Config.


DP can output and display, but the output port cannot be detected in the system.

Known BUG
Using your Config UMA mode, HDMI cannot work and output, and an external HDMI display is recognized, but it cannot be displayed. In the message, it has been detected that the display can be configured, and the screen is not bright.

Thunderbolt 3 cannot work, and the Thunderbolt interface works in USB2.0 mode by default.

I have just learned to configure OC for a week, and many do not understand and do not understand. If there is a mistake, I hope to help me correct it so that I can learn new knowledge.

thanks.
 

Attachments

  • MacOS MontereyOC0.6.9.zip
    22.4 MB · Views: 48
Joined
Jul 21, 2011
Messages
370
Motherboard
Zbook G5 17"
CPU
i7
Graphics
AMD WX-4170
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Hello, I modified the settings part and updated some kext drivers on your EFI OC 0.6.9 to make OC more suitable for Mac OS12 Monterey. The Bluetooth and WIFI in the EFI you shared cannot work.
Wifi works, but you need heliport or manually edit the info.plist inside the kext to add your SSID and password. Blutooth I didn't test, and my kext build are pretty old now, so you're probably right.
Known BUG
Using your Config UMA mode, HDMI cannot work and output, and an external HDMI display is recognized, but it cannot be displayed. In the message, it has been detected that the display can be configured, and the screen is not bright.
It does in my system, it could be related to your TB3 problem, since there's output sharing between ports.
Thunderbolt 3 cannot work, and the Thunderbolt interface works in USB2.0 mode by default.
Did you try to flash a newer TB3 firmware? TB3 and USBC work in my system without any problems.
OK. See what else I need to do, my laptop has not been assembled yet.
If we can't get the complete debug logs, there's no point in keeping the card out.
As a last resort, if you have a spare HDD then you can install Catalina and try again? it may be a BigSur issue.

Thank you for helping.
 
Top