Contribute
Register

HP Z620 No working USB3 Catalina 10.15.3 RehabMan's Method

Joined
Nov 8, 2014
Messages
75
Motherboard
HP Z620
CPU
E2680
Graphics
RX 5700 XT
Mac
  1. Mac Pro
Tried that, it doesn't work.
 
Joined
Dec 13, 2013
Messages
8
Motherboard
HP Z620 Workstation
CPU
2 x Intel Xeon E5-2680v2 2.80-3.60 GHz
Graphics
Sapphire Radeon RX 570 4 GB on BENQ PD3200U 4K
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
You mean that USB3 is still behaving like an "invisible USB2"?
Unfortunately, I don't think this is something fixable due to TI USB3 not having proper drivers on macOS...
I suggest to stick to USB2 for slow periperals (input devices) and buy an ASMEDIA ASM1142, ASM1543 USB 3.1 gen2 PCIe card which works OOB giving you 10 Gbps bandwidth.
Additionally, I've successfully tested and running MacPro7,1 SMBIOS on my Z620 without any issue: it gave me a little boost in performance on CPU, full H.264/HEVC HW encoding/decoding from my Rdeon RX 570 and a cool new 2019 Mac Pro icon on iCloud! ^__^
Check out HERE for further informations.

Have fun!
AC
 
Joined
Nov 8, 2014
Messages
75
Motherboard
HP Z620
CPU
E2680
Graphics
RX 5700 XT
Mac
  1. Mac Pro
You mean that USB3 is still behaving like an "invisible USB2"?
Unfortunately, I don't think this is something fixable due to TI USB3 not having proper drivers on macOS...
I suggest to stick to USB2 for slow periperals (input devices) and buy an ASMEDIA ASM1142, ASM1543 USB 3.1 gen2 PCIe card which works OOB giving you 10 Gbps bandwidth.
Additionally, I've successfully tested and running MacPro7,1 SMBIOS on my Z620 without any issue: it gave me a little boost in performance on CPU, full H.264/HEVC HW encoding/decoding from my Rdeon RX 570 and a cool new 2019 Mac Pro icon on iCloud! ^__^
Check out HERE for further informations.

Have fun!
AC
Sweet. May try the newer SMbios to see if it blesses me with any performance enhancements. Thanks.
 
Joined
May 4, 2012
Messages
8
Motherboard
Hp 8300 sff
CPU
Intel Core i5 3470 3,2 GHz 4 cores
Graphics
Nvidia msi 1050ti lp 4gb ram
Mac
  1. iMac
  2. Mac Pro
Sweet. May try the newer SMbios to see if it blesses me with
You mean that USB3 is still behaving like an "invisible USB2"?
Unfortunately, I don't think this is something fixable due to TI USB3 not having proper drivers on macOS...
I suggest to stick to USB2 for slow periperals (input devices) and buy an ASMEDIA ASM1142, ASM1543 USB 3.1 gen2 PCIe card which works OOB giving you 10 Gbps bandwidth.
Additionally, I've successfully tested and running MacPro7,1 SMBIOS on my Z620 without any issue: it gave me a little boost in performance on CPU, full H.264/HEVC HW encoding/decoding from my Rdeon RX 570 and a cool new 2019 Mac Pro icon on iCloud! ^__^
Check out HERE for further informations.

Have fun!
AC

Hi Antonio in wondering if it would be good for me to try smbios 7.1 on my z620 single cpu e-1650 v2 with a 7970 gpu ? I do not have an usb 3. Pcie card Installed yet.. so fare just working usb2 in an Catalina install with virtual smc.... working fine..

It could help me be to see you full EFI folder could you share ?

Cheers Jeppe c.
 
Joined
Dec 13, 2013
Messages
8
Motherboard
HP Z620 Workstation
CPU
2 x Intel Xeon E5-2680v2 2.80-3.60 GHz
Graphics
Sapphire Radeon RX 570 4 GB on BENQ PD3200U 4K
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
Hello Jeppe!
Start with testing your VDA decoding capabilities with Hackintool and/or VideoProc to see if SMBIOS MacPro7,1 is needed.
Integrated USB 3 is hopeless, I suggest to install a compatible USB 3.1 gen2 PCIe card.

Let us know!
AC
 
Joined
May 4, 2012
Messages
8
Motherboard
Hp 8300 sff
CPU
Intel Core i5 3470 3,2 GHz 4 cores
Graphics
Nvidia msi 1050ti lp 4gb ram
Mac
  1. iMac
  2. Mac Pro
Looks like VDA decoder failed , Hackintool image.. and I believe it’s not possible to use smbios 7,1 with that type of GPU.
image.jpg
 
Joined
Dec 13, 2013
Messages
8
Motherboard
HP Z620 Workstation
CPU
2 x Intel Xeon E5-2680v2 2.80-3.60 GHz
Graphics
Sapphire Radeon RX 570 4 GB on BENQ PD3200U 4K
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
Worth a try... ^__^
 
Joined
Jun 20, 2013
Messages
86
Motherboard
Gigabyte X299X Designare-10G
CPU
i9-10940X
Graphics
Radeon VII 16GB
-- nvm
 
Last edited:
Joined
Jan 29, 2017
Messages
27
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Sapphire Pulse RX580
Mac
  1. iMac
Mobile Phone
  1. Android
I have installed Catalina on HP Z620 (xeon E5 2620 v1 3.6GHz) with Quadro K4000. Graphics working OOB but NO H264 HEVC Acceleration or Hardware Encoding.
System Definition is Mac Pro 6,1
 
Joined
Dec 13, 2013
Messages
8
Motherboard
HP Z620 Workstation
CPU
2 x Intel Xeon E5-2680v2 2.80-3.60 GHz
Graphics
Sapphire Radeon RX 570 4 GB on BENQ PD3200U 4K
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
Top