Contribute
Register

HP Probook Installer Clover Edition

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'm studying this. Please help me to patch ACPI and install kexts for my laptop. Thank you!
I will move to the new thread.
The new guide does all ACPI patching on-the-fly (with Clover config.plist, and extra SSDTs).

Just follow the guide as written...

You may need to submit additional information, so your model 9480m can be supported directly (if you know what model it is similar to that can help too).
 
Joined
Mar 22, 2014
Messages
3
Hello,
I am confusing about my graphic:
My laptop have a graphic card name is AMD Firepro M2000(look my sign). This card is same/base like AMD Radeon 7650M.
But, After I installed HP Probook tool, My card become "AMD Radeon HD 6xxx 1024 MB" (follow guideline installation in the topic here)
How can I do to replace current to right card ?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello,
I am confusing about my graphic:
My laptop have a graphic card name is AMD Firepro M2000(look my sign). This card is same/base like AMD Radeon 7650M.
But, After I installed HP Probook tool, My card become "AMD Radeon HD 6xxx 1024 MB" (follow guideline installation in the topic here)
How can I do to replace current to right card ?
Probably just cosmetic... not important.
 
Joined
Jul 1, 2016
Messages
5
Motherboard
HP EliteBook 8470w 8GB Memory
CPU
Intel Core i7 2.69GHz 4Cores
Graphics
AMD FirePro M2000 (1 GB dedicated GDDR5 video memory)
I have an 8470w with an AMD Firepro M2000 (Radeon HD 7670M). However in Probook-Installer under "Config and DSDT patcher" -> "HP Laptop" -> "Business Model", there is only the option "8x70w nVidia".

When I choose the "8x70w nVidia" option, I can get my Hackbook to boot fine, but:
  1. I get weird flickering right after logging in, while its loading (Fix EDID, did not help).
  2. My Display Port does not work, and neither does the Display Port or DVI on the dock.
  3. In "About this Mac" -> "System Report" -> "Graphics/Displays", it shows as "Vendor: ATI" with "VRAM(Total): 5MB" (it should be 1GB).

I figure if I get the correct kext/driver/whatever installed for my GPU it will fix all the above problems?

I tried using "8x70p AMD" but it would just get stuck at some audio step patching AppleHDA
I have exactly the same laptop you have and am also facing the same problem with the video card. How did you fix this problem ?
My laptop is HP EliteBook 8470w with AMD FirePro M2000. It is detected as ATI Radeon 7650M by Clover and the system and always gives flickering problem when enabled. I have to disable on every boot to get the system to work. However, it is very slow and the display is sluggish.
Any help to fix this would be highly appreciated.
 
Joined
Jul 1, 2016
Messages
5
Motherboard
HP EliteBook 8470w 8GB Memory
CPU
Intel Core i7 2.69GHz 4Cores
Graphics
AMD FirePro M2000 (1 GB dedicated GDDR5 video memory)
Hello,
I am confusing about my graphic:
My laptop have a graphic card name is AMD Firepro M2000(look my sign). This card is same/base like AMD Radeon 7650M.
But, After I installed HP Probook tool, My card become "AMD Radeon HD 6xxx 1024 MB" (follow guideline installation in the topic here)
How can I do to replace current to right card ?
I have a similar laptop/video card to yours. Is the video card recognized and enabled by your system ? Can you please share how you got it to work ? My system is suffering from a flickering/gradient colors problem whenever the graphics card is enabled. I have a fresh Yosemite install with Clover.
 
Joined
Jul 13, 2012
Messages
30
Motherboard
Dell m6800
CPU
i7-4810MQ
Graphics
Quadro K4100m
Mac
iMac, MacBook Pro
Mobile Phone
iOS


HP Probook Installer Clover Edition 6.4.3 (September 23th)
https://bitbucket.org/dhnguyenit/hp-probook-installer-clover-edition/downloads
Download
https://bitbucket.org/dhnguyenit/hp-probook-installer-clover-edition/downloads

Changelog

Source @bitbucket

Guide to install Mavericks on HP Probook

Guide to install Yosemite on HP Probook


Troubleshooting


If you have any problems with PBI, please send me your troubleshooting files:
Run PBI CE, select Extra Tools > Troubleshooting, then compress the Troubleshooting folder on Desktop and post here.
hi tanx for your works! i am trying to install EL 10.11.5 on my EliteBook 8570W nVidia - but my touchpad not work and when i patch my dsdt using PBI my hack display going to sleep
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
hi tanx for your works! i am trying to install EL 10.11.5 on my EliteBook 8570W nVidia - but my touchpad not work and when i patch my dsdt using PBI my hack display going to sleep
Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Provide output (in Terminal):
Code:
kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc
kextstat|grep -y applehda
Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

Attach output of (in Terminal):
Code:
sudo touch /System/Library/Extensions && sudo kextcache -u /
Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
 
Joined
Jul 13, 2012
Messages
30
Motherboard
Dell m6800
CPU
i7-4810MQ
Graphics
Quadro K4100m
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Provide output (in Terminal):
Code:
kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc
kextstat|grep -y applehda
Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

Attach output of (in Terminal):
Code:
sudo touch /System/Library/Extensions && sudo kextcache -u /
Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
there @RehabMan i have attached the zip file for you
 

Attachments

Joined
Jul 13, 2012
Messages
30
Motherboard
Dell m6800
CPU
i7-4810MQ
Graphics
Quadro K4100m
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Provide output (in Terminal):
Code:
kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc
kextstat|grep -y applehda
Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

Attach output of (in Terminal):
Code:
sudo touch /System/Library/Extensions && sudo kextcache -u /
Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
dear rehab man do you have checked my problem? please
 
Joined
Mar 22, 2014
Messages
3
I have a similar laptop/video card to yours. Is the video card recognized and enabled by your system ? Can you please share how you got it to work ? My system is suffering from a flickering/gradient colors problem whenever the graphics card is enabled. I have a fresh Yosemite install with Clover.
Hi seme, Sorry my late,
Present, I installed successfully.
Version MacOSx: 10.11.5
Almost feature working well except "wake up" have a problem with screen didn't turn on.
You should install follow this topic http://www.tonymacx86.com/threads/hp-elitebook-8470p-with-amd-success-on-10-11-4-with-sleep-wake-issue.190368/

With HP probook installer:
You should follow below options:
OS X support kexts: 6x60b/8x60 AMD
DSDT patched: 6x70b/8x70p AMD
Other option you follow installation guide.

@RehabMan
With my cosmetic card name: AMD Radeon HD 6xxx 1024 MB
I changed FB name form Ebi to TyPha (because TyPha has 5 port)
And modified the ATIConnectorsPatch correctly
ATIConnectorsData: 0004000004030000000101001102040100040000040300000001020021030502000400000001000000090300100002050004000000010000000904002001030604000000140200000001050002040103
ATIConnectorsPatch: 0200000040000000090100001000000100040000040300000001020011020105000400000402000000010200210302020004000004020000000100001204030310000000100000000001000000100408
 

Attachments

Top