Contribute
Register

HP ProBook 4530s Intel HD3000m VGA port fix, Clover UEFI hotpatch

Status
Not open for further replies.
Joined
Jul 19, 2016
Messages
1
Hi, I'm just new to tonymacx86.com community, and my english is bad, sorry for mistakes.
I'm just installed 10.11.5 El Capitan on my HP ProBook 4530s LH301EA with RehabMan's Clover UEFI hotpatch guide:

http://www.tonymacx86.com/threads/g...book-using-clover-uefi-hotpatch-10-11.189416/

I'm used RehabMan's config_4x30s.plist.


ProBook 4530s.png


But i'm use MacBookPro8,1 SMBIOS ProductName because of Core i3 on my laptop.
And I saw that my Intel HD Graphics 3000 is normally identified but my VGA port not working with my LG monitor.
I fixed it for my machine but not sure it will work for you.
To fix this I'm add item to config.plist -> KernelAndKextPatches -> KextsToPatch to patch AppleIntelSNBGraphicsFB.kext to identify VGA port properly.
I took the code of patch from HP ProBook Installer 6.4.6 CE config.plist for 4530s Standard Model build, there it is:

Code:
<key>KernelAndKextPatches</key
    <dict>
         <key>KextsToPatch</key>
          <array>
            <dict>
                <key>Comment</key>
                <string>Patch VGA port HD3000</string>
                <key>Find</key>
                <data>
                AQIEABAHAAAQBwAABQMAAAIAAAAwAAAAAgUAAAAEAAAH
                AAAAAwQAAAAEAAAJAAAABAYAAAAEAAAJAAAA
                </data>
                <key>Name</key>
                <string>AppleIntelSNBGraphicsFB</string>
                <key>Replace</key>
                <data>
                AQIDABAHAAAQBwAABgIAAAABAAAJAAAABQMAAAIAAAAw
                AAAABAYAAAAIAAAJAAAAAAAAAAAAAAAAAAAA
                </data>
            </dict>
          </array>
    </dict>

config.png


Interesting that in RehabMan's config_4x30s.plist there are a patch to identify HDMI port graphics/sound but I don't know the reasons why he deleted or not added patch for VGA port.
And nguyenmac in his PBI CE recommends to disable HDMI patch if you use VGA patch and vice versa. Anyway i leaved two patches for injecting but i do not have HDMI monitor to test it. VGA is works fine. I hope this will help you.

P.S. If you patched but display is not working try in the System Preferences ->Displays hold "Option" key and click "Detect Displays" button that's appears.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi, I'm just new to tonymacx86.com community, and my english is bad, sorry for mistakes.
I'm just installed 10.11.5 El Capitan on my HP ProBook 4530s LH301EA with RehabMan's Clover UEFI hotpatch guide:

http://www.tonymacx86.com/threads/g...book-using-clover-uefi-hotpatch-10-11.189416/

I'm used RehabMan's config_4x30s.plist.


View attachment 203838

But i'm use MacBookPro8,1 SMBIOS ProductName because of Core i3 on my laptop.
And I saw that my Intel HD Graphics 3000 is normally identified but my VGA port not working with my LG monitor.
I fixed it for my machine but not sure it will work for you.
To fix this I'm add item to config.plist -> KernelAndKextPatches -> KextsToPatch to patch AppleIntelSNBGraphicsFB.kext to identify VGA port properly.
I took the code of patch from HP ProBook Installer 6.4.6 CE config.plist for 4530s Standard Model build, there it is:

Code:
<key>KernelAndKextPatches</key
    <dict>
         <key>KextsToPatch</key>
          <array>
            <dict>
                <key>Comment</key>
                <string>Patch VGA port HD3000</string>
                <key>Find</key>
                <data>
                AQIEABAHAAAQBwAABQMAAAIAAAAwAAAAAgUAAAAEAAAH
                AAAAAwQAAAAEAAAJAAAABAYAAAAEAAAJAAAA
                </data>
                <key>Name</key>
                <string>AppleIntelSNBGraphicsFB</string>
                <key>Replace</key>
                <data>
                AQIDABAHAAAQBwAABgIAAAABAAAJAAAABQMAAAIAAAAw
                AAAABAYAAAAIAAAJAAAAAAAAAAAAAAAAAAAA
                </data>
            </dict>
          </array>
    </dict>

View attachment 203837

Interesting that in RehabMan's config_4x30s.plist there are a patch to identify HDMI port graphics/sound but I don't know the reasons why he deleted or not added patch for VGA port.
And nguyenmac in his PBI CE recommends to disable HDMI patch if you use VGA patch and vice versa. Anyway i leaved two patches for injecting but i do not have HDMI monitor to test it. VGA is works fine. I hope this will help you.

P.S. If you patched but display is not working try in the System Preferences ->Displays hold "Option" key and click "Detect Displays" button that's appears.

The VGA patch is well known, but not recommended. It tends to cause problems with HDMI and the internal display.

Best to use an active HDMI->VGA adapter instead.
 
Joined
Sep 30, 2011
Messages
8
Motherboard
HP 4530s
CPU
i7-2670qm
Graphics
HD3000
Thank you. This helps.
 
Last edited:
Status
Not open for further replies.
Top