Contribute
Register

HP Pavilion dv6 6121tx 2nd gen Camera Not working.

Status
Not open for further replies.
Joined
Feb 17, 2012
Messages
156
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi Rehab,

Since Mountain Lion I had not been able to use my webcam. I don't know why but I never really cared. Now things have. I need to use webcam and trying to figure out why it does not work.

I have attached my IOREG. If you get time, please have a look.


Thanks!!
 

Attachments

  • Lubana’s MacBook Pro.zip
    1.1 MB · Views: 118

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Feb 17, 2012
Messages
156
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS

Also, see if it helps.

Usually Webcam works natively. Why it doesn't in my case?

Screen Shot 2014-11-02 at 8.48.16 PM.png
 
Joined
Feb 17, 2012
Messages
156
CPU
i5-7300HQ
Graphics
HD 630 + GTX 1050 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
From the ioreg, webcam is active on the USB bus. Try using CameraControl: http://phoboslab.org/log/2009/07/uvc-camera-control-for-mac-os-x

This doesn't help. Like I said before camera doesn't show up in system information. And sometimes console keep firing messages like "Found a Transaction which hasn't moved for 5000 milliseconds. Timing Out." or something like "Failed to enumerate a device on USB". Simultaneously IORegistryExplorer keeps repeating Camera device with red and green lines. IOREG attached for reference.
 

Attachments

  • Lubana’s MacBook Pro 2.zip
    383.7 KB · Views: 126

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
This doesn't help. Like I said before camera doesn't show up in system information. And sometimes console keep firing messages like "Found a Transaction which hasn't moved for 5000 milliseconds. Timing Out." or something like "Failed to enumerate a device on USB". Simultaneously IORegistryExplorer keeps repeating Camera device with red and green lines. IOREG attached for reference.

Seems like the camera is connecting, then disconnecting...
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Can we do something about it?

Webcam works fine under windows.

I've never seen that problem before. You definitely have some sort of USB problem. Did you apply "IRQ Fix" DSDT patch?
 
Status
Not open for further replies.
Top