Contribute
Register

HP ENVY x2 13 - After updating to Sur laptop can only be powered by AC

Joined
Mar 3, 2013
Messages
31
Motherboard
Intel Wildcat Point-LP
CPU
Core M-5Y10c [ Broadwell ]
Graphics
5300
Mac
  1. MacBook
Mobile Phone
  1. Android
As in title, after seemingly successful upgrade from fully working Catalina laptop [HP Envy x2 13] can no longer be used on battery, after the charger cable is disconnected the laptop instantly powers off [fully, which it normally doesn't do, you have to force it] no blinking standby led, nothing.
It started during the update actually, and I've hand waved it initially, it powered off during, so my uneducated guess would be that it installed a new firmware to my lappy's controller?

macOS, Windows, Linux all seem to detect that battery is present, supposed to be charging, it doesn't though and is slowly getting down from 85% [currently at 85%, takes half a day to drain 1%]

Any help, any pointers would be deeply appreciated. It is really disheartening.

clover, ioreg attached
 

Attachments

  • MacBook.iojones
    1.4 MB · Views: 8
  • Archive.zip
    1.6 MB · Views: 10
Last edited:
Joined
Mar 3, 2013
Messages
31
Motherboard
Intel Wildcat Point-LP
CPU
Core M-5Y10c [ Broadwell ]
Graphics
5300
Mac
  1. MacBook
Mobile Phone
  1. Android
It seems to be charging too. When it feels like it. Up until 85-86%. The main issue is that it doesn't switch from AC to the battery...
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,368
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
As in title, after seemingly successful upgrade from fully working Catalina laptop [HP Envy x2 13] can no longer be used on battery, after the charger cable is disconnected the laptop instantly powers off [fully, which it normally doesn't do, you have to force it] no blinking standby led, nothing.
It started during the update actually, and I've hand waved it initially, it powered off during, so my uneducated guess would be that it installed a new firmware to my lappy's controller?

macOS, Windows, Linux all seem to detect that battery is present, supposed to be charging, it doesn't though and is slowly getting down from 85% [currently at 85%, takes half a day to drain 1%]

Any help, any pointers would be deeply appreciated. It is really disheartening.

clover, ioreg attached
Have you looked into Re-flashing the bios? Disconnect drives and flash a new or the same version.
 
Joined
Mar 3, 2013
Messages
31
Motherboard
Intel Wildcat Point-LP
CPU
Core M-5Y10c [ Broadwell ]
Graphics
5300
Mac
  1. MacBook
Mobile Phone
  1. Android
Yup, already did that, tried two never versions. Didn't help.
[It's not-really a user serviceable lappy, there will be no pulling of battery or drive disconnecting]
 
Joined
Mar 3, 2013
Messages
31
Motherboard
Intel Wildcat Point-LP
CPU
Core M-5Y10c [ Broadwell ]
Graphics
5300
Mac
  1. MacBook
Mobile Phone
  1. Android
Managed to disconnect the battery, snaping my sdcard in half in the process. Got cmos reset as a bonus which scared the hell out of my as it enabled secured boot.
It changed nothing in the end, looks like my lappy is perma-semi-****ed :)

Seems like a proper ending after almost two decades of hackintoshin and this wonderful year :)
 
Joined
Mar 3, 2013
Messages
31
Motherboard
Intel Wildcat Point-LP
CPU
Core M-5Y10c [ Broadwell ]
Graphics
5300
Mac
  1. MacBook
Mobile Phone
  1. Android
Looks like it flashed firmware for MacBook 8,1, that's what I've had set in my config.plist as that's what is recommended for Broadwell.
Found it in APPLE's EFI folder
I mean, how the hell? Why it's even possible?
 

Attachments

  • APPLE.zip
    4.4 MB · Views: 8
Top